Search Support

Why won't Firefox play videos at foxnews.com?

  • 17 uphendule
  • 1 inale nkinga
  • 22 views
  • Igcine ukuphendulwa ngu cor-el

more options

Chrome can play them. Edge can play them. Why can't Firefox play videos at foxnews.com? I switched to Edge over a year ago, and just tried again, and Firefox still does not play videos at foxnews.com.

All Replies (17)

more options

I found that my ad-blocker was causing the issue.

Helpful?

more options

FredMcD said

I found that my ad-blocker was causing the issue.

It's definitely not an adblocker, or any extension causing an inability to play videos at foxnews.com. When I start Firefox with all extensions disabled, it still does not work. Hasn't worked for years. Frankly I think this behavior is suspect.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

I really didn't think starting my computer in safe mode would have any benefit. It didn't. Considering the fact that Firefox plays videos everywhere EXCEPT foxnews.com, and considering that all other browsers I've tried ARE ABLE TO PLAY videos at Fox News, the anecdotal evidence suggests that there are left-wing-nuts working at Mozilla.

Helpful?

more options

Would you see what happens when you do this :

Click on the padlock when you're on that site , click on the little black arrow next to 'Connection secure' and then at the bottom on 'More Information'. Under the Persmissons tab, scroll down to 'Autoplay', uncheck 'Use Default' and check 'Allow Audio and Video'.

Then close and restart Firefox.

Okulungisiwe ngu McCoy

Helpful?

more options

McCoy said

For me, videos on foxnews.com play, even when I disable autoplay for the site (which shouldn't happen). Would you see what happens when you do this : Click on the padlock when you're on that site , click on the little black arrow next to 'Connection secure' and then at the bottom on 'More Information'. Under the Persmissons tab, scroll down to 'Autoplay', uncheck 'Use Default' and check 'Allow Audio and Video'

I did what you suggested plus cleared all cookies for foxnews.com, restarted Firefox with plugins disabled, and I still just get the spinning circle of death. This occurs on two different computers, one connected via ethernet the other wifi.

Helpful?

more options

I just noticed that I forgot to mention that, after unchecking 'Use Default' and checking 'Allow Audio and Video', you need to close and restart Firefox (so sorry .... )

Helpful?

more options

McCoy said

I just noticed that I forgot to mention that, after unchecking 'Use Default' and checking 'Allow Audio and Video', you need to close and restart Firefox (so sorry .... )

Yes, I did restart Firefox. I told you I restarted it without plugins enabled.

Helpful?

more options

zbernie123 said

Yes, I did restart Firefox. I told you I restarted it without plugins enabled.

No, I meant close and restart after you made the change in Page Info (under the Permissions tab).

Helpful?

more options

Read my previous post:

I did what you suggested plus cleared all cookies for foxnews.com, restarted Firefox with plugins disabled, and I still just get the spinning circle of death. This occurs on two different computers, one connected via ethernet the other wifi.

Helpful?

more options

zbernie123 said

Read my previous post: I did what you suggested plus cleared all cookies for foxnews.com, restarted Firefox with plugins disabled, and I still just get the spinning circle of death. This occurs on two different computers, one connected via ethernet the other wifi.

Oh, I'm sorry - I thought you meant that you did all that before changing the setting on Page Info.

My sincere apologies.

Maybe FredMcD (or someone else) has some more ideas .......

Helpful?

more options

If you hadn't mentioned that disabling all of your extensions didn't make a difference, I would ask you to take a look at the Chosen Solution in this thread :

https://support.mozilla.org/bm/questions/1211627

But of course that can't be it, can it ?



Then I found this thread, where Refresh solved the problem :

https://support.mozilla.org/en-US/questions/1221464

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Helpful?

more options

You can check the Web Console for possible media related messages and messages about blocked content.

Helpful?

more options

cor-el said

You can check the Web Console for possible media related messages and messages about blocked content.


So Firefox is blocking the videos at foxnews.com. Every other browser I've tried plays the videos without an issue.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.segment.io/v1/t. (Reason: CORS request did not succeed).

Helpful?

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

   On Windows you can open Firefox in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
   On Mac you can open Firefox  in Safe Mode by holding the option key while starting Firefox.
   On Linux you can open Firefox  in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
   Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Okulungisiwe ngu Harindu Lakshan

Helpful?

more options

Harindu Lakshan said

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. (If you're not using it, switch to the Default theme.) On Windows you can open Firefox in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut. On Mac you can open Firefox in Safe Mode by holding the option key while starting Firefox. On Linux you can open Firefox in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Read the thread I've already tried safe mode and other solutions which did not work either. Evidently Mozilla is blocking videos at foxnews.com.

Helpful?

more options

Are there other (error) messages in the Web Console ?

Can you attach a screenshot ?

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.