Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't use discrete GPU since 74.0 ?

  • 5 uphendule
  • 1 inale nkinga
  • 2143 views
  • Igcine ukuphendulwa ngu jdashg

more options

Firefox used to cause a switch to the discrete GPU in my MacBookPro whenever I opened certain sites (such as those containing webapps that require WebGL - bestforpuzzles.com ) I monitor the switch using the app gfxCardStatus.

This switch is not happening anymore, apparently since Firefox was updated to 74.0 on March 13 2020. It's not a major problem, but the WebGL games stutter, for example. I cannot make Firefox to switch to discrete GPU no matter what site I open.

Safari causes switching to discrete GPU. Chrome switches to discrete GPU, but it's always off or on. I have Firefox 65 in a different volume containing Sierra, in the same Mac. That Firefox causes GPU switching as usual.

Was there a change in 74.0 that would prevent GPU switching? Or is it due to something else?

Okulungisiwe ngu JohnTake

Isisombululo esikhethiwe

sounds like this was a bug shipped with 74

https://bugzilla.mozilla.org/show_bug.cgi?id=1579984

a user suggests this potential fix:

go to about:config and adjust webgl.default-low-power to false and see if that fixes it for now.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Isisombululo Esikhethiwe

sounds like this was a bug shipped with 74

https://bugzilla.mozilla.org/show_bug.cgi?id=1579984

a user suggests this potential fix:

go to about:config and adjust webgl.default-low-power to false and see if that fixes it for now.

more options

Thank you Eve. Setting webgl.default-low-power to false brings back the old familiar behavior.

more options

Chrome has the same behavior as Firefox 74 as of Chrome 80 (currently Release): https://www.khronos.org/webgl/public-mailing-list/public_webgl/1912/msg00001.php If you're seeing different behavior in Firefox 74 and Chrome 80, can you please file a bug? :)

more options

jdashg,

I currently have Chrome 80.0.3987.149. In Chrome, when I turn on "Use hardware acceleration when available", graphics switches immediately to the discrete GPU. Switch back to integrated GPU never happens.

With Firefox 74, switch to discrete GPU never happens. "Use hardware acceleration when available" has always been enabled. In Firefox 74, when I set webgl.default-low-power to False, Firefox switches between the discrete and the integrated GPU dynamically. This is the behavior I had seen before 74.

So, Firefox doesn't behave the same as Chrome - at least in my MacbookPro setup.

Is Chrome 80 designed to switch dynamically? My Chrome 80 doesn't. Isn't it desirable to have dynamic switching?

I wouldn't know where to begin to file a bug. And I don't really know what the bug is...

A wrench in the mix? : I have the MacBookPro that is prone to kernel panics when graphics switch occurs. I applied the fix from GitHub that apparently limits use of highest power graphics state. Still, switches to the discrete GPU does occur.

more options

Interesting! I too have a MacBook Pro, and switching works as I described! Hmm... On http://jdashg.github.io/misc/webgl/low-power.html I get the following on Firefox, Firefox Nightly, Chrome, and Chrome Canary:

{"powerPreference":"low-power"}

 => Intel Iris Pro OpenGL Engine

{}

 => Intel Iris Pro OpenGL Engine

{"powerPreference":"high-performance"}

 => NVIDIA GeForce GT 750M OpenGL Engine

What are you getting from that page? If email is easier, I'm jgilbert@mozilla.com.