Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox inresponsive after dragging link to file browser

more options

hello, i have an exotic, but easily reproducable hang-up (no crash, process and window still exist, but UI gets inresponsive, also the close-window-x in top right window corner stops working and active downloads don't continue) when dragging a link from firefox 74.0 (64-bit) on windows 10 to my favourite file browser "total commander". i use this link dragging almost everyday, dragging the lock symbol from the url entry line to a folder in my file browser. this always worked and stopped since updating firefox to 74.0.

now the really weird stuff: when i drag the link to a explorer window (i mean the windows file browser), it works. when i drag a link first to explorer and then the same link from firefox to total commander it works. when i drag a link that i never dragged to explorer to total commander, firefox UI becomes inresponsive, downloads hang, i can't change tabs or even click the close-windows-x. i can only quit firefox by right-clicking its icon in the windows task bar and select quit firefox there. even more interesting: when firefox is then quit, the .url file has been successfully created in the folder where i dragged it. also on resuming firefox, all tabs are successfully restored to where i just left it.

summary: my work flow: i drag a link using the lock icon in firefox to my file browser to store the url in a ".url" file. explorer works. total command not. this bug probably got introduced in firefox 74 (i didn't update total commander recently).

i hope you can reproduce this bug (total commander is free for testing at ). it might not hit many users, but it hits me several times per day.

All Replies (1)

more options

Hi robert135

Have you tried filing a support request in the Total Command forum?

I would try that first.