Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get URL autocomplete (in the address bar) to work again?

more options

I am not sure what I did (other than upgrade to the latest version of Firefox), but the autocomplete URLs doesn't work any more for new websites (autocomplete works for some older websites). I have reinstalled, refreshed settings and restarted my computer (and also ensured that the browser autofill (about:config urlb) is set to "true").

I am not sure what I may have done, or if it is associated with the upgrade... Any assistance would be greatly appreciated,

All Replies (8)

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

I removed the places. and favicons.sqlite and restarted.

The files were correctly rebuilt, but still no joy...

Any other recommendations?

more options

I am thinking that I might have pushed a key combination by mistake or not set something correct in the preferences...

But I don't see where I may have mis-configured...

more options

Hello brian.fischer,

In case you use bookmarks; would you please read this ghacks
article (especially the last part) and see if maybe this applies to you :

https://www.ghacks.net/2018/09/10/firefox-not-auto-completing-bookmarks-thats-a-bug/

more options

Thank you, McCoy -- unfortunately, that is not the problem (though it is an interesting bug / feature).

The lack of autocompletion is mostly around recently visited (but not bookmarked) sites.

As I said, I think it stopped working when updating to 73.0.1 last week (or maybe a bit before that)

more options

Quick update -- I downgraded to v72.0.2 and the URL autocomplete works.

I upgraded again and autocomplete is now working in 73.0.1.

I will try reloading my bookmarks, etc.

more options

brian.fischer said

Quick update -- I downgraded to v72.0.2 and the URL autocomplete works.
I upgraded again and autocomplete is now working in 73.0.1.

So far so good .....

I will try reloading my bookmarks, etc.

Let us know how that went, will you please ?

more options

Hi, all-

I decided NOT to reload my old information (applications, bookmarks, etc.), just in case there was something wrong with them.

I have added some new bookmarks and everything appears to be work as expected and as normal.

I wonder what happened!

In any event, thank you all for your help.

Kind regards,

Brian