X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Isithangami Sabeseki

Upgraded from Firefox ESR 52.9 (winxp) to win7 and lost all passwords

Kuphostiwe

Have FF ver 73.0.1 64 bit installed now on 64 bit win 7, I have profile from the winxp/FF 52.9 ESR setup I used to use, can copy all of old profile files they are unchanged, logins and passwords are not recovered in new installation, but oddly bookmarks are ok. If I use menu entry to open "logins and passwords", there are 0 entries. If I open logins.json, I see entries . Further, if I view about:protections and scroll to bottom of page, it indicates there are 124 saved passwords.

I can reboot to the old winxp system (a different HD) and all of my passwords/logins are still there. (Note: have copied everything to a much larger HD before installing win7 then using PCMover to move all programs to win7). So...., my profile is saved/intact from the ESR 52.9 setup. I have tried all kinds of tips/suggestions, recopying entire profle (all files), copying just logins.json key3.db files, toggling signon.importedFromSqlite setting to false, uninstalling/reinstalling latest FF, it just seems there is some bug where FF does not recognize the logins properly. I did NOT use a master password on the old winxp/ESR setup. Any suggestions? Thanks in advance.

Have FF ver 73.0.1 64 bit installed now on 64 bit win 7, I have profile from the winxp/FF 52.9 ESR setup I used to use, can copy all of old profile files they are unchanged, logins and passwords are not recovered in new installation, but oddly bookmarks are ok. If I use menu entry to open "logins and passwords", there are 0 entries. If I open logins.json, I see entries . Further, if I view about:protections and scroll to bottom of page, it indicates there are 124 saved passwords. I can reboot to the old winxp system (a different HD) and all of my passwords/logins are still there. (Note: have copied everything to a much larger HD before installing win7 then using PCMover to move all programs to win7). So...., my profile is saved/intact from the ESR 52.9 setup. I have tried all kinds of tips/suggestions, recopying entire profle (all files), copying just logins.json key3.db files, toggling signon.importedFromSqlite setting to false, uninstalling/reinstalling latest FF, it just seems there is some bug where FF does not recognize the logins properly. I did NOT use a master password on the old winxp/ESR setup. Any suggestions? Thanks in advance.
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

none

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Eminye Imininingwane

philipp
  • Top 25 Contributor
  • Moderator
5348 izisombululo 23617 izimpendulo
Kuphostiwe

hi, due to a change in the password database format i think you can't update from 52 to 73 in one go (bug). try to install firefox 72 first and import the password files from the firefox 52 profile, and update to firefox 73 afterwards.

Install an older version of Firefox

also, why not update to win10 at this occasion instead of another system that has already reached its end of support...

hi, due to a change in the password database format i think you can't update from 52 to 73 in one go ([https://bugzilla.mozilla.org/show_bug.cgi?id=1615382 bug]). try to install firefox 72 first and import the password files from the firefox 52 profile, and update to firefox 73 afterwards. [[Install an older version of Firefox]] also, why not update to win10 at this occasion instead of another system that has already reached its end of support...
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks for your time to make suggestions. Ver 72 produced exact same results. FWIW, I uninstalled 73, installed 72, found profile folder, copied all files over from old ESR 52.9 profile, same results.

Win 10 is a possible future upgrade, I don't care for it tho and don't see how win10 will resolve my FF issue presently. One step at a time please.

Thanks for your time to make suggestions. Ver 72 produced exact same results. FWIW, I uninstalled 73, installed 72, found profile folder, copied all files over from old ESR 52.9 profile, same results. Win 10 is a possible future upgrade, I don't care for it tho and don't see how win10 will resolve my FF issue presently. One step at a time please.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17857 izisombululo 161585 izimpendulo
Kuphostiwe

Did you make sure to remove an existing key4.db and only use logins.json and key3.db from Firefox 52 ?

Copying a complete profile is usually not a good idea, best is to copy only selected files.

Did you make sure to remove an existing key4.db and only use logins.json and key3.db from Firefox 52 ? Copying a complete profile is usually not a good idea, best is to copy only selected files.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Complete copy of old ESR 52.9.0 profile was causing the problem.

I'm pretty certain I tried JUST the key3.db and logins.json file copy from the old profile with FF 73 with no luck, so it looks like FF 72 was also part of the solution. Both phillipp and cor-el had valuable input to resolve this issue.

Here's what I did:

Created a new profile in FF 72.0.2, then quit FF. Opened up new profile folder in Explorer and renamed key4.db to key4.db.old Copied key3.db and logins.json from the old FF 52.9 ESR profile to the new profile I just created, started up FF, imported my bookmarks from a backup in the defunct profile where logins did not work but bookmarks did, and now it appears to be working as I tried a few sites and the login/password info was autoinserted into correct text boxes.

Had noticed and read many of your posts helping others Cor-El so was glad to see you chimed in.

Bottom line is one CANNOT copy an entire old version FF profile folder to a new version FF install and hope it will work correctly; who knows which file was causing the problem, only the codecutters know for certain.

Complete copy of old ESR 52.9.0 profile was causing the problem. I'm pretty certain I tried JUST the key3.db and logins.json file copy from the old profile with FF 73 with no luck, so it looks like FF 72 was also part of the solution. Both phillipp and cor-el had valuable input to resolve this issue. Here's what I did: Created a new profile in FF 72.0.2, then quit FF. Opened up new profile folder in Explorer and renamed key4.db to key4.db.old Copied key3.db and logins.json from the old FF 52.9 ESR profile to the new profile I just created, started up FF, imported my bookmarks from a backup in the defunct profile where logins did not work but bookmarks did, and now it appears to be working as I tried a few sites and the login/password info was autoinserted into correct text boxes. Had noticed and read many of your posts helping others Cor-El so was glad to see you chimed in. Bottom line is one CANNOT copy an entire old version FF profile folder to a new version FF install and hope it will work correctly; who knows which file was causing the problem, only the codecutters know for certain.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.