Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't connect to official mozilla firefox addons website Error: MOZILLA_PKIX_ERROR_KEY_PINNING_FAILURE

  • 12 uphendule
  • 3 zinale nkinga
  • 177 views
  • Igcine ukuphendulwa ngu Sergei

more options

Get this error when ill try to open this ADDONS MOZILLA WEBSITE (https://addons.mozilla.org/ru/firefox/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_content=find-more-link-bottom) Can i get some solution please? Thank you, Sergei

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test the Add-ons site.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like Feb2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Can Firefox connect to the Add-ons site in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Feb2020 will remain available for future testing.)

Note: if this test changed your default profile, use the Set as Default Profile button for your regular profile to set it back to normal.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

Does the answer from this thread fix the problem?

more options

Wesley Branton said

Does the answer from this thread fix the problem?

check it unfortunately this not help to me :(

Okulungisiwe ngu Sergei

more options

Do you have any non-default settings here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste pinning and pause while the list is filtered

On mine, the only one that is bolded (customized) is a date value (services.blocklist.pinning.checked). (Screenshot attached.)

To reset a customized preference, use the little arrow button at the right end.

more options

jscher2000 said

Do you have any non-default settings here: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste pinning and pause while the list is filtered On mine, the only one that is bolded (customized) is a date value (services.blocklist.pinning.checked). (Screenshot attached.) To reset a customized preference, use the little arrow button at the right end.

Same settings as your, Sir . Reset and nothing. Also reinstall firefox now and still same problem

more options

Isisombululo Esikhethiwe

Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test the Add-ons site.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like Feb2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Can Firefox connect to the Add-ons site in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Feb2020 will remain available for future testing.)

Note: if this test changed your default profile, use the Set as Default Profile button for your regular profile to set it back to normal.

more options

I have exactly the same problem (and also in Russia).

When I created new profile and tried to enter addons.mozilla.org there i got redirected to some phishing site. Something like that also happens in Chrome. It says the cerificate is fake.

When i use my mobile provider with wifi hotspot everything works just fine. My main provider (Sumtel) says that my traffic is blocked somewhere after leaving their network and so the problem is not on their side.

On whose side is it then?

more options

Hi Phil, could you test DNS over HTTPS -- bypassing your regular DNS provider -- to see whether that makes any difference? More info in this article: Firefox DNS-over-HTTPS.

more options

Hi Phil

See also:

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

Turning on DNS over HTTPS feature solved the problem (FYI: just changing proxy settings didn't)

Thanks for your help!

more options

Phil said

Turning on DNS over HTTPS feature solved the problem

Okay, that implies that the DNS provided through the standard path (your service provider) is not returning correct results for every site. This might be intentional, or maybe not, hard to say.

more options

It seems like this might be related to Russian State Security Service experimenting with Deep Packet Inspection hardware that local providers were made to install

Okulungisiwe ngu Phil

more options

Guys, thank you very much!

Phil said

Turning on DNS over HTTPS feature solved the problem (FYI: just changing proxy settings didn't) Thanks for your help!