X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Unwanted http redirecting to https

Kuphostiwe

My sites are redirecting to https when they should not be redirecting. Problem does not exist with chrome , IE, and Edge.

I have some sites that are blocked in some countries if they are https. So I want these websites to be http. Better than nothing.

FF is directing http to https. I dont want that , but thanks anyway.

My sites are redirecting to https when they should not be redirecting. Problem does not exist with chrome , IE, and Edge. I have some sites that are blocked in some countries if they are https. So I want these websites to be http. Better than nothing. FF is directing http to https. I dont want that , but thanks anyway.

Isisombululo esikhethiwe

Safe mode had no effect. But Refresh firefox did solve the problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8962 izisombululo 73440 izimpendulo
Kuphostiwe

If the site is sending a redirect on every visit, that would be difficult to work around.

Firefox may redirect HTTP to HTTPS in a number of cases:

  • a redirect from a previous visit was stored in the cache (the cache can be cleared if needed: How to clear the Firefox cache)
  • on a previous visit, the site sent Strict-Transport-Security (HSTS) headers to Firefox previously, which are then retained in a settings file
  • Firefox has built-in instructions to always uses HTTPS from an HSTS list
  • if an extension like HTTPS Everywhere is installed
If the site is sending a redirect on every visit, that would be difficult to work around. Firefox may redirect HTTP to HTTPS in a number of cases: * a redirect from a previous visit was stored in the cache (the cache can be cleared if needed: [[How to clear the Firefox cache]]) * on a previous visit, the site sent Strict-Transport-Security (HSTS) headers to Firefox previously, which are then retained in a settings file * Firefox has built-in instructions to always uses HTTPS from an HSTS list * if an extension like HTTPS Everywhere is installed
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
FredMcD
  • Top 10 Contributor
4398 izisombululo 61724 izimpendulo
Kuphostiwe

Please provide a public link (no password) that we can check out. No Personal Information Please !

Please provide a public link (no password) that we can check out. '''No Personal Information Please ! '''
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit.

No other tweaking was performed. Default out of the box FF.

the site is madeinirandotcom

Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit. No other tweaking was performed. Default out of the box FF. the site is madeinirandotcom
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4398 izisombululo 61724 izimpendulo
Kuphostiwe

I had no problem with http://madeiniran.com/

I had no problem with http://madeiniran.com/
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
jscher2000
  • Top 10 Contributor
8962 izisombululo 73440 izimpendulo
Kuphostiwe

pixelpadre said

Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit.

If Firefox saved an HSTS instruction it would be saved in your profile in this file:

SiteSecurityServiceState.txt

You could try removing that file (while Firefox is closed) to see whether the redirection stops.

More info on accessing your profile folder: Profiles - Where Firefox stores your bookmarks, passwords and other user data

''pixelpadre [[#answer-1292764|said]]'' <blockquote> Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit. </blockquote> If Firefox saved an HSTS instruction it would be saved in your profile in this file: SiteSecurityServiceState.txt You could try removing that file (while Firefox is closed) to see whether the redirection stops. More info on accessing your profile folder: [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]]
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 said

pixelpadre said
Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit.

If Firefox saved an HSTS instruction it would be saved in your profile in this file:

SiteSecurityServiceState.txt

You could try removing that file (while Firefox is closed) to see whether the redirection stops.

More info on accessing your profile folder: Profiles - Where Firefox stores your bookmarks, passwords and other user data

No entries for the domain here. M/s and google browsers work as expected.

''jscher2000 [[#answer-1292804|said]]'' <blockquote> ''pixelpadre [[#answer-1292764|said]]'' <blockquote> Clearing the cache was the first thing I did. And yes there once was a https version that I visited in FF. But the cache might have cleared that visit. </blockquote> If Firefox saved an HSTS instruction it would be saved in your profile in this file: SiteSecurityServiceState.txt You could try removing that file (while Firefox is closed) to see whether the redirection stops. More info on accessing your profile folder: [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] </blockquote> No entries for the domain here. M/s and google browsers work as expected.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

FredMcD said

I had no problem with http://madeinirandotcom/

I suspected that it would work for you since it worked for ms and google. Problem is with my desktop. Not a big problem, but a problem none the less.

''FredMcD [[#answer-1292769|said]]'' <blockquote> I had no problem with http://madeinirandotcom/ </blockquote> I suspected that it would work for you since it worked for ms and google. Problem is with my desktop. Not a big problem, but a problem none the less.

Okulungisiwe ngu pixelpadre

Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8962 izisombululo 73440 izimpendulo
Kuphostiwe

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

Safe mode had no effect. But Refresh firefox did solve the problem.

Safe mode had no effect. But Refresh firefox did solve the problem.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4398 izisombululo 61724 izimpendulo
Kuphostiwe

Well done.

Well done.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17876 izisombululo 161748 izimpendulo
Kuphostiwe

Did you previously tried "Forget About This Site" to remove all data from this host ?

Did you previously tried "Forget About This Site" to remove all data from this host ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jlevitas16 0 izisombululo 4 izimpendulo
Kuphostiwe

I am having the same problem. I have a site that in the past, I have accessed via https, but as a developer, I can and need to bypass this and access via http. When I've had this issue before, I've clear the site settings in the cache and it worked fine. I have checked my SiteSecurityServiceState.txt file, the domain is not listed there. I've done the Forget About This Site. I've tried everything. There is no question that somehow the https is still "stuck" in Firefox's cache, and that there has been some change over the past couple of weeks that has caused this problem. If I can't get an answer within the next week, I will be switching permanently to Chrome. I don't want to "Refresh" Firefox and lose my add-ons that are set up.

I am having the same problem. I have a site that in the past, I have accessed via https, but as a developer, I can and need to bypass this and access via http. When I've had this issue before, I've clear the site settings in the cache and it worked fine. I have checked my SiteSecurityServiceState.txt file, the domain is not listed there. I've done the Forget About This Site. I've tried everything. There is no question that somehow the https is still "stuck" in Firefox's cache, and that there has been some change over the past couple of weeks that has caused this problem. If I can't get an answer within the next week, I will be switching permanently to Chrome. I don't want to "Refresh" Firefox and lose my add-ons that are set up.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17876 izisombululo 161748 izimpendulo
Kuphostiwe

You can try to remove the disk cache manually. You can find the location of the disk cache on the about:cache page and possibly use the about:profiles page to go to the secondary 'Local' profile location.

You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages
You can try to remove the disk cache manually. You can find the location of the disk cache on the about:cache page and possibly use the about:profiles page to go to the secondary 'Local' profile location. You can open "<b>about:</b>" pages via the location/address bar *"about:" is a protocol to access special pages
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jlevitas16 0 izisombululo 4 izimpendulo
Kuphostiwe

I tried removing both my primary and secondary cache and the problem persists. There is no problem in Chrome or Edge.

I tried removing both my primary and secondary cache and the problem persists. There is no problem in Chrome or Edge.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

FredMcD said

I had no problem with http://mcom/

Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you.

''FredMcD [[#answer-1292769|said]]'' <blockquote> I had no problem with http://mcom/ </blockquote> Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you.

Okulungisiwe ngu pixelpadre

Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4398 izisombululo 61724 izimpendulo
Kuphostiwe

FredMcD said

I had no problem with http://madeiniran.com/

pixelpadre said

Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you.

The link you posted is still there. And you said nothing about keeping it private.

''FredMcD [[#answer-1292769|said]]'' <blockquote> I had no problem with http://madeiniran.com/ </blockquote> ''pixelpadre [[#answer-1293159|said]]'' <blockquote> Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you. </blockquote> The link you posted is still there. And you said nothing about keeping it private.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

FredMcD said

FredMcD said
I had no problem with http://m/

pixelpadre said

Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you.

The link you posted is still there. And you said nothing about keeping it private.

I deleted your link, is that not a statement telling you do not backlink my webiste.

''FredMcD [[#answer-1293165|said]]'' <blockquote> ''FredMcD [[#answer-1292769|said]]'' <blockquote> I had no problem with http://m/ </blockquote> ''pixelpadre [[#answer-1293159|said]]'' <blockquote> Since you insist on including a link to my website after I DELETED IT, I will be sure in the future to not include any information about my site and ignore any comments by you. </blockquote> The link you posted is still there. And you said nothing about keeping it private. </blockquote> I deleted your link, is that not a statement telling you do not backlink my webiste.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8962 izisombululo 73440 izimpendulo
Kuphostiwe

Hi jlevitas16, let's continue in your new thread here: https://support.mozilla.org/questions/1280667

Hi jlevitas16, let's continue in your new thread here: https://support.mozilla.org/questions/1280667
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.