Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When trying to install some software I get a message saying browser is not secure and/or enable Java script. Java script is enabled.

  • 2 uphendule
  • 1 inale nkinga
  • 15 views
  • Igcine ukuphendulwa ngu putts

more options

I have gone thru FF troubleshooting but that doesn't fix problem. Please help.

All Replies (2)

more options

It sounds like something is blocking Javascript (or maybe just a specific part of Javascript) on the website that you are trying to use.

Looking at the list of add-ons you provided in your system details, it looks like you have a lot of content blockers (Ghostery, Privacy Badger, uBlock, etc) installed and running on Firefox. These add-ons are often the cause of these types of problems.

If you run Firefox in Safe Mode you will likely notice that the problem goes away. If that's the case, one of your installed extensions is blocking the required content on that website. You will either need to disable the add-on entirely or add the website to the add-on's whitelist.

The only other thing that I think may be causing the problem is Enhanced Tracking Protection (ETP). Sometimes ETP will block certain scripts that it thinks are tracking content. You may need to disable ETP on that specific website.

Hope this helps.

more options

I tried running FF in safe mode as per troubleshooting instructions. That did not help.

As for ETP I wasn't at a specific website. I was trying to install PDF Architect 7 and when it asked me to sign in was when I got the message that I needed to enable Java script.

I appreciate the response but I'm afraid I'm still stuck.