X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Isithangami Sabeseki

private browsing add ons

Kuphostiwe

Hi. I am trying to figure out why my add ons do not work at all in private browsing. my tab manager fails to save tabs in private mode and adblock does not work at all. what would be the cause of this behavior? I have the option enabled for both to use in private but they refuse to run. thanks

Hi. I am trying to figure out why my add ons do not work at all in private browsing. my tab manager fails to save tabs in private mode and adblock does not work at all. what would be the cause of this behavior? I have the option enabled for both to use in private but they refuse to run. thanks
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8957 izisombululo 73389 izimpendulo
Kuphostiwe

Hi BradS, when you install an extension, it is only enabled for regular windows by default. Firefox displays a little confirmation panel on the right side of the toolbar with a checkbox to enable it in private windows. If you don't do it then, you still should be able to do it now. Here's how.

Open the Add-ons page -- either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then on the right side, find an extension that needs to run in private windows, and click it to view its Details panel. Scroll down (if needed) to the line with

Run in Private Windows   O Allow  O Don't Allow

And update your preference.

Repeat with other extensions as needed.

Was that it?

Hi BradS, when you install an extension, it is only enabled for regular windows by default. Firefox displays a little confirmation panel on the right side of the toolbar with a checkbox to enable it in private windows. If you don't do it then, you still should be able to do it now. Here's how. Open the Add-ons page -- either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then on the right side, find an extension that needs to run in private windows, and click it to view its Details panel. Scroll down (if needed) to the line with Run in Private Windows O Allow O Don't Allow And update your preference. Repeat with other extensions as needed. Was that it?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8957 izisombululo 73389 izimpendulo
Kuphostiwe

Of course, I missed that last sentence. Try toggling between Don't allow and Allow.

I'm not aware of any global settings that could block all extensions from running in private windows.

The other thing that comes to mind is possibly the extensions.json file has become corrupted in some manner. In that case, you could remove the file and let Firefox rebuild it. This may flush your accumulated extension settings and data so consider it a last resort.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename extensions.json to something like extensionsOLD.json.

Start Firefox back up again and it should rediscover the installed extensions. Most likely you'll need to enable each one for private.

Of course, I missed that last sentence. Try toggling between Don't allow and Allow. I'm not aware of any global settings that could block all extensions from running in private windows. The other thing that comes to mind is possibly the '''extensions.json''' file has become corrupted in some manner. In that case, you could remove the file and let Firefox rebuild it. '''This may flush your accumulated extension settings and data so consider it a last resort.''' Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''extensions.json''' to something like '''extensionsOLD.json'''. Start Firefox back up again and it should rediscover the installed extensions. Most likely you'll need to enable each one for private.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hi. thanks for the suggestions. Still having the same problems.

Hi. thanks for the suggestions. Still having the same problems.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.