X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Isithangami Sabeseki

Widevine crashes every time I visit Netflix or Amazon

Kuphostiwe

I'm on Arch Linux and recently updated Firefox to version 73.0 through pacman. I got no errors and Firefox works fine. Except that Widevine crashes whenever I visit Netflix or Amazon. I tried removing the plugin and reinstalling it, reinstalling Firefox and starting Firefox in safe mode. If anyone knows a solution to my problem your help would be much appreciated!

I'm on Arch Linux and recently updated Firefox to version 73.0 through pacman. I got no errors and Firefox works fine. Except that Widevine crashes whenever I visit Netflix or Amazon. I tried removing the plugin and reinstalling it, reinstalling Firefox and starting Firefox in safe mode. If anyone knows a solution to my problem your help would be much appreciated!

Isisombululo esikhethiwe

So I now downgraded glibc and lib32-glibc which fixed the problem. Thank you all for your help! Have a lovely day :)

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Eminye Imininingwane

Matthew Thomas
  • Top 25 Contributor
13 izisombululo 90 izimpendulo
Kuphostiwe

It looks like you're actually on Firefox 74 which is not a stable release. Maybe you should try rolling it back to the current stable release.

Other than that, you can try to remove video hardware acceleration by disabling media.hardware-video-decoding.enabled in about:config.

It looks like you're actually on Firefox 74 which is not a stable release. Maybe you should try rolling it back to the current stable release. Other than that, you can try to remove video hardware acceleration by disabling media.hardware-video-decoding.enabled in about:config.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hey. Thank you for your reply. I posted that question from the firefox developer edition as I wanted to see if it worked there, but it didn't either. I tried disabling hardware video decoding but it sadly didn't work either. Thank you for your help though.

Hey. Thank you for your reply. I posted that question from the firefox developer edition as I wanted to see if it worked there, but it didn't either. I tried disabling hardware video decoding but it sadly didn't work either. Thank you for your help though.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17860 izisombululo 161609 izimpendulo
Kuphostiwe

Does Widevine work here ?

Does Widevine work here ? *https://shaka-player-demo.appspot.com/demo/
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

Does Widevine work here ?

Sadly it still crashes immediately

''cor-el [[#answer-1290430|said]]'' <blockquote> Does Widevine work here ? *https://shaka-player-demo.appspot.com/demo/ </blockquote> Sadly it still crashes immediately
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Roland Tanglao
  • Administrator
77 izisombululo 848 izimpendulo
Kuphostiwe

Hi Quirinbrunner:

I believe this is fixed in Firefox 73.0.1 which was released today. Please give it a try.

Cheers!

...Roland

Hi Quirinbrunner: I believe this is fixed in Firefox 73.0.1 which was released today. Please give it a try. Cheers! ...Roland
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Sadly it still crashes :/

Sadly it still crashes :/
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Is there any information I could give that could help?

Is there any information I could give that could help?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

So I now downgraded glibc and lib32-glibc which fixed the problem. Thank you all for your help! Have a lovely day :)

So I now downgraded glibc and lib32-glibc which fixed the problem. Thank you all for your help! Have a lovely day :)
Ingabe lokhu kube usizo kuwena?
Isicaphuno
bvandyk 0 izisombululo 1 izimpendulo
Kuphostiwe

If anyone is running into this and is willing to test, it would be useful to know if running with the environment variable `MOZ_DISABLE_GMP_SANDBOX=1` set impacts the crash. That env var can be used to disable the sandbox Widevine runs in. You can unset the var once you've tested.

We've seen new versions of glibc run into the sandbox because they change the syscalls some functions use. So if setting that fixes the problem, that would be helpful to know. If it does fix the problem, running with the env var `MOZ_SANDBOX_LOGGING=1` set should log to the terminal what call is blocked. If Mozilla can get that info we can use it to adjust the sandbox as needed.

If anyone is running into this and is willing to test, it would be useful to know if running with the environment variable `MOZ_DISABLE_GMP_SANDBOX=1` set impacts the crash. That env var can be used to disable the sandbox Widevine runs in. You can unset the var once you've tested. We've seen new versions of glibc run into the sandbox because they change the syscalls some functions use. So if setting that fixes the problem, that would be helpful to know. If it does fix the problem, running with the env var `MOZ_SANDBOX_LOGGING=1` set should log to the terminal what call is blocked. If Mozilla can get that info we can use it to adjust the sandbox as needed.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

bvandyk said

If anyone is running into this and is willing to test, it would be useful to know if running with the environment variable `MOZ_DISABLE_GMP_SANDBOX=1` set impacts the crash. That env var can be used to disable the sandbox Widevine runs in. You can unset the var once you've tested. We've seen new versions of glibc run into the sandbox because they change the syscalls some functions use. So if setting that fixes the problem, that would be helpful to know. If it does fix the problem, running with the env var `MOZ_SANDBOX_LOGGING=1` set should log to the terminal what call is blocked. If Mozilla can get that info we can use it to adjust the sandbox as needed.

I would love to help but even with the glib and lib32-versions at the versions they were before it doesn't crash anymore.

''bvandyk [[#answer-1291527|said]]'' <blockquote> If anyone is running into this and is willing to test, it would be useful to know if running with the environment variable `MOZ_DISABLE_GMP_SANDBOX=1` set impacts the crash. That env var can be used to disable the sandbox Widevine runs in. You can unset the var once you've tested. We've seen new versions of glibc run into the sandbox because they change the syscalls some functions use. So if setting that fixes the problem, that would be helpful to know. If it does fix the problem, running with the env var `MOZ_SANDBOX_LOGGING=1` set should log to the terminal what call is blocked. If Mozilla can get that info we can use it to adjust the sandbox as needed. </blockquote> I would love to help but even with the glib and lib32-versions at the versions they were before it doesn't crash anymore.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.