Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't log into my banks any longer. Worked yesterday. Today after I put in my login info I get a blank screen. I've changed nothing. Using Version 72.0.2

  • 1 baphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu McCoy

more options

e.g. Here is one site, Royal Bank of Canada Direct Investing https://www.rbcdirectinvesting.com/ that worked yesterday, but not today. I disabled add-ons and extensions. Still the same result. I ran FF in safe mode still the same result. I cleared the cache and cookies and still get a blank screen. I'm at a loss. I tested and I can log in using Chrome, but no longer FF. I prefer using FF, but will switch to Chrome if I have to in order to perform my financial duties. So what's up? How do I fix this? Thanks.

All Replies (1)

more options

Hello blwtalk,

As for RBC, please see this thread :

https://support.mozilla.org/en-US/questions/1277382