Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How set the default behavior when downloading .dmg files to just save them, not open them?

  • 4 uphendule
  • 1 inale nkinga
  • 98 views
  • Igcine ukuphendulwa ngu Rumboogy

more options

When I try to download a .dmg file the default is to is to open it with "DiskImageMounter". This is disastrously bad behavior and there seems to be no way to change this insane default.

Isisombululo esikhethiwe

I think I fixed it (accidentally). I downloaded a .dmg from different website than the original attempt and this time it let me change the default which in turn, created an entry in the applications table. So now I can set it to "Save File" or "Always Ask".

I don't know why going to the frist website where I downloaded a .dmg did not create this entry in the application table, but it is there now so I can control the behavior in the future when I download .dmg files.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Hi,

Fortunately, you can change this! :)

You can change this setting by going to Firefox Preferences (on the menu button at the top of the screen, click Firefox > Preferences).

Make sure you're in the "General" section and scroll down until you find:

"Applications Choose how Firefox handles the files you download from the Web or the applications you use while browsing."

If you search for 'dmg' the the applications search box, you'll find .dmg files listed with "Use DiskImageMounter" on the right hand side. Click there, and choose "Save File" to have .dmg files automatically downloaded but not opened, or choose "Always Ask" and Firefox will prompt whether to save or open every time you download a .dmg.

Hope this helps!

more options

Thanks for the response.

When I search for "DMG" in the applications search box I get no results. There are very few entries in the applications list to start with. This seems odd because I recall from previously looking at this that there were many items in this list.

This is a relatively fresh install of Firefox BTW.

more options

How do I go about creating a new entry in the applications box?

more options

Isisombululo Esikhethiwe

I think I fixed it (accidentally). I downloaded a .dmg from different website than the original attempt and this time it let me change the default which in turn, created an entry in the applications table. So now I can set it to "Save File" or "Always Ask".

I don't know why going to the frist website where I downloaded a .dmg did not create this entry in the application table, but it is there now so I can control the behavior in the future when I download .dmg files.

Okulungisiwe ngu Rumboogy