Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

cannot load usage page from cox

  • 10 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu RobertJ

more options

When I go to the Cox usage page after I sign in

it is blank when using Firefox.  Using Edge (don't like to use) the page loads correctly.  Have cleaned out history and cookies and cache..any other suggestions?

Isisombululo esikhethiwe

Hi oldbob2, Try disabling the Norton Safe Web extension and restarting Firefox. Then sign in to Cox and see if you can continue.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (10)

more options

Isisombululo Esikhethiwe

Hi oldbob2, Try disabling the Norton Safe Web extension and restarting Firefox. Then sign in to Cox and see if you can continue.

more options

I disabled it and re-stsarted as instructed and the page now loads..I then enabled it again and the page still loads. .Don't really understand why as Edge worked and Firefox was working a few days ago but mine is to not know why just be happy it is working now!! Thank you again. UPDATE: WHEN I RE-STARTED THE LAPTOP THE PAGE WOULD AGAIN WOULD NOT OPEN.. Cant leave that turned off forever as I loose protection. Norton Safe search is turned on in Edge and it loads the page but not in Firefox

Okulungisiwe ngu oldbob2

more options

Firefox's Enhanced Tracking Protection won't leave you out in the cold.

How often do you visit Cox? If it isn't very often, at least you know what the problem is when the page won't load. Then, you can disable Norton for that visit. Or disable it ahead of time.

There are many other extensions available. Like Malwarebytes Browser Guard:

more options

thank you ..but can Firefox fix this? Like I said it has always worked on Firefox and I prefer Firefox and if it works on Edge I assume it is a Firefox issue and not a Norton issue..yes..I do use it a lot.

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Boy a lot of suggestions..try them tomorrow when I am fresh and patient.. Odd sometimes it works at restart but not on full shut down and vice versa..Maybe too Norton (try to deal with them is close to impossible) considers in their Firefox programming considers that page not safe but in their programming of Edge it is safe..way over my understanding..but thank you for all the suggestions. Will give them a try.

more options

You can try to contact Norton for support.

more options

This is interesting:

Safe Web Report for:

more options

RobertJ said

This is interesting: Safe Web Report for:

Thank you Robert..interresting that Norton clears this Cox page so maybe Firefox is noting it might be something they need to look at..and this AM there was an update to Firefox..and the page opens..I know its not a biggie issue to many but it was to me and I find these Forums are so helpful and I thank you all..

more options

I'm not so sure that Firefox has anything to do with it. There are always False Positives generated by security software. It could be an association with the Norton Safe Search extension.

You can ask a question at the forum that @cor-el mentioned.

And bookmark this thread as a reference.