X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox 72.0.1 (64-bit, Windows 10) ignores options set by GeckDriver (V026.0) via Java. Used to work fine for Firefox 72.0 and older.

Kuphostiwe

Firefox 72.0.1 (64-bit, Windows 10, 1909) ignores options set by GeckDriver (V026.0) via Java. Used to work fine for Firefox 72.0 and older. Java version is openjdk version "1.8.0_222"

I am setting options to download files (PDFs) from a web page to a folder: profile.setPreference("browser.download.folderList", 2); File tempfile = new File(tempFolder); profile.setPreference("browser.download.dir", tempfile.getAbsolutePath()); profile.setPreference("browser.download.manager.alertOnEXEOpen", false); profile.setPreference("browser.helperApps.neverAsk.saveToDisk", "application/zip,application/octet-stream,application/pdf"); profile.setPreference("browser.download.manager.showWhenStarting", false); profile.setPreference("browser.download.manager.focusWhenStarting", false); profile.setPreference("browser.download.useDownloadDir", true); profile.setPreference("browser.helperApps.alwaysAsk.force", false); profile.setPreference("browser.download.manager.alertOnEXEOpen", false); profile.setPreference("browser.download.manager.closeWhenDone", true); profile.setPreference("browser.download.manager.showAlertOnComplete", false); profile.setPreference("browser.download.manager.useWindow", false); profile.setPreference("services.sync.prefs.sync.browser.download.manager.showWhenStarting", false); profile.setPreference("pdfjs.disabled", true); profile.setPreference("browser.privatebrowsing.autostart", true); profile.setPreference("extensions.allowPrivateBrowsingByDefault", true); profile.setPreference("intl.accept_languages", "en-us,en"); profile.setPreference("javascript.enabled", true);

This worked all right before I got Firefox 72.0.1. With 72.0.1 the PDF is opened in the pdf view of FireFox. I checked the Firefox options and they are set as desired. Any ideas how to fix this?

Firefox 72.0.1 (64-bit, Windows 10, 1909) ignores options set by GeckDriver (V026.0) via Java. Used to work fine for Firefox 72.0 and older. Java version is openjdk version "1.8.0_222" I am setting options to download files (PDFs) from a web page to a folder: profile.setPreference("browser.download.folderList", 2); File tempfile = new File(tempFolder); profile.setPreference("browser.download.dir", tempfile.getAbsolutePath()); profile.setPreference("browser.download.manager.alertOnEXEOpen", false); profile.setPreference("browser.helperApps.neverAsk.saveToDisk", "application/zip,application/octet-stream,application/pdf"); profile.setPreference("browser.download.manager.showWhenStarting", false); profile.setPreference("browser.download.manager.focusWhenStarting", false); profile.setPreference("browser.download.useDownloadDir", true); profile.setPreference("browser.helperApps.alwaysAsk.force", false); profile.setPreference("browser.download.manager.alertOnEXEOpen", false); profile.setPreference("browser.download.manager.closeWhenDone", true); profile.setPreference("browser.download.manager.showAlertOnComplete", false); profile.setPreference("browser.download.manager.useWindow", false); profile.setPreference("services.sync.prefs.sync.browser.download.manager.showWhenStarting", false); profile.setPreference("pdfjs.disabled", true); profile.setPreference("browser.privatebrowsing.autostart", true); profile.setPreference("extensions.allowPrivateBrowsingByDefault", true); profile.setPreference("intl.accept_languages", "en-us,en"); profile.setPreference("javascript.enabled", true); This worked all right before I got Firefox 72.0.1. With 72.0.1 the PDF is opened in the pdf view of FireFox. I checked the Firefox options and they are set as desired. Any ideas how to fix this?
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

uBlock Origin, HTTPS everywhere, Cookie AutoDelete

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Eminye Imininingwane

d.mattera 3 izisombululo 17 izimpendulo
Kuphostiwe

Are you using Selenium here as well and if so, which version? It's possible that could be the issue.

Can you confirm that "pdfjs.disabled" is indeed being set to "true" once the browser is up and running by going to "about:config" and typing "pdfjs.disabled" into the search box?

That being said, you may be able to get quicker, more effective support on this from the folks on the geckodriver and selenium teams by opening issues on their respective GitHub repos:

https://github.com/mozilla/geckodriver/issues https://github.com/SeleniumHQ/selenium/issues

Are you using Selenium here as well and if so, which version? It's possible that could be the issue. Can you confirm that "pdfjs.disabled" is indeed being set to "true" once the browser is up and running by going to "about:config" and typing "pdfjs.disabled" into the search box? That being said, you may be able to get quicker, more effective support on this from the folks on the geckodriver and selenium teams by opening issues on their respective GitHub repos: https://github.com/mozilla/geckodriver/issues https://github.com/SeleniumHQ/selenium/issues

Okulungisiwe ngu d.mattera

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Selenium version is 3.141.59. "pdfjs.disabled" is false in about:config.

Selenium version is 3.141.59. "pdfjs.disabled" is false in about:config.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.