Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

keep getting Acess denied message for Gamestop website

  • 31 uphendule
  • 2 zinale nkinga
  • Igcine ukuphendulwa ngu McCoy

more options

keep getting this message: You don't have permission to access "" on this server.

Reference #18.690ac617.1577807083.28e55fdf

it was working 24 hours ago, so what happened??

Isisombululo esikhethiwe

oldbob2 said

I am in CT and this morning with Firefox I could get on gamestop so hopefully this issue is resolved (at least for me) Thank You

Thank you for lettings us know !

It's different for many people in different locations and with different browsers; I have a friend in CT who never got the "Access Denied".

Totally unpredictable.

When you do search about this weird phenomenon, you'll find numerous people reporting this (and have been for a long time).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

Hello Joe,

You're not the only one who gets that "Access Denied" ...

See :

Also see these search results ....

FWIW : I get the same message.

more options

I got thru with no problem. Re-try accessing the site.

more options

still not working on Firefox, but working on Chrome and Edge. I've clear my cache, reset the browser, and still nothing. I guess my main concern is if it's an issue with the browser or the website. Update: yeah, looking like it might be the website, lots of Firefox users reporting the same issue online

Okulungisiwe ngu Joe

more options

I still get the "Access Denied" in both Firefox and Edge (different reference numbers).

more options
more options

Still the same for others :

When you scroll down a little it says :

"We have tried pinging GameStop website using our server and the website returned the above results. If is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress... "

Also see the search results I posted earlier.

Okulungisiwe ngu McCoy

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Got the browser to forget the site, still not getting anywhere.

more options

Joe, are you located in the US ?

I'm asking because of what I read in this thread :

Also here it still says :

" Access to is declined. The server doesn't allow access to the page... "

more options

FredMcD said


Good question Fred, but if Joe is located in the US, that may not be the case. I asked a neighbor (who uses Safari) to try the site, as well as a friend who uses Chrome: both get the same "Access Denied", just like I do with Firefox and Edge. (we all are located in the Netherlands) But then : location may have nothing to do with it ......

more options

Hey guys, yes, I am in the US. I was even looking at their site only a few hours before it started denying me access, so I'm not sure what happened, if it is an issue with the site itself or an issue that developed within Firefox. If it's their website, ok, but if FIrefox is going to start spontaneously locking out websites, that's going to be a problem, I think.

more options

I was wondering if maybe you weren't in the US, as I do not get the "Access Denied" when I enter in the address bar.

I mentioned the same happening in other browsers, but then in other threads I see people mentioning that it works in other browsers. I'm baffled ....

more options

McCoy, I'm just as baffled as you are lol. It makes no sense, and I've done everything I can think of on my end to correct the issue, short of deleting Firefox and reinstalling it, and that's a hassle I don't really want to deal with

more options

This may not help, but; Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there? Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Joe said

deleting Firefox and reinstalling it, and that's a hassle I don't really want to deal with

Right you are ! I wouldn't go through all the hassle just yet.

Who knows : some brainbox just might come up with the perfect solution (fingers crossed .... ).

more options

Joe said

keep getting this message: You don't have permission to access "" on this server. Reference #18.690ac617.1577807083.28e55fdf it was working 24 hours ago, so what happened??

I too cannot use Firefox for gamestop but it load in Edge..but I prefer Firefox. Have cleared history (but cant see where it says to forget this site) and still get same access message.

Any other suggestions?

more options

Weird how some people don't get the "Access Denied" in Edge,
and others (like me) do :

more options

it's starting to sound more and more like a website issue then. Numerous browsers and numerous people are being affected. I might as well go ahead and close the thread. I appreciate all the advise and suggestions provided by you all :) good to have a helping hand out there.

more options

Someone should alert the webmaster there.

  1. 1
  2. 2