X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Font rendering on a specific website

Kuphostiwe

Hello,

I have a trouble with font rendering on one specific website - https://www.checkpoint.com.

Text on this site looks quite ugly (see font01.png).

But if I open "Web Developer" -> "Inspector" -> "Fonts" -> "All fonts on page", then I can see the text renderred correctly in the preview field (see font02.png).

So text uses "DIN WXX Regular" font, but I do not understand, why Firefox cannot render it on the web page in the same manner as in the Developer tools?

Any clue how to fix it?

Browser: Firefox 68.2.0esr (64-bit) OS: Debian Bullseye

Thanks Zbynek

Hello, I have a trouble with font rendering on one specific website - https://www.checkpoint.com. Text on this site looks quite ugly (see font01.png). But if I open "Web Developer" -> "Inspector" -> "Fonts" -> "All fonts on page", then I can see the text renderred correctly in the preview field (see font02.png). So text uses "DIN WXX Regular" font, but I do not understand, why Firefox cannot render it on the web page in the same manner as in the Developer tools? Any clue how to fix it? Browser: Firefox 68.2.0esr (64-bit) OS: Debian Bullseye Thanks Zbynek
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

So I can confirm that it brakes when upgrading from Debian 9 to 10.

Nothing to do with Firefox version.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

Kiki
  • Administrator
6 izisombululo 26 izimpendulo
Kuphostiwe

Hi Zbynek,

Apologies for the inconvenience. I check the website myself and it looks fine (I'm using Firefox 71 in Mac). Maybe this could do the trick?

Hi Zbynek, Apologies for the inconvenience. I check the website myself and it looks fine (I'm using Firefox 71 in Mac). Maybe [https://support.mozilla.org/en-US/questions/1243718 this] could do the trick?
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Hi,

I belive that in every Firefox with default browser/system font settings it will look fine. But I have some system font customizations, so that could be the reason. Also I have another Debian with the same customizations (but older distro version) and the same Firefox version, where it works fine. But I don't know, why Firefox behaves differently.

gfx.text.disable-aa completely disables Anti-Aliasing, so I have the ugly font on all web sites (and no change for https://www.checkpoint.com). So the question might be how to enable Anti-Aliasing for https://www.checkpoint.com while any other pages are Anti-Aliased fine?

Thanks Zbynek

Hi, I belive that in every Firefox with default browser/system font settings it will look fine. But I have some system font customizations, so that could be the reason. Also I have another Debian with the same customizations (but older distro version) and the same Firefox version, where it works fine. But I don't know, why Firefox behaves differently. ''gfx.text.disable-aa'' completely disables Anti-Aliasing, so I have the ugly font on all web sites (and no change for https://www.checkpoint.com). So the question might be how to enable Anti-Aliasing for https://www.checkpoint.com while any other pages are Anti-Aliased fine? Thanks Zbynek
Ingabe lokhu kube usizo kuwena?
Isicaphuno
RashanH 1 izisombululo 44 izimpendulo
Kuphostiwe

There are may be some relations between Anti-Aliasing with computer's graphic rendering services. Not sure, just an opinion.

There are may be some relations between Anti-Aliasing with computer's graphic rendering services. Not sure, just an opinion.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))
You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems. *<b>View -> Zoom -> Reset</b> (Ctrl+0/Command+0 (zero)) *https://support.mozilla.org/en-US/kb/how-do-i-use-zoom
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Hi, zoom is ok, that's not the issue.

Regards Zbynek

Hi, zoom is ok, that's not the issue. Regards Zbynek
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

Can you make it look better if you adjust the font-size setting in the Fonts tab or zoom the page.

See also:

  • browser.display.auto_quality_min_font_size
Can you make it look better if you adjust the font-size setting in the Fonts tab or zoom the page. See also: *browser.display.auto_quality_min_font_size
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

Can you make it look better if you adjust the font-size setting in the Fonts tab or zoom the page. See also:
  • browser.display.auto_quality_min_font_size

No change.

''cor-el [[#answer-1273237|said]]'' <blockquote> Can you make it look better if you adjust the font-size setting in the Fonts tab or zoom the page. See also: *browser.display.auto_quality_min_font_size </blockquote> No change.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I have tried to copy Firefox profile from the other PC (where fonts are ok) and it did not help. Based on this I guess that any change in "about:config" won't help.

So I have a few ideas what difference could be in the game: - Debian version (8 vs. 11) - installed (font) packages - hardware

Both PCs use Xfce environment and https://www.checkpoint.com looks fine in Chromium browser.

Regards Zbynek

I have tried to copy Firefox profile from the other PC (where fonts are ok) and it did not help. Based on this I guess that any change in "about:config" won't help. So I have a few ideas what difference could be in the game: - Debian version (8 vs. 11) - installed (font) packages - hardware Both PCs use Xfce environment and https://www.checkpoint.com looks fine in Chromium browser. Regards Zbynek
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17668 izisombululo 159825 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I would assume that this is more a matter of GTK font settings in Linux that Firefox get from the OS about rendering and anti-aliasing (subpixel).

I would assume that this is more a matter of GTK font settings in Linux that Firefox get from the OS about rendering and anti-aliasing (subpixel).
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Is there any developer forum/list, where somebody can help me to debug it?

Thanks Zbynek

Is there any developer forum/list, where somebody can help me to debug it? Thanks Zbynek
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

So I can confirm that it brakes when upgrading from Debian 9 to 10.

Nothing to do with Firefox version.

So I can confirm that it brakes when upgrading from Debian 9 to 10. Nothing to do with Firefox version.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.