Search Support

Make Outlook use Firefox to open links contained in emails

  • 6 uphendule
  • 3 zinale nkinga
  • 21 views
  • Igcine ukuphendulwa ngu jscher2000

more options

In Outlook for Office 365 if I click to view an email in a web browser, it opens in Internet Explorer 11 or Microsoft Edge, neither of which I want to use. I haven't found any way of changing the default to Firefox. In the Office file association wizard I ought to be able to associate the file types .mht, .mhtml, .url etc with Firefox but my options seem to be locked down within Windows 10 Home. 'Choose where to get apps' is set to 'anywhere' but I'm forced towards the MS Store where Firefox is not acknowledged as an app. Surely I can solve this without having to switch to Windows 10 Pro? Grateful for all help.

Isisombululo esikhethiwe

Hi Kath, Firefox doesn't have a decoder for .mht files, so even if Windows let you send them to Firefox, the results would not be helpful.

Background

There is a special feature of Microsoft Office Outlook that it can reformulate some messages in a local file saved in MHTML format. The link is in the message header instead of the message itself.

Firefox does not make itself the default application for .mht files or the mhtml: protocol because Firefox cannot render them correctly. So it is normal not to see Firefox as an option for these files in Windows file type/protocol dialogs.

Older versions of Firefox supported legacy extensions that could decode and display MHT files, but as far as I know, that isn't an option for Firefox 57 and later -- unless there's a new add-on I don't know about.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

You need to set the firefox browser as your default web browser.

Windows-Settings > Apps > Standart-Apps Here you can set the firefox as your default browser...

I think that should work.

Okulungisiwe ngu Jonathan von Rhein

Helpful?

more options

Sorry, Jonathan, I should have made clear - Firefox is already set to be the default.

Helpful?

more options

This is a Microsoft issue, and as far as i can tell, it rather appears that it is not one they are going to fix. They "claim" that setting the default browser should work, while all the complaints for years say that it does not. Nor will they implement an exceedingly simple code for opening in *choose browser from list* in a right-click context menu.

-" 'Choose where to get apps' is set to 'anywhere' but I'm forced towards the MS Store where Firefox is not acknowledged as an app."

This would be irrelevant to your problem. I would imagine that FF is not being written and distributed as a "Metro App" or whatever MS wants to call this ridiculous app model these days.

-"Surely I can solve this without having to switch to Windows 10 Pro?"

No, you don't need to switch.

The URL "filetype" extension is generally handled by the system, you should not need to change that. FF does open as default browser in other situations, yes?

If the .mht, .mhtml, .html, extensions are not associated with Firefox, had you tried all the methods for changing these as shown, e.g., here: https://www.thewindowsclub.com/change-file-associations-windows AND are you logged in with an administrators group account? This may be necessary.

There is a small filetype managing utility shown on that page as well, which would be a good last resort before attempting a registry edit.

Hopefully changing these associations would rectify the issue.

Okulungisiwe ngu crankygoat

Helpful?

more options

I've already tried all the methods for changing the associations available withouth logging in as an administrator. As I haven't had to resort to that to solve any other issue, nor feel confident of attempting a registry edit or installing some freeware, I guess I'm stuck with the problem. Thanks anyway though crankygoat.

Helpful?

more options

Guess I will have to go back to Chrome, since it works there, just not in Firefox...oh well...another attempt to use Firefox has gone down in flames...

Helpful?

more options

Isisombululo Esikhethiwe

Hi Kath, Firefox doesn't have a decoder for .mht files, so even if Windows let you send them to Firefox, the results would not be helpful.

Background

There is a special feature of Microsoft Office Outlook that it can reformulate some messages in a local file saved in MHTML format. The link is in the message header instead of the message itself.

Firefox does not make itself the default application for .mht files or the mhtml: protocol because Firefox cannot render them correctly. So it is normal not to see Firefox as an option for these files in Windows file type/protocol dialogs.

Older versions of Firefox supported legacy extensions that could decode and display MHT files, but as far as I know, that isn't an option for Firefox 57 and later -- unless there's a new add-on I don't know about.

Okulungisiwe ngu jscher2000

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.