X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

firefox won't let me change search engine at all

Kuphostiwe

Question.. I have had zero issues in the past when searching things in firefox .. it would go automatically through google..now for somewhat reason it's using timewarner cable search and i've tired the preference button, clicked on search, but where it says default search engine its completely blank.. like no option comes up .. when i click on that box its a small blank box with zero options.. and it wont allow me to add anything.. any clue on what i can do?

Question.. I have had zero issues in the past when searching things in firefox .. it would go automatically through google..now for somewhat reason it's using timewarner cable search and i've tired the preference button, clicked on search, but where it says default search engine its completely blank.. like no option comes up .. when i click on that box its a small blank box with zero options.. and it wont allow me to add anything.. any clue on what i can do?

Okulungisiwe ngu robin.wildberger

Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:71.0) Gecko/20100101 Firefox/71.0

Eminye Imininingwane

evhenry
  • Top 25 Contributor
  • Administrator
33 izisombululo 190 izimpendulo
Kuphostiwe

Can you go to that page, about:preferences#search and scroll to the bottom box and click the button that says "Restore default search engines"? It should repopulate the search engines that'll then show up in the drop down.

If that isn't working, let me know.

Can you go to that page, about:preferences#search and scroll to the bottom box and click the button that says "Restore default search engines"? It should repopulate the search engines that'll then show up in the drop down. If that isn't working, let me know.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

evhenry said

Can you go to that page, about:preferences#search and scroll to the bottom box and click the button that says "Restore default search engines"? It should repopulate the search engines that'll then show up in the drop down. If that isn't working, let me know.

The "restore default search engines" button wont even let me click on it

I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine

''evhenry [[#answer-1272136|said]]'' <blockquote> Can you go to that page, about:preferences#search and scroll to the bottom box and click the button that says "Restore default search engines"? It should repopulate the search engines that'll then show up in the drop down. If that isn't working, let me know. </blockquote> The "restore default search engines" button wont even let me click on it I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine

Okulungisiwe ngu robin.wildberger

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17691 izisombululo 160067 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.

Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.

I tired both options you have given me .. i set it back to default theme, checked my hardware, found my profile folder and removed it and it did nothing .. i have tried the trouble shooting options but not fixing it its just the same ..

I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine

''cor-el [[#answer-1272145|said]]'' <blockquote> Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles Firefox will rebuild the search.json.mozlz4 file from the builtin search engines. </blockquote> I tired both options you have given me .. i set it back to default theme, checked my hardware, found my profile folder and removed it and it did nothing .. i have tried the trouble shooting options but not fixing it its just the same .. I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine

Okulungisiwe ngu robin.wildberger

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine

I have tried to add google by typing it in the address box and clicking the three dots next to the pocket button but it wont give me the option to save it as a search engine
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17691 izisombululo 160067 izimpendulo
Kuphostiwe

You can only add a search engine if you right-click in a search bar on a web page like the Google website (https://www.google.com), so you would have to type/paste this address in the location bar and press the enter key to open the Google website if you want to try out if you can add a new search engine this way. Then go the search bar on the Google website and right-click to find: "Add a Keyword for this Search".

Did you try my above suggestions ?

You can only add a search engine if you right-click in a search bar on a web page like the Google website (https://www.google.com), so you would have to type/paste this address in the location bar and press the enter key to open the Google website if you want to try out if you can add a new search engine this way. Then go the search bar on the Google website and right-click to find: "Add a Keyword for this Search". Did you try my above suggestions ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17691 izisombululo 160067 izimpendulo
Kuphostiwe

The only thing that is really weird about the HTML version of about:config is creating a new pref.

You need to type the full name in the search bar at the top and then select the type on the add/delete bar at the bottom of the page and then click the '+' button. That can be rather dangerous because if you click this plus button then you create a new pref with whatever you have typed in the search bar as the name. If you check that bar at the bottom in the Inspector then you see that this is just a table row (TR tag) just like the other entries on the page with only a different class name. There aren't any special access keys for this row AFAICT, so you would have to use the Tab key to get there.

The only thing that is really weird about the HTML version of about:config is creating a new pref. You need to type the full name in the search bar at the top and then select the type on the add/delete bar at the bottom of the page and then click the '+' button. That can be rather dangerous because if you click this plus button then you create a new pref with whatever you have typed in the search bar as the name. If you check that bar at the bottom in the Inspector then you see that this is just a table row (TR tag) just like the other entries on the page with only a different class name. There aren't any special access keys for this row AFAICT, so you would have to use the Tab key to get there.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.