Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

cant get java script on FF

more options

cant get java script on FF [latest version] , its enabled in about config. gumtree needs it apparently, gumtree says its refreshing browser to confirm java but it never happens . thanks

All Replies (8)

more options

hello, please try to refresh firefox and see if this can address the issue...

more options

Is the website asking for Java, or Javascript? They are two completely different things

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked

more options

its java script thanks

more options

cor-el said

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.
  • click the shield icon for more details and possibly disable the protection
You can check in the Web Console what content is blocked
more options

yes i use uBlock Origin) but how do i set it , if u know thanks

more options

cor-el said

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.
  • click the shield icon for more details and possibly disable the protection
You can check in the Web Console what content is blocked

i see that uBlock Origin) is NOT set to disable javascript thanks

more options

some of the more advanced settings have been moved to a different location in Firefox and are no longer accessible

from the standard "Settings" controls. 

Click into the Address Bar You now need to go to a special address to be able to change them. The Address Bar is at the top of the Firefox window.


Go to the Advanced Configuration url In the address bar, type in about:config and press enter


Accept the warning about changing settings Click the "I'll be careful, I promise" button. This warning will appear each time you visit about:config unless you untick the "Show this warning next time" button. We recommend keeping this box ticked to remind you each time!


You will now see the list of advanced settings

Type "javascript" into the "Search" box at the top to locate the setting you need to change


Find the "javascript.enabled" preference One of the settings which you can see should be called "javascript.enabled" in the "Preference Name" column,

"This is because it is not the default setting: the default setting is for "javascript.enabled" to be "true".

So that is the setting you need to change."

Toggle the false/true preference On the line for "javascript.enabled",

Right Click (or Command Click on Mac) on the 

"false" value, you will see a small menu appear, the top option is "Toggle". Click "Toggle",

and the "false" will change to "true".

Because "true" is the default setting, the entire line will no longer be in bold either.

Javascript is now enabled. Close the tab. click this link to confirm that, https://www.whatismybrowser.com/detect/is-javascript-enabled