X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox opens infinite number of tabs when loading SWF files from local file system

Kuphostiwe

Firefox 70.0.1 on Ubuntu Linux 18.04 will correctly open and play SWF files (e.g. Flash games) via HTTP(S) but when you open the same file from the local file system it keeps opening new tabs until you kill the program.

http://Flashgames/somegame.swf works

file:///www/Flashgames/somegame.swf turns Firefox into a tab forking bomb.

I have deleted the handlers.json file in the profle, but that only causes Firefox to ask with what EXTERNAL application this file should be opened (it does not play the file within the browser).

There is no application associated with *.swf files on the OS level.

Firefox 70.0.1 on Ubuntu Linux 18.04 will correctly open and play SWF files (e.g. Flash games) via HTTP(S) but when you open the same file from the local file system it keeps opening new tabs until you kill the program. http://Flashgames/somegame.swf works file:///www/Flashgames/somegame.swf turns Firefox into a tab forking bomb. I have deleted the handlers.json file in the profle, but that only causes Firefox to ask with what EXTERNAL application this file should be opened (it does not play the file within the browser). There is no application associated with *.swf files on the OS level.
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

Did you look at this pref on the about:config page?

  • plugins.http_https_only = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Did you look at this pref on the <b>about:config</b> page? *plugins.http_https_only = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

I tried it. No effect. I also started Firefox in "save mode" but that didn't make any difference, either.

I tried it. No effect. I also started Firefox in "save mode" but that didn't make any difference, either.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

You get an infinite number of tabs opening when you set Firefox to handle a specific file extension, you it looks that you once did this when you tried to open a SWF file in Firefox and got the 'open with' dialog instead. You should never do this, so you will have to remove this action.

You get an infinite number of tabs opening when you set Firefox to handle a specific file extension, you it looks that you once did this when you tried to open a SWF file in Firefox and got the 'open with' dialog instead. You should never do this, so you will have to remove this action. *https://support.mozilla.org/en-US/kb/Firefox+keeps+opening+many+tabs+or+windows
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

You get an infinite number of tabs opening when you set Firefox to handle a specific file extension, you it looks that you once did this when you tried to open a SWF file in Firefox and got the 'open with' dialog instead. You should never do this, so you will have to remove this action.

First off, thank you for responding, and what you write now makes sense: Firefox tries to open the designated media type using itself as the application to open it with. Looking at the settings I see that in my FF install this is indeed the case.

However, I would consider this behavior undesirable. Firstly, it is easy for a user to do what I did, with problematic results. If one should never do this, FF should either not allow it or warn against it. Secondly, why are files opened from a local file system handled differently from files opened via http?

By my personal definition, this should be classified as either a but or as a UI design flaw, and fixed in future updates. But that's just me.

That said, while this doesn't fix the problem it at least explains what's happening, so thank you. I appreciate it!

''cor-el [[#answer-1266823|said]]'' <blockquote> You get an infinite number of tabs opening when you set Firefox to handle a specific file extension, you it looks that you once did this when you tried to open a SWF file in Firefox and got the 'open with' dialog instead. You should never do this, so you will have to remove this action. </blockquote> First off, thank you for responding, and what you write now makes sense: Firefox tries to open the designated media type using itself as the application to open it with. Looking at the settings I see that in my FF install this is indeed the case. However, I would consider this behavior undesirable. Firstly, it is easy for a user to do what I did, with problematic results. If one should never do this, FF should either not allow it or warn against it. Secondly, why are files opened from a local file system handled differently from files opened via http? By my personal definition, this should be classified as either a but or as a UI design flaw, and fixed in future updates. But that's just me. That said, while this doesn't fix the problem it at least explains what's happening, so thank you. I appreciate it!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.