X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

user.js file not working for new preference

Kuphostiwe

I noticed that the secure URL padlock icon is now grey instead of green. This is intuitively wrong: it makes me think it's not really secure, so I found on another forum the about: config setting for this and changed it back to green. I have about 20 FF profiles across several devices, and these all share a common user.js file which I edit in a Dropbox folder and copy to all the profiles. I placed this setting into the common user.js file:

user_pref("security.secure_connection_icon_color_gray", false);

But it doesn't work. Do I have the syntax wrong, or is there another setting for this?

I noticed that the secure URL padlock icon is now grey instead of green. This is intuitively wrong: it makes me think it's not really secure, so I found on another forum the about: config setting for this and changed it back to green. I have about 20 FF profiles across several devices, and these all share a common user.js file which I edit in a Dropbox folder and copy to all the profiles. I placed this setting into the common user.js file: user_pref("security.secure_connection_icon_color_gray", false); But it doesn't work. Do I have the syntax wrong, or is there another setting for this?
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36 OPR/64.0.3417.92

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17566 izisombululo 158879 izimpendulo
Kuphostiwe

Did you confirm via about:config that the pref is actually set to false and that there isn't a problem with the user.js file?

Note that you can also set prefs via an autoconfig.cfg file for all profiles used by a specific Firefox installation.

Did you confirm via about:config that the pref is actually set to false and that there isn't a problem with the user.js file? Note that you can also set prefs via an autoconfig.cfg file for all profiles used by a specific Firefox installation. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

In about:config the pref remained at true. I checked the prefs.js file and the pref had not been copied from user.js. To check that the user.js file is not corrupt, I changed the setting of a random existing pref in user.js. This was copied correctly and was applied. So it's this particular pref that is not being copied.

Thank you for the information about autoconfig.cfg. I didn't know about that, so I'll try it.

In about:config the pref remained at true. I checked the prefs.js file and the pref had not been copied from user.js. To check that the user.js file is not corrupt, I changed the setting of a random existing pref in user.js. This was copied correctly and was applied. So it's this particular pref that is not being copied. Thank you for the information about autoconfig.cfg. I didn't know about that, so I'll try it.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.