Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't access Firefox Send

  • 4 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu McCoy

more options

On 9//11/19 and 10/11/19 I tried to access Firefox Send, but simply get message 'Something Went Wrong'. I even changed my password but the same thing happened. Can anyone please help. I am using Windows 7 on a public computer.

Isisombululo esikhethiwe

Was a cookies problem. Now solved, thanks.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Firefox Send uses a Firefox Account just like this SUMO forum and Sync. Are you possibly using any content blocking extensions that could cause this?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Also make sure you do not block cookies.

You should see all connected devices under "Devices & Apps" on the Firefox Account Settings page.

more options

Just in case the above doesn't do the trick :

Would you try this please :

Enter this URL in the address bar:

Then click on the padlock at the left side of the address bar.

Click on the little black arrow on the dropdown (next to "Connection secure") and then on "More Information".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Separate issue :

Your system details show that you need to update your Adobe Flash Player; you're running a very old version, which can cause problems.

Would you please uninstall your current version and install the latest version, which is

Uninstaller :

Note : some "extras" may be offered in the download.

Your system details also show that you're running an older
Firefox version (66.0) - any specific reason ?

(the current version is 70.0.1)

more options

Isisombululo Esikhethiwe

Was a cookies problem. Now solved, thanks.

more options

recoverymail123890 said

Was a cookies problem. Now solved, thanks.

                        My pleasure !