X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Screenshot not working for Bing

Kuphostiwe

Odd one this, but the built in screenshot feature on Firefox 70.0.1 will work on Bing serach results, all other sites I have tested it works fine. When clicked it simply does nothing at all. I have replicated this in Safemode for firefox also.

Now either this is an odd bug to do with Firefox, or Bing stops people from taking screenshots from within the browser as the Microsoft snip and sketch tool in windows 10 works fine.

Any ideas would be great, or if other users could try this themselves to see if they can replicate this and let me know if this is a wider issue or it's just me.

Thanks.

Odd one this, but the built in screenshot feature on Firefox 70.0.1 will work on Bing serach results, all other sites I have tested it works fine. When clicked it simply does nothing at all. I have replicated this in Safemode for firefox also. Now either this is an odd bug to do with Firefox, or Bing stops people from taking screenshots from within the browser as the Microsoft snip and sketch tool in windows 10 works fine. Any ideas would be great, or if other users could try this themselves to see if they can replicate this and let me know if this is a wider issue or it's just me. Thanks.

Isisombululo esikhethiwe

Hi again Paul, I haven't given up yet. I'm almost out of ideas right now, though. Maybe some of the other folks here will have something new to try.

It is a strange one. I can make a screenshot in the Web Console but not anywhere in the browser.

We'll get to the bottom of it.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

Plug ins- Just the default- OpenH264 Codec and the Widevine Content Decryption Module.

Add-ons- Honey, Grammerly, Privacy badger, HTTPS everywhere, Ublock origin, Lastpass, Onenote. I have however tesetd in safe mode with all add-ons disabled.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Eminye Imininingwane

My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

Hi Paul, It isn't just you. There's probably a high-tech explanation for it but, I think Bing search results are mostly links and Screenshot doesn't "see" anything except hyperlinks. If I need to do a screenshot of search results, I use Prt Sc and crop the image.

Hi Paul, It isn't just you. There's probably a high-tech explanation for it but, I think Bing search results are mostly links and Screenshot doesn't "see" anything except hyperlinks. If I need to do a screenshot of search results, I use ''Prt Sc'' and crop the image.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17589 izisombululo 159130 izimpendulo
Kuphostiwe

No problem here.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

No problem here. You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

@cor-el, I tried a new profile - Set Bing as default search engine Searched for "Firefox" Still can't Screenshot Bing search results.

@cor-el, I tried a new profile - Set Bing as default search engine Searched for "Firefox" Still can't Screenshot Bing search results.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
the-edmeister
  • Top 25 Contributor
  • Moderator
5412 izisombululo 40317 izimpendulo
Kuphostiwe

My_Cheese_Is_Slippin' said

@cor-el, I tried a new profile - Set Bing as default search engine Searched for "Firefox" Still can't Screenshot Bing search results.

Just a thought ... Are you doing the search from the NewTab page or the HomePage?

''My_Cheese_Is_Slippin' [[#answer-1265667|said]]'' <blockquote> @cor-el, I tried a new profile - Set Bing as default search engine Searched for "Firefox" Still can't Screenshot Bing search results. </blockquote> Just a thought ... Are you doing the search from the NewTab page or the HomePage?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

From the Firefox Home page search bar. I also tried going to Bing home page and got the same results.

From the Firefox Home page search bar. I also tried going to Bing home page and got the same results.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17589 izisombululo 159130 izimpendulo
Kuphostiwe

I used the location bar (@bing firefox) and "Take screenshot" in the right-click context menu and via Page actions.

Anything related in the Web Console?

  • "3-bar" menu button or Tools -> Web Developer
I used the location bar (@bing firefox) and "Take screenshot" in the right-click context menu and via Page actions. Anything related in the Web Console? *"3-bar" menu button or Tools -> Web Developer
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

I can't get any technique to work. Web console shows one warning:

Empty string passed to getElementById().

I can't get any technique to work. Web console shows one warning: Empty string passed to getElementById().
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

Sorry. In the new profile I get three warnings:

Empty string passed to getElementById().

Use of Mutation Events is deprecated. Use MutationObserver instead.

The script from “https://4.bing.com/ipv6test/test” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.

Sorry. In the new profile I get three warnings: Empty string passed to getElementById(). Use of Mutation Events is deprecated. Use MutationObserver instead. The script from “https://4.bing.com/ipv6test/test” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thank's for the answers so far, and thanks for testing. Very strange one this. Do we have any direction to go now as far as testing?

Thank's for the answers so far, and thanks for testing. Very strange one this. Do we have any direction to go now as far as testing?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Hi again Paul, I haven't given up yet. I'm almost out of ideas right now, though. Maybe some of the other folks here will have something new to try.

It is a strange one. I can make a screenshot in the Web Console but not anywhere in the browser.

We'll get to the bottom of it.

Hi again Paul, I haven't given up yet. I'm almost out of ideas right now, though. Maybe some of the other folks here will have something new to try. It is a strange one. I can make a screenshot in the Web Console but not anywhere in the browser. We'll get to the bottom of it.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Yeah, it's not a massive issue, it's one of those niggly little ones that's small and annoying. I'm new(ish) to firefox after many years using Chrome (Used firefox, then years back changed to chrome, then got sick of Google and their practises so came home to Mozilla to find out how great their products are now) so under the hood stuff is better handled by people like yourself who knows better what they are doing.

There will be a bottom of it, and I know you or someone will find it!

Yeah, it's not a massive issue, it's one of those niggly little ones that's small and annoying. I'm new(ish) to firefox after many years using Chrome (Used firefox, then years back changed to chrome, then got sick of Google and their practises so came home to Mozilla to find out how great their products are now) so under the hood stuff is better handled by people like yourself who knows better what they are doing. There will be a bottom of it, and I know you or someone will find it!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 izisombululo 1024 izimpendulo
Kuphostiwe

Hello again Paul, I still haven't found a way to take a screenshot but, recently, I noticed that when Bing loads search results and you try to copy text from a synopsis it is treated as an image and takes you up to the image search at the top.

I guess "Odd" wasn't good enough...

Hello again Paul, I still haven't found a way to take a screenshot but, recently, I noticed that when Bing loads search results and you try to copy text from a synopsis it is treated as an image and takes you up to the image search at the top. I guess "Odd" wasn't good enough...
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Ha, no probs man.

Not a big deal, I'm betting it's something M$ has done with their site. Maybe to stop people taking screenshots?

Ha, no probs man. Not a big deal, I'm betting it's something M$ has done with their site. Maybe to stop people taking screenshots?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.