X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

how to stop new tabs from opening while scrolling through a webpage?

Kuphostiwe

WHile browsing a webpage such as Facebook new tabs are automatically opened in a new tab.

WHile browsing a webpage such as Facebook new tabs are automatically opened in a new tab.
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 31.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Eminye Imininingwane

WestEnd 60 izisombululo 5387 izimpendulo
Kuphostiwe

I doubt that is coming from firefox but from FB doing that. I haven't seen that happen when using firefox.

I doubt that is coming from firefox but from FB doing that. I haven't seen that happen when using firefox.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
jscher2000
  • Top 10 Contributor
8785 izisombululo 71851 izimpendulo
Kuphostiwe

Hi jerryjsimons, what kind of things are opening? For example, items from your news feed, random advertisements, disturbing pages, etc.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi jerryjsimons, what kind of things are opening? For example, items from your news feed, random advertisements, disturbing pages, etc. Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17567 izisombululo 158896 izimpendulo
Kuphostiwe

Note that some pages automatically load extra content if you scroll down. It sounds that in your case this new content is loaded in new tabs.-


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Note that some pages automatically load extra content if you scroll down. It sounds that in your case this new content is loaded in new tabs.- ----- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks for your suggestions. I have tried them all and none have a corrrective effect.

You ask what "what kind of things are opening?"

If I am on my Facebook home page and begin scrooling, new tabs open re to the post I just scrolled over.

If I am on an Amazon page that shows a number of items and begin viwing them, a new tab open showing the specific item I just scrolled over.

Thanks for your suggestions. I have tried them all and none have a corrrective effect. You ask what "what kind of things are opening?" If I am on my Facebook home page and begin scrooling, new tabs open re to the post I just scrolled over. If I am on an Amazon page that shows a number of items and begin viwing them, a new tab open showing the specific item I just scrolled over.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Bogdan Mihai 0 izisombululo 2 izimpendulo
Kuphostiwe

Hi jerryjsimons,

Can you try to replace the mouse and scroll ?

It looks like your scroll button is defect and it's also clicking randomly on the posts from your feed which are opened in new tabs.

"Open in new-tab" is default action for mouse middle-click.

Let me know if this solution worked.

Hi jerryjsimons, Can you try to replace the mouse and scroll ? It looks like your scroll button is defect and it's also clicking randomly on the posts from your feed which are opened in new tabs. "Open in new-tab" is default action for mouse middle-click. Let me know if this solution worked.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8785 izisombululo 71851 izimpendulo
Kuphostiwe

jerryjsimons said

If I am on my Facebook home page and begin scrooling, new tabs open re to the post I just scrolled over.
If I am on an Amazon page that shows a number of items and begin viwing them, a new tab open showing the specific item I just scrolled over.

That's definitely not normal. Links should only open if you click them. There are times that Firefox may retrieve links in the background to accelerate loading, but they shouldn't be made visible.

Try turning off the pre-fetching features:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste prefetch and pause while the list is filtered

(3) Double-click the network.prefetch-next preference to switch the value from true to false

(4) If the network.predictor.enable-prefetch preference is bolded and "modified" to true, double-click it to restore the default value of false

(5) Double-click the network.dns.disablePrefetch preference to switch the value from false (enabled) to true (disabled)

''jerryjsimons [[#answer-1265186|said]]'' <blockquote> If I am on my Facebook home page and begin scrooling, new tabs open re to the post I just scrolled over. <br> If I am on an Amazon page that shows a number of items and begin viwing them, a new tab open showing the specific item I just scrolled over. </blockquote> That's definitely not normal. Links should only open if you click them. There are times that Firefox may retrieve links in the background to accelerate loading, but they shouldn't be made visible. Try turning off the pre-fetching features: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''prefetch''' and pause while the list is filtered (3) Double-click the '''network.prefetch-next''' preference to switch the value from true to false (4) If the '''network.predictor.enable-prefetch''' preference is bolded and "modified" to true, double-click it to restore the default value of false (5) Double-click the '''network.dns.disablePrefetch''' preference to switch the value from false (enabled) to true (disabled)
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.