X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox 70 show empty tab bar. How to hide it again?

Kuphostiwe

Since updating to Firefox 70, the tab bar is shown even if there is only one tab (it just shows the + button then). Previously, the bar was hidden if there was only one tab. This previous behavior may depend on some setting, but I don't remember if I changed any setting for that. Have *no* Add-ons installed that affect tab visibility.

How to restore the old behaviour that tab bar is hidden if there is only one tab?

Since updating to Firefox 70, the tab bar is shown even if there is only one tab (it just shows the + button then). Previously, the bar was hidden if there was only one tab. This previous behavior may depend on some setting, but I don't remember if I changed any setting for that. Have *no* Add-ons installed that affect tab visibility. How to restore the old behaviour that tab bar is hidden if there is only one tab?

Isisombululo esikhethiwe

It's not difficult to remove the + button as well, but does that help?

/* Hide solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] {
  visibility: collapse;
}
/* Hide New Tab Button immediately next to solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + toolbarbutton {
  visibility: collapse;
}
Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:70.0) Gecko/20100101 Firefox/70.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8886 izisombululo 72693 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi xmarks1, Firefox hasn't had a setting to hide the tab bar with only one tab for a really long time. But you may have been using custom style rules in an optional userChrome.css file to accomplish that. Is that possible?

You probably can find an updated "recipe" on the following site:

https://www.reddit.com/r/FirefoxCSS/

Hi xmarks1, Firefox hasn't had a setting to hide the tab bar with only one tab for a really long time. But you may have been using custom style rules in an optional '''userChrome.css''' file to accomplish that. Is that possible? You probably can find an updated "recipe" on the following site: https://www.reddit.com/r/FirefoxCSS/
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17773 izisombululo 160751 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You would need code in userChrome.css to hide the Tab bar with only one tab visible. If this code isn't working then you need to look for an update for Firefox 70.

Did this still work properly in Firefox 69 ?


In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

You would need code in userChrome.css to hide the Tab bar with only one tab visible. If this code isn't working then you need to look for an update for Firefox 70. Did this still work properly in Firefox 69 ? ---- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true *https://www.userchrome.org/firefox-changes-userchrome-css.html
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Ah, right. It is in userChrome.css:

#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] { visibility: collapse; }

This worked until Firefox 69. toolkit.legacyUserProfileCustomizations.stylesheets is enabled.

Ah, right. It is in userChrome.css: &#35;tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] { visibility: collapse; } This worked until Firefox 69. toolkit.legacyUserProfileCustomizations.stylesheets is enabled.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8886 izisombululo 72693 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

It's not difficult to remove the + button as well, but does that help?

/* Hide solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] {
  visibility: collapse;
}
/* Hide New Tab Button immediately next to solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + toolbarbutton {
  visibility: collapse;
}
It's not difficult to remove the + button as well, but does that help? <pre>/* Hide solo tab */ #tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] { visibility: collapse; } /* Hide New Tab Button immediately next to solo tab */ #tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + toolbarbutton { visibility: collapse; } </pre>
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Yeah, that works. Thanks a lot!

Actually there was some more code, which I forgot to post:

#tabbrowser-tabs .tabs-newtab-button { visibility: collapse; } #tabbrowser-tabs, #tabbrowser-tabs > .tabbrowser-arrowscrollbox { min-height: 0 !important; }

And the first one of those is the one which no longer works with FF 70. So the .tabs-newtab-button needed to be replaced by tab + toolbarbutton.

Yeah, that works. Thanks a lot! Actually there was some more code, which I forgot to post: &#35;tabbrowser-tabs .tabs-newtab-button { visibility: collapse; } &#35;tabbrowser-tabs, #tabbrowser-tabs > .tabbrowser-arrowscrollbox { min-height: 0 !important; } And the first one of those is the one which no longer works with FF 70. So the <code>.tabs-newtab-button</code> needed to be replaced by <code>tab + toolbarbutton</code>.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8886 izisombululo 72693 izimpendulo
Kuphostiwe

There's probably a slight modification to .tabs-newtab-button class name in the latest version that would still work, but I'm not going to look it up at this point...

There's probably a slight modification to .tabs-newtab-button class name in the latest version that would still work, but I'm not going to look it up at this point...
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17773 izisombululo 160751 izimpendulo
Kuphostiwe

This is no longer a class name, but has changed to an id: #tabs-newtab-button {}

This is no longer a class name, but has changed to an id: #tabs-newtab-button {}
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.