Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Tab bar has moved down into webpages so titles no longer visible.

more options

One day the tab titles partially dropped down off the black strip of the tab bar into the web pages. It is now very hard to read the titles. How do I get them back up? Thanks for your help.

Ama-screenshot ananyekiwe

All Replies (20)

more options

Are you using a userChrome.css file with code for the Tab bar?

If that is the case then you need updated code for Firefox 70.

What code do you currently have in userChrome.css if you use this file?

more options

Thanks for taking the time to reply, Cor-el. I don't use any code with the tab bar. I haven't adjusted it myself at all. This change occurred spontaneously on its own.

more options

You can start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks Cor-el. I started in safe mode and the tabs went to the very top with the names wholly inside the black bar. So, as desired, albiet in the wrong place. I was already in default theme but restarted as usual anyway. The problem remained. Both "Use recommended performance settings" and hardware acceleration were already set to off. I disabled all extensions, restarted as normal. Problem remained.

Can anything else be done?

more options

You didn't clarify whether you have a userChrome.css or do not have this file in the chrome folder. Firefox Safe Mode disables userChrome.css and userContent.css, so if you have the file then that might explain the difference in Safe Mode. Code in userChrome.css to affects the position of the Tab bar needs to be changed in Firefox 70 to work properly.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Ah, yes. Apologies. I do have a userChrome.css file in my chrome folder. What should I do now? Thank you for your time, btw. I appreciate it.

more options

Can you post the content of your userChrome.css or possibly upload and post the link if the file is too big ?

more options
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* TABS: on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000!important}

#TabsToolbar {
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}
#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {padding-bottom: var(--tab-min-height) !important;}

/* TABS: height */
:root {
 --tab-toolbar-navbar-overlap: 0px !important;
 --tab-min-height: 27px !important; /* 30 */
}
:root #tabbrowser-tabs {
 --tab-min-height: 27px !important; /* 30 */
 --tab-min-width: 80px !important;
}

#TabsToolbar {
 height: var(--tab-min-height) !important;
 margin-bottom: 1px !important;
 box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important;
}

#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

/* drag space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 40px;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}
#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}
#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

Okulungisiwe ngu cor-el

more options

You need at least to add a "display: block" rule to this section:

#TabsToolbar {
 display: block !important;
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
}
more options

Thanks, Cor-el. I'll look up how to do that (I just tried to add it in to the document that opened when I clicked to copy for you and nothing happened) and will let you know if that does the trick.

more options

I added that, restarted. Problem remains. Hmm.

more options

Try to replace this code with the code further down to pull up the tab bar.

Current code:

#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {
 padding-bottom: var(--tab-min-height) !important;
}

New code:

:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
  bottom: var(--tab-min-height) !important;
  padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/
}

:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/
}

A problem on Mac is usually the placement of the three colored buttons. Your screenshot didn't show their position (on the title bar?).

See also my reply in this thread.

more options

Adding the new code made no difference, unfortunately. Screen shot of three coloured buttons attached. I've got the your other thread open and will try replacing my entire code with that. I presume that's what you mean.

more options

Oh dear! This is even worse. I cannot read the tabs at all now. If the website is white, it's possible to see the tab names but they haven't shifted back up into the proper position on the black tab strip.

more options

You can adjust the - 20px value (might be positive or negative) to position the Tab bar in the space where it should be.

:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
  bottom: var(--tab-min-height) !important;
  padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/
}

To position the colored caption buttons you can modify the value of the --caption-buttons-adjust variable.

/* caption buttons - adjust to position the caption buttons in the correct space */
:root {--caption-buttons-adjust: 20px !important}  /*adjust to position the caption buttons*/

:root[tabsintitlebar]:not([inFullscreen="true"]) #toolbar-menubar[autohide="true"]
 ~ #TabsToolbar .titlebar-buttonbox-container {
  display: block !important;
  position: fixed !important;
  left: 0 !important; /* left:0 for Mac; right:0 for other platforms */
  top: calc(var(--tab-min-height) + var(--caption-buttons-adjust));
  visibility: visible !important;
  /* height: var(--tab-min-height) !important; */
}
more options

Firefox is being very recalcitrant. Changing the values does nothing. Initially I used small values eg -40 but nothing changed with each restart. I went as low as -600 and as high as 1000 with the tab min height. I took the caption buttons to 1000. Nothing. Have changed them back to the original values. I don't even remember where the coloured buttonas are supposed to be, it's been so long.

more options

Anne said

Firefox is being very recalcitrant. Changing the values does nothing.

Firefox needs to be closed before saving the edited userChrome.css file, otherwise your edits won't be saved.

more options

Yes. I restarted every time and also checked to ensure the changed code had saved. Thanks for sticking with this, Cor-el.

more options

Anne said

Thanks for sticking with this, Cor-el.

and The Edmeister

more options

I am also facing an issue while using mozilla. When i try to open http://bit.ly/2lU9dyG in firefox, the page start lagging and does work well whereas in other browsers it work fine. Do you an idea about the problem. thanks

  1. 1
  2. 2