Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Version 70.0

more options

Hello all, since the new update 70.0 Firefox will not start up at all! I keep clicking on the icon and nothing happens. But after clicking on it a bazillion times it will finally come up. Ive had to switch back to Safari to get my work done. What is the problem and how can I fix it? I run Mac OSX -El Capitan v10.11.6. I never had a problem until this last update with Firefox. Thanks very much in advance for any insight with this problem.

All Replies (7)

more options

Hi SunnySkyez, did the icon seem to indicate Firefox was trying to load all that time or was it just not even responding in any way?

When Firefox finally did show itself, did it work, or is it not working, either?

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Im replying back to you in safari as FF isn't working. I will start from the beginning with more info on what happened and what I did since your post.

**Brief descrip. of what first happened:

When starting a prog on Mac, there is a little black dot next to the App icon, that will flash until the program starts then it stays solid: See the little black dot to the left of the icon app. see pic 1

A couple minutes later when it did come up it was just the tool bar:

see pic 2

When it came up a little bit more I got just a white screen with a tool bar and tab: See picture 3

Today: I haven’t been able to get it to do the above again. I got safe mode to come up once. I didn’t know what I supposed to see in my preferences but in your explanation of safe mode’s temp deactivation, I recognized the words “hardware acceleration”. I remember having a problem a few months back and someone from the forum said to uncheck that box. So today while in safe mode noticed the acceleration box was checked. I then got out of safe mode and clicked on the FF- app it started right up. I went to my preferences and saw that the hardware acceleration was checked again, which must have happened when the new update loaded? I uncheck the acceleration box and I restarted my mac to see if FF would load up with the uncheck acceleration box, now I can’t even get safe mode back. Ive been working on this for 2 hours now and Im totally ticked off. Anymore ideas?

more options

Unfortunately, I'm not familiar enough with MacOS to provide specific troubleshooting suggestions.

If it becomes necessary, this article describes how to downgrade to a previous version: Install an older version of Firefox.

more options

While yes I had to download to version 68 and now Im at cruising speed, it still doesnt fix the version 70 problem. So I cant honestly mark this as totally resolved as I was going to downgrade as the last resort.

Oh and while you may have to downgrade as I did, do not be intimidated by Fire Fox's scary warning of security problems by rolling back. The only scary problems are with the new FF updates. IMHO. If they put out an update and it doesnt work for people, they need to FIX it or dont put out any new versions. And Fire Fox shouldnt drop the ball by relying on its users to fix their problems. I love Fire Fox and have been with them since they started, but when you screw with my surfing I draw the line. Oh and I save all my dmgs for just such occasions.

One more note, when you do downgrade, you will be asked to create a new profile, dont be scared. All you need to do download the older dmg then load it up. Next sign in with your original email follow through with your password. Then go to your add on's page and everything you had before just kinda reloads for ya. You dont lose your bookmarks either. I also unchecked the update versions box in preferences and reset it to ask and I will decide. Wont burn me twice on that one.

So, Im back and now happy even though I had to spend hours of wasted time.

more options

you can find solution from this link [ https://support.mozilla.org/en-US/kb/firefox-wont-start-find-solutions] thank you

more options

Not one to give up because I love my mac and I love FireFox. I found the best solution for my macbook and this problem, was to simply remove FireFox with my Mac App Cleaner, then reload a fresh FireFox 7.0 and after a couple of very slow load ups it started working again just fine.

So if you have a macbook this worked for me: download a copy of the Mac App Cleaner, remove everything even playlists that arent checked on the App Cleaner removal list. Then go to FF and download their latest version, in my case it was 70.0, load it back up and you should be golden. I really didnt need to do much more as FF still had my info, like my themes, bookmarks, and add ons. Mac App Cleaner can be found at the Mac App Store or here at Mac UpDate: https://www.macupdate.com/app/mac/25276/appcleaner .

I hope this helps others who have had my problem. Cheers!

Okulungisiwe ngu SunnySkyez

more options