X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Narrator button missing in reader view

Kuphostiwe

Issue: As per the title, whenever I open up a page in reader view, there is no narrate button. However, in a new profile, there is said button and it works fine. It is only on my current profile.

Methods Tried: -Toggling 'Prevent accessibility services from accessing your browser'(about:preferences#privacy), narrate.enabled and extensions.pocket.enabled. -Restarting Firefox with all extensions disabled (via about:profiles).

Additional notes:

As I have tried disabling all extensions to no avail, I've concluded that the issue lies with Firefox's configuration, which might have been changed by some extensions or by me (following guide at privacytools.io).

Request: Can I know of all settings (including about:config) that can cause the narrate function to be disabled? If not, is there anything I can do other than to switch to a new profile or refreshing Firefox? I don't really want to reconfigure everything. Thanks in advance.

Issue: As per the title, whenever I open up a page in reader view, there is no narrate button. However, in a new profile, there is said button and it works fine. It is only on my current profile. Methods Tried: -Toggling 'Prevent accessibility services from accessing your browser'(about:preferences#privacy), narrate.enabled and extensions.pocket.enabled. -Restarting Firefox with all extensions disabled (via about:profiles). Additional notes: As I have tried disabling all extensions to no avail, I've concluded that the issue lies with Firefox's configuration, which might have been changed by some extensions or by me (following guide at privacytools.io). Request: Can I know of all settings (including about:config) that can cause the narrate function to be disabled? If not, is there anything I can do other than to switch to a new profile or refreshing Firefox? I don't really want to reconfigure everything. Thanks in advance.

Okulungisiwe ngu helloandthegoodbye

Isisombululo esikhethiwe

Try to disable Resist Fingerprinting if you have this currently enabled.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

Authenticator Bitwarden - Free Password Manager CanvasBlocker Cookie AutoDelete Decentraleyes Emsisoft Browser Security Facebook Container Firefox Multi-Account Containers Grammar and Spell Checker - LanguageTool History Cleaner HTTPS Everywhere Nano Adblocker Nano Defender Popup Blocker (strict) Privacy Badger Privacy Settings uMatrix

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.2 Safari/605.1.15

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Definitely you need narrate.enabled to be true, and also this one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste websp and pause while the list is filtered

(3) If the media.webspeech.synth.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true

Ref. https://developer.mozilla.org/docs/Web/API/Web_Speech_API/Using_the_Web_Speech_API#Browser_support_2

Does that work on yours?

Definitely you need '''narrate.enabled''' to be true, and also this one: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''websp''' and pause while the list is filtered (3) If the '''media.webspeech.synth.enabled''' preference is bolded and "modified" to false, double-click it to restore the default value of true Ref. https://developer.mozilla.org/docs/Web/API/Web_Speech_API/Using_the_Web_Speech_API#Browser_support_2 Does that work on yours?
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Do you remember what privacy changes you made from suggestions on that website?

Did you try to rename prefs.js (prefsOLD.js) to see if this is about modified prefs ?

You can try to compare the prefs.js files in both profiles to see if any important prefs are modified.

Do you remember what privacy changes you made from suggestions on that website? Did you try to rename prefs.js (prefsOLD.js) to see if this is about modified prefs ? You can try to compare the prefs.js files in both profiles to see if any important prefs are modified.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

If you adopted the user.js file from Ghacks, then it includes flipping the preference I mentioned:

https://github.com/ghacksuserjs/ghacks-user.js/blob/master/user.js#L1536

If you adopted the user.js file from Ghacks, then it includes flipping the preference I mentioned: https://github.com/ghacksuserjs/ghacks-user.js/blob/master/user.js#L1536
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

If the media.webspeech.synth.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true.

I tried looking into that, but it is set to true.

Do you remember what privacy changes you made from suggestions on that website?

Basically all of them (webgl, XOriginPolicy, drm related settings, cookieBehaviour) (except ghacks-user.js)

Did you try to rename prefs.js (prefsOLD.js) to see if this is about modified prefs ?

Yes, and that worked. Narrate button is visible and working.

You can try to compare the prefs.js files in both profiles to see if any important prefs are modified.

I found an interesting setting called dom.webaudio.enabled which is set to false, but when I set it to true, nothing regarding my issue is solved.

Just an interesting observation, when I inspect the reader view webpage, I found out that the button has been hidden and that I can unhide it. However, it does not work and the dropdown menu showing all available voices cannot be opened. Another thing to note is that extensions relying on the html5 TTS api does not work (Text to Speech (TTS) by morni colhkher), even with webspeech option enabled, suggesting that the browser cannot access system TTS services.

I dunno. I’m a novice when it comes to such things.

<blockquote> If the media.webspeech.synth.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true.</blockquote> I tried looking into that, but it is set to true. <blockquote> Do you remember what privacy changes you made from suggestions on that website?</blockquote> Basically all of them (webgl, XOriginPolicy, drm related settings, cookieBehaviour) (except ghacks-user.js) <blockquote> Did you try to rename prefs.js (prefsOLD.js) to see if this is about modified prefs ?</blockquote> Yes, and that worked. Narrate button is visible and working. <blockquote> You can try to compare the prefs.js files in both profiles to see if any important prefs are modified.</blockquote> I found an interesting setting called dom.webaudio.enabled which is set to false, but when I set it to true, nothing regarding my issue is solved. Just an interesting observation, when I inspect the reader view webpage, I found out that the button has been hidden and that I can unhide it. However, it does not work and the dropdown menu showing all available voices cannot be opened. Another thing to note is that extensions relying on the html5 TTS api does not work (Text to Speech (TTS) by morni colhkher), even with webspeech option enabled, suggesting that the browser cannot access system TTS services. I dunno. I’m a novice when it comes to such things.

Okulungisiwe ngu helloandthegoodbye

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Try to disable Resist Fingerprinting if you have this currently enabled.

Try to disable Resist Fingerprinting if you have this currently enabled. *privacy.resistFingerprinting = false *https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

Try to disable Resist Fingerprinting if you have this currently enabled.

It worked! Thank you very much!

''cor-el [[#answer-1260026|said]]'' <blockquote> Try to disable Resist Fingerprinting if you have this currently enabled. *privacy.resistFingerprinting = false *https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting </blockquote> It worked! Thank you very much!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.