X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

YouTube causes high CPU load in Firefox

Kuphostiwe

Hello,

When watching videos on YouTube, Firefox begins to use up to 50% my CPU. This only occurs when I select the youtube tab. Weirdly, the same does not happen if I start Firefox in safe mode, although it does happen if I start Firefox normally and disable ALL addons. If anyone has a clue what to do, please share it.

Hello, When watching videos on YouTube, Firefox begins to use up to 50% my CPU. This only occurs when I select the youtube tab. Weirdly, the same does not happen if I start Firefox in safe mode, although it does happen if I start Firefox normally and disable ALL addons. If anyone has a clue what to do, please share it.

Okulungisiwe ngu florian2833z

Isisombululo esikhethiwe

I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar.

When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem.

Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists.

If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

1Password extension (desktop app required) 4.7.5.90 true onepassword4@agilebits.com Amazon.de 1.1 true amazon@search.mozilla.org Bing 1.0 true bing@search.mozilla.org DuckDuckGo 1.0 true ddg@search.mozilla.org eBay 1.0 true ebay@search.mozilla.org Ecosia 1.0 true ecosia@search.mozilla.org Facebook Container 2.0.3 true @contain-facebook Google 1.0 true google@search.mozilla.org HTTPS Everywhere 2019.6.27 true https-everywhere@eff.org LEO Eng-Deu 1.0 true leo_ende_de@search.mozilla.org NoScript 11.0.3 true {73a6fe31-595d-460b-a920-fcc0f8843232} Stylus 1.5.6 true {7a7a4a92-a2a0-41d1-9fd7-1e92480d612d} uBlock Origin 1.22.4 true uBlock0@raymondhill.net Wikipedia (de) 1.0 true wikipedia@search.mozilla.org Adblock Plus - kostenloser Adblocker 3.6.3 false {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Adobe Acrobat 18.0.10 false web2pdfextension.17@acrobat.adobe.com CanvasBlocker 0.5.14 false CanvasBlocker@kkapsner.de Cookie Manager 1.5 false cookie-manager@robwu.nl Enhancer for YouTube™ 2.0.98.2 false enhancerforyoutube@maximerf.addons.mozilla.org Firefox Color 2.1.5 false FirefoxColor@mozilla.com LastPass: Free Password Manager 4.35.0.3 false support@lastpass.com Tampermonkey 4.9.5941 false firefox@tampermonkey.net uMatrix 1.4.0 false uMatrix@raymondhill.net User-Agent Switcher 0.2.6 false {75afe46a-7a50-4c6b-b866-c43a1075b071} YouTube High Definition 68.0.2 false {7b1bf0b6-a1b9-42b0-b75d-252036438bdc}

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 izisombululo 871 izimpendulo
Kuphostiwe

Hi florian2833z, Safe Mode also temporarily disables hardware acceleration.

Check that your graphics driver is up to date and/or disable hardware acceleration in your Options -> General page -> Performance section. Uncheck Use recommended performance settings and you'll see Use hardware acceleration when available.

Hi florian2833z, Safe Mode also temporarily disables hardware acceleration. Check that your graphics driver is up to date and/or disable hardware acceleration in your Options -> General page -> Performance section. Uncheck Use recommended performance settings and you'll see Use hardware acceleration when available.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hey,

Thanks for the quick reply. Unfortunately, this does not fix the high cpu usage. Is there anything else that is changed when using safe mode?

Hey, Thanks for the quick reply. Unfortunately, this does not fix the high cpu usage. Is there anything else that is changed when using safe mode?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 izisombululo 871 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar.

When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem.

Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists.

If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.

I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar. When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem. Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists. If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 izisombululo 871 izimpendulo
Kuphostiwe

Firefox also has a built-in Task Manager which might help you determine a faulty add-on.

Click on the 3-bar Menu button Select More Select Task Manager

or type about:performance in the address bar and press enter.

Firefox also has a built-in Task Manager which might help you determine a faulty add-on. Click on the 3-bar Menu button Select More Select Task Manager or type about:performance in the address bar and press enter.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17517 izisombululo 158410 izimpendulo
Kuphostiwe

You can try to disable VP9 via the about:config page.

  • media.wmf.vp9.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can try to disable VP9 via the <b>about:config</b> page. *media.wmf.vp9.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

You can try to disable VP9 via the about:config page.
  • media.wmf.vp9.enabled = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Thank you for this info, I disabled vp9 via config, restartet firefox and still youtube shows vp9 as currently used codec. Is this a bug?

''cor-el [[#answer-1259662|said]]'' <blockquote> You can try to disable VP9 via the <b>about:config</b> page. *media.wmf.vp9.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox </blockquote> Thank you for this info, I disabled vp9 via config, restartet firefox and still youtube shows vp9 as currently used codec. Is this a bug?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

My_Cheese_Is_Slippin' said

Firefox also has a built-in Task Manager which might help you determine a faulty add-on. Click on the 3-bar Menu button Select More Select Task Manager or type about:performance in the address bar and press enter.

I already tried the taskmanager, but it doesn't show cpu usage per tab or addon, at least I haven't found it yet. It only shows how much power is used by tab and weirdly it says that youtube consumes "medium" energy, although CPU is up to 50%.

''My_Cheese_Is_Slippin' [[#answer-1259622|said]]'' <blockquote> Firefox also has a built-in Task Manager which might help you determine a faulty add-on. Click on the 3-bar Menu button Select More Select Task Manager or type about:performance in the address bar and press enter. </blockquote> I already tried the taskmanager, but it doesn't show cpu usage per tab or addon, at least I haven't found it yet. It only shows how much power is used by tab and weirdly it says that youtube consumes "medium" energy, although CPU is up to 50%.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

My_Cheese_Is_Slippin' said

I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar. When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem. Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists. If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.

Ha, you were right! I had to disable Stylus (https://addons.mozilla.org/en-US/firefox/addon/styl-us/) and then restart Firefox and that did the trick! My CPU is not at 50% all the time anymore, thank you. What I don't understand tho is why Stylus is a recommended addon. I guess it's only my setup (stlyes) or something like that.

''My_Cheese_Is_Slippin' [[#answer-1259619|said]]'' <blockquote> I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar. When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem. Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists. If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem. </blockquote> Ha, you were right! I had to disable Stylus (https://addons.mozilla.org/en-US/firefox/addon/styl-us/) and then restart Firefox and that did the trick! My CPU is not at 50% all the time anymore, thank you. What I don't understand tho is why Stylus is a recommended addon. I guess it's only my setup (stlyes) or something like that.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

florian2833z said

My_Cheese_Is_Slippin' said
I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar. When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem. Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists. If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.

Ha, you were right! I had to disable Stylus (https://addons.mozilla.org/en-US/firefox/addon/styl-us/) and then restart Firefox and that did the trick! My CPU is not at 50% all the time anymore, thank you. What I don't understand tho is why Stylus is a recommended addon. I guess it's only my setup (stlyes) or something like that.

Specifically, it was this certain style: https://userstyles.org/styles/164882/rainbowtube

Problem solved!

''florian2833z [[#answer-1259704|said]]'' <blockquote> ''My_Cheese_Is_Slippin' [[#answer-1259619|said]]'' <blockquote> I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar. When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem. Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists. If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem. </blockquote> Ha, you were right! I had to disable Stylus (https://addons.mozilla.org/en-US/firefox/addon/styl-us/) and then restart Firefox and that did the trick! My CPU is not at 50% all the time anymore, thank you. What I don't understand tho is why Stylus is a recommended addon. I guess it's only my setup (stlyes) or something like that. </blockquote> Specifically, it was this certain style: https://userstyles.org/styles/164882/rainbowtube Problem solved!

Okulungisiwe ngu florian2833z

Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 10 Contributor
83 izisombululo 871 izimpendulo
Kuphostiwe

Great! I'm glad to hear that you got the problem solved. Now, you can binge-watch on Youtube!

FYI: The recommendation for the extension comes from reviewers at AMO. Evidently their criteria doesn't include thoroughly checking out each and every style.

Great! I'm glad to hear that you got the problem solved. Now, you can binge-watch on Youtube! FYI: The recommendation for the extension comes from reviewers at AMO. Evidently their criteria doesn't include thoroughly checking out each and every style.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

My_Cheese_Is_Slippin' said

Great! I'm glad to hear that you got the problem solved. Now, you can binge-watch on Youtube! FYI: The recommendation for the extension comes from reviewers at AMO. Evidently their criteria doesn't include thoroughly checking out each and every style.

Of course, they can't check every single style that exists haha Thanks for your help!

''My_Cheese_Is_Slippin' [[#answer-1259709|said]]'' <blockquote> Great! I'm glad to hear that you got the problem solved. Now, you can binge-watch on Youtube! FYI: The recommendation for the extension comes from reviewers at AMO. Evidently their criteria doesn't include thoroughly checking out each and every style. </blockquote> Of course, they can't check every single style that exists haha Thanks for your help!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.