X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

How can I play mp4 videos in external player?

Kuphostiwe

In customization I added AVI to the list to make that file type open in VLC video player. The process was when I downloaded an AVI file it popped up a dialog which offered me an "always do this" option that put the file type into that list.

I am trying to do something similar for MP3 and MP4, but am not able to prevent them from opening and running in Firefox. If I left click, the video downloads and runs. If I right click, there is no "download" option on the menu. In the customization page there is no way to add file types to the list, as the search box above the list appears to be nonfunctional.

There was an article from some years ago to change the "media.windows-media-foundation" in "about:config" from true to false, but that configuration does not appear to exist in my Firefox version (69.0.3 64 bit).

So, the question: how can I get MP4 videos to play in an external player?

In customization I added AVI to the list to make that file type open in VLC video player. The process was when I downloaded an AVI file it popped up a dialog which offered me an "always do this" option that put the file type into that list. I am trying to do something similar for MP3 and MP4, but am not able to prevent them from opening and running in Firefox. If I left click, the video downloads and runs. If I right click, there is no "download" option on the menu. In the customization page there is no way to add file types to the list, as the search box above the list appears to be nonfunctional. There was an article from some years ago to change the "media.windows-media-foundation" in "about:config" from true to false, but that configuration does not appear to exist in my Firefox version (69.0.3 64 bit). So, the question: how can I get MP4 videos to play in an external player?

Isisombululo esikhethiwe

You can set this pref to false on the about:config page to prevent Firefox from playing media files via the HTML5 media player.

  • media.play-stand-alone = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17534 izisombululo 158555 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You can set this pref to false on the about:config page to prevent Firefox from playing media files via the HTML5 media player.

  • media.play-stand-alone = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can set this pref to false on the <b>about:config</b> page to prevent Firefox from playing media files via the HTML5 media player. *media.play-stand-alone = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Great. That did the trick. Thank you.

Great. That did the trick. Thank you.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.