X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Why isn't there a "name" column in the "Show all bookmarks" display? (FF 69 forward)

Kuphostiwe

Now that FF is updated to version 69, when "Show all bookmarks" is selected, the window shows only the list of URLs, not their associated names (the select-columns pulldown has "Name" checked, but greyed-out. What's the reason for this? If I want to sort through links by name in case I want to delete any of them, I can't (sorting by URL is of no help as very often I tweak the name to something usually shorter)

Now that FF is updated to version 69, when "Show all bookmarks" is selected, the window shows only the list of URLs, not their associated names (the select-columns pulldown has "Name" checked, but greyed-out. What's the reason for this? If I want to sort through links by name in case I want to delete any of them, I can't (sorting by URL is of no help as very often I tweak the name to something usually shorter)
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

jscher2000 said

Sorry, for some reason it is possible to set the width of the Name column to 0, which obviously makes it impossible to see and probably impossible to re-expand to reasonable width. Before taking further action, in case the columns were switched, if you drag the right border of the URL column heading to the left, does the Name column appear on the right?

Nope, there's only a small space there anyhow because of the Name column being hidden and greyed out.

If not, and if you don't get a direct solution: The widths of the columns in the Library window are stored in a file named xulstore.json -- for example, mine lists this for the Name column: "placesContentTitle":{"width":"423"} I suspect there's a problem with that value in your file, but it's in a tightly packed text format which is difficult to edit successfully. So usually when there is a problem with it, we suggest renaming the file and having Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > Exit
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, it's ancient now, you can delete it. Start Firefox back up again. The Library window should have its default layout (only certain columns displayed, but much wider).

That it does. Thanks for the help.

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:
  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)
To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Used to that when FF is refreshed, which I've had to do a few times.

dL

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8775 izisombululo 71736 izimpendulo
Kuphostiwe

Sorry, for some reason it is possible to set the width of the Name column to 0, which obviously makes it impossible to see and probably impossible to re-expand to reasonable width.

Before taking further action, in case the columns were switched, if you drag the right border of the URL column heading to the left, does the Name column appear on the right?

If not, and if you don't get a direct solution:

The widths of the columns in the Library window are stored in a file named xulstore.json -- for example, mine lists this for the Name column:

"placesContentTitle":{"width":"423"}

I suspect there's a problem with that value in your file, but it's in a tightly packed text format which is difficult to edit successfully. So usually when there is a problem with it, we suggest renaming the file and having Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, it's ancient now, you can delete it.

Start Firefox back up again. The Library window should have its default layout (only certain columns displayed, but much wider).

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Sorry, for some reason it is possible to set the width of the Name column to 0, which obviously makes it impossible to see and probably impossible to re-expand to reasonable width. Before taking further action, in case the columns were switched, if you drag the right border of the URL column heading to the left, does the Name column appear on the right? ''If not, and if you don't get a direct solution:'' The widths of the columns in the Library window are stored in a file named '''xulstore.json''' -- for example, mine lists this for the Name column: "placesContentTitle":{"width":"423"} I suspect there's a problem with that value in your file, but it's in a tightly packed text format which is difficult to edit successfully. So usually when there is a problem with it, we suggest renaming the file and having Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like '''xulstoreOLD.json'''. If you see a file named localstore.rdf, it's ancient now, you can delete it. Start Firefox back up again. The Library window should have its default layout (only certain columns displayed, but much wider). ''That mini-reset will hide the menu bar and bookmarks toolbar.'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Toolbars button (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158598 izimpendulo
Kuphostiwe

If you move the mouse to the left end of the Location field (empty space just before the Location heading) on the headings bar then you should see a resize pointer and be able to drag the Name column wider (you can't disable the Name column).

If you move the mouse to the left end of the Location field (empty space just before the Location heading) on the headings bar then you should see a resize pointer and be able to drag the Name column wider (you can't disable the Name column).

Okulungisiwe ngu cor-el

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

jscher2000 said

Sorry, for some reason it is possible to set the width of the Name column to 0, which obviously makes it impossible to see and probably impossible to re-expand to reasonable width. Before taking further action, in case the columns were switched, if you drag the right border of the URL column heading to the left, does the Name column appear on the right?

Nope, there's only a small space there anyhow because of the Name column being hidden and greyed out.

If not, and if you don't get a direct solution: The widths of the columns in the Library window are stored in a file named xulstore.json -- for example, mine lists this for the Name column: "placesContentTitle":{"width":"423"} I suspect there's a problem with that value in your file, but it's in a tightly packed text format which is difficult to edit successfully. So usually when there is a problem with it, we suggest renaming the file and having Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > Exit
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, it's ancient now, you can delete it. Start Firefox back up again. The Library window should have its default layout (only certain columns displayed, but much wider).

That it does. Thanks for the help.

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:
  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)
To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Used to that when FF is refreshed, which I've had to do a few times.

dL

''jscher2000 [[#answer-1258385|said]]'' <blockquote> Sorry, for some reason it is possible to set the width of the Name column to 0, which obviously makes it impossible to see and probably impossible to re-expand to reasonable width. Before taking further action, in case the columns were switched, if you drag the right border of the URL column heading to the left, does the Name column appear on the right? </blockquote> Nope, there's only a small space there anyhow because of the Name column being hidden and greyed out. <blockquote> ''If not, and if you don't get a direct solution:'' The widths of the columns in the Library window are stored in a file named '''xulstore.json''' -- for example, mine lists this for the Name column: "placesContentTitle":{"width":"423"} I suspect there's a problem with that value in your file, but it's in a tightly packed text format which is difficult to edit successfully. So usually when there is a problem with it, we suggest renaming the file and having Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like '''xulstoreOLD.json'''. If you see a file named localstore.rdf, it's ancient now, you can delete it. Start Firefox back up again. The Library window should have its default layout (only certain columns displayed, but much wider). </blockquote> That it does. Thanks for the help. <blockquote> ''That mini-reset will hide the menu bar and bookmarks toolbar.'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Toolbars button (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list. </blockquote> Used to that when FF is refreshed, which I've had to do a few times. dL
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158598 izimpendulo
Kuphostiwe

Did you try my suggestion ?

The screenshot you posted hides the left end of the heading bar, so I can't see whether there is more space then there should be, but the margin at the left end of the location field suggests that something is still there. I can drag the Name field quite small, but can't make it disappear and I am always able to drag it wider. Like I wrote, you can hide all other columns, but you can't hide the Name field. That is why it is always enabled and grayed and it isn't possible to remove its checkmark.

Did you try my suggestion ? The screenshot you posted hides the left end of the heading bar, so I can't see whether there is more space then there should be, but the margin at the left end of the location field suggests that something is still there. I can drag the Name field quite small, but can't make it disappear and I am always able to drag it wider. Like I wrote, you can hide all other columns, but you can't hide the Name field. That is why it is always enabled and grayed and it isn't possible to remove its checkmark.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I, regrettably, can NOT drag the Name field, only the others.

I wasn't trying to hide the Name field. It became hidden as a result of something not of my doing that occurred since the upgrade reached version 69.0.1, my best educated guess, and I didn't notice it had occurred until 69.0.3. jscher2000's instructions enabled me to un-hide it.

dL

I, regrettably, can NOT drag the Name field, only the others. I wasn't ''trying'' to hide the Name field. It became hidden as a result of something not of my doing that occurred since the upgrade reached version 69.0.1, my best educated guess, and I didn't notice it had occurred until 69.0.3. jscher2000's instructions enabled me to ''un-''hide it. dL

Okulungisiwe ngu Dale_Latimer

Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.