X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Fonts displaying as question marks on certain sites (such as the autofill on Google).

Kuphostiwe

HI- Recently lots of my fonts have started displaying as question marks on certain sites (such as the autofill on Google). If I uncheck the box in prefs that allows websites to use their own fonts, it's fine. But then the sites look nasty. I've reinstalled Firefox 69.0.2 but its no better. It's a work Apple mac so I can't access all the settings but the issue is only on Firefox. Please don't make me use Chrome! Thanks

HI- Recently lots of my fonts have started displaying as question marks on certain sites (such as the autofill on Google). If I uncheck the box in prefs that allows websites to use their own fonts, it's fine. But then the sites look nasty. I've reinstalled Firefox 69.0.2 but its no better. It's a work Apple mac so I can't access all the settings but the issue is only on Firefox. Please don't make me use Chrome! Thanks
Ama-screenshot ananyekiwe
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17532 izisombululo 158526 izimpendulo
Kuphostiwe

Impendulo Ewusizo

This likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

This likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'. You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Ingabe lokhu kube usizo kuwena? 2
Isicaphuno
greg18 0 izisombululo 4 izimpendulo
Kuphostiwe

The same thing happened to me when I upgraded my MacOS to Catalina.

I tried disabling all fonts to try to isolate a conflict and was not able to figure it out. Any help here would be appreciated as it is very annoying.

The same thing happened to me when I upgraded my MacOS to Catalina. I tried disabling all fonts to try to isolate a conflict and was not able to figure it out. Any help here would be appreciated as it is very annoying.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17532 izisombululo 158526 izimpendulo
Kuphostiwe

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
greg18 0 izisombululo 4 izimpendulo
Kuphostiwe

Impendulo Ewusizo

When I hover over ".LastResort" it highlights the question mark boxes. It says what is used is Helvetica, which I have loaded on my computer, but it is not loading for some reason. Any thoughts?

When I hover over ".LastResort" it highlights the question mark boxes. It says what is used is Helvetica, which I have loaded on my computer, but it is not loading for some reason. Any thoughts?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17532 izisombululo 158526 izimpendulo
Kuphostiwe

This probably means that either the Helvetica font is corrupted or is installed in a location that isn't allowed (whitelisted) in Firefox.

Try to uninstall this Helvetica font via Font Book.

This probably means that either the Helvetica font is corrupted or is installed in a location that isn't allowed (whitelisted) in Firefox. Try to uninstall this Helvetica font via Font Book.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
greg18 0 izisombululo 4 izimpendulo
Kuphostiwe

The system will not allow me to uninstall it. I'm getting the attached message.

The system will not allow me to uninstall it. I'm getting the attached message.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17532 izisombululo 158526 izimpendulo
Kuphostiwe

Did you make sure that only this one system Helvetica font is installed and not other fonts that report as Helvetica ?

Did you make sure that only this one system Helvetica font is installed and not other fonts that report as Helvetica ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
greg18 0 izisombululo 4 izimpendulo
Kuphostiwe

There is also Helvetica Neue installed. But I cannot disable or remove either one.

There is also Helvetica Neue installed. But I cannot disable or remove either one.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
helen8 0 izisombululo 3 izimpendulo
Kuphostiwe

I am using FontExplorer X Pro on macOS Catalina and also having problems with fonts not displaying properly.

FontExplorer X Pro overides Font Book.

Also noticed numeral nine (9) not displaying properly in documents on the internet!


Any suggestions please as it's driving me crazy.

I am using FontExplorer X Pro on macOS Catalina and also having problems with fonts not displaying properly. FontExplorer X Pro overides Font Book. Also noticed numeral nine (9) not displaying properly in documents on the internet! Any suggestions please as it's driving me crazy.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.