Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google Maps Earth 3d view is unavailable

  • 6 uphendule
  • 1 inale nkinga
  • 29 views
  • Igcine ukuphendulwa ngu Sulik

more options

Google Maps keeps showing information, that the Earth 3d view is not available. It worked for two days or so, just after the system reinstallation (Windows 10), but suddenly stopped. Firefox Quantum 69.0 64 bit, system Windows 10 installed a month ago (updated daily), GTX750 Ti, CPU i7-3770, 16 GB RAM. I've tried to clear cache, cookies and google for the solution, but nothing helped. Months ago, when Firefox showed "Earth 3d view is not available" (in the right bottom corner of the map) I could just click that link, and choose "Other versions..." and "Open Maps in 3d" but it doesn't work any more. Earth 3d map view works in Chrome. Please help!

All Replies (6)

more options
more options

Is WebGL enabled and working properly?

You can check the graphics section on the "Help -> Troubleshooting Information" (about:support) page for WebGL related messages.

more options

I used https://www.google.pl/maps/ https://earth.google.com/web/?beta=1 - I see no map, only a black screen (and navigation buttons).

in the about:config the Webgl.disable is false in the Options, Under Performance "Use hardware acceleration when available" is checked

I used https://get.webgl.org/ and get "Your browser supports WebGL" (I see rotating cube)

I used https://web.basemark.com and get: https://web.basemark.com/result/?4SD0DK9N ("Browser wasn't able to run WebGL 2.0 Test")

Okulungisiwe ngu Sulik

more options

Go to about:support and check the WebGL2 sections.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

about:support Renderer WebGL 2: WebGL creation failed:

  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR

Safe Mode: problem still persists

(Thanks guys for helping me) :)