X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Composing gmail - unwanted line breaks in FF 69.0

Kuphostiwe

I had posted another question here about 69.0 being the genesis of bad line breaking, and now a new thing I discovered.

In Firefox - and only firefox - if I'm composing a new message, pressing enter generates a single line break as I'd like and expect - new paragraphs require two "enter" presses.

EXCEPT, since 69.0, if I include a bulleted or numbered list in the message, when I end the bullets or numbering, the text below it inserts a forced double space with every "enter" press. That is, single-spacing before the bullet/number list; double-spacing after it.

Here is a "selection source" of a short message I composed:

=======
<div id=":ol" class="Am Al editable LW-avf tS-tW tS-tY" hidefocus="true" aria-label="Message Body" g_editable="true" role="textbox" aria-multiline="true" style="direction: ltr; min-height: 376px;" tabindex="1" contenteditable="true">
Before the bulleted list line 1<br>

Before the bulleted list line 2<br>

Before the bulleted list line 3<br><div><ul><li>Bullet list line 1<br></li><li>Bullet list line 2</li><li>Bullet list line 3</li></ul><p>After the bulleted list line 1</p><p>After the bulleted list line 2</p><p> After the bulleted list line 3

</p><br></div></div> =======

If you notice, the "enter" generated a <br> before the list, then a <p> after it. Highlighting the lines after the bullets and removing the formatting (the slashed-out T in gmail compose) changes their selection source to:

=======
After the bulleted list line 1<br><br>After the bulleted list line 2<br><br>After the bulleted list line 3
=======

As you see, the <p> is replaced with a <br> and the unwanted blank lines can be edited out.

This was fine until this month when 69 took over.

I'd like to see it put back to how it was in 68.

I had posted another question here about 69.0 being the genesis of bad line breaking, and now a new thing I discovered. In Firefox - and only firefox - if I'm composing a new message, pressing enter generates a single line break as I'd like and expect - new paragraphs require two "enter" presses. EXCEPT, since 69.0, if I include a bulleted or numbered list in the message, when I end the bullets or numbering, the text below it inserts a forced double space with every "enter" press. That is, single-spacing before the bullet/number list; double-spacing after it. Here is a "selection source" of a short message I composed: <pre><nowiki>======= <div id=":ol" class="Am Al editable LW-avf tS-tW tS-tY" hidefocus="true" aria-label="Message Body" g_editable="true" role="textbox" aria-multiline="true" style="direction: ltr; min-height: 376px;" tabindex="1" contenteditable="true"> Before the bulleted list line 1<br> </nowiki></pre> Before the bulleted list line 2&lt;br&gt; Before the bulleted list line 3&lt;br&gt;&lt;div&gt;&lt;ul&gt;&lt;li&gt;Bullet list line 1&lt;br&gt;&lt;/li&gt;&lt;li&gt;Bullet list line 2&lt;/li&gt;&lt;li&gt;Bullet list line 3&lt;/li&gt;&lt;/ul&gt;&lt;p&gt;After the bulleted list line 1&lt;/p&gt;&lt;p&gt;After the bulleted list line 2&lt;/p&gt;&lt;p&gt; After the bulleted list line 3 &lt;/p&gt;&lt;br&gt;&lt;/div&gt;&lt;/div&gt; <nowiki>=======</nowiki> If you notice, the "enter" generated a &lt;br&gt; before the list, then a &lt;p&gt; after it. Highlighting the lines after the bullets and removing the formatting (the slashed-out T in gmail compose) changes their selection source to: <pre><nowiki> ======= After the bulleted list line 1<br><br>After the bulleted list line 2<br><br>After the bulleted list line 3 =======</nowiki></pre> As you see, the &lt;p&gt; is replaced with a &lt;br&gt; and the unwanted blank lines can be edited out. This was fine until this month when 69 took over. I'd like to see it put back to how it was in 68.

Okulungisiwe ngu cor-el

Isisombululo esikhethiwe

The forum honors line break and paragraph tags instead of displaying them, which makes the description hard to understand.

In the other thread, as an experiment, we asked you to flip a preference. Try switching it back to the default setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste newline and pause while the list is filtered

(3) If the editor.use_div_for_default_newlines preference is bolded and modified to false, double-click it to restore the default value of true

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8693 izisombululo 71056 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

The forum honors line break and paragraph tags instead of displaying them, which makes the description hard to understand.

In the other thread, as an experiment, we asked you to flip a preference. Try switching it back to the default setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste newline and pause while the list is filtered

(3) If the editor.use_div_for_default_newlines preference is bolded and modified to false, double-click it to restore the default value of true

The forum honors line break and paragraph tags instead of displaying them, which makes the description hard to understand. In the other thread, as an experiment, we asked you to flip a preference. Try switching it back to the default setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''newline''' and pause while the list is filtered (3) If the '''editor.use_div_for_default_newlines''' preference is bolded and '''modified''' to false, double-click it to restore the default value of true
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 said

The forum honors line break and paragraph tags instead of displaying them, which makes the description hard to understand. In the other thread, as an experiment, we asked you to flip a preference. Try switching it back to the default setting: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste newline and pause while the list is filtered (3) If the editor.use_div_for_default_newlines preference is bolded and modified to false, double-click it to restore the default value of true

For this problem - not the different one I'd posted about double-spacing not porting from gmail to some other text-entry - this solved the problem!

Last week I'd flipped editor.use_div_for_default_newlines from default true, to false. This time I flipped it from false back to the default true.

A small caveat though that this applies to my home Win7 setup. My office computer is Windows 10, and I never touched editor.use_div_for_default_newlines in that, and that was having the problem too, yesterday.

Although it will be a worthwhile experiment to do the flip-to-true, flip-to-false, and see what happens.

Thanks for the nudge.

''jscher2000 [[#answer-1252007|said]]'' <blockquote> The forum honors line break and paragraph tags instead of displaying them, which makes the description hard to understand. In the other thread, as an experiment, we asked you to flip a preference. Try switching it back to the default setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''newline''' and pause while the list is filtered (3) If the '''editor.use_div_for_default_newlines''' preference is bolded and '''modified''' to false, double-click it to restore the default value of true </blockquote> For this problem - not the different one I'd posted about double-spacing not porting from gmail to some other text-entry - this solved the problem! Last week I'd flipped editor.use_div_for_default_newlines from default true, to false. This time I flipped it from false back to the default true. A small caveat though that this applies to my home Win7 setup. My office computer is Windows 10, and I never touched editor.use_div_for_default_newlines in that, and that was having the problem too, yesterday. Although it will be a worthwhile experiment to do the flip-to-true, flip-to-false, and see what happens. Thanks for the nudge.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.