X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Why does my "Top Sites" layout suddenly have 7 columns instead of 5?

Kuphostiwe

Yesterday, my New Tab page that's usually set with three rows and five columns of Top Sites suddenly had seven columns instead. This happened suddenly in the middle of the day, while I was using Firefox. I've restarted FF, and restarted my PC. I've tried the about:config browser.newtabpage.columns variable that I've seen posted in various places as a fix, but that variable doesn't exist any longer. I've tried this fix: https://support.mozilla.org/en-US/questions/1242653, and it didn't do anything at all.

How do I change it back to five columns like it was before?

Edit: Well, it's actually eight columns now, and it was six before the change. Apparently I can't even count to six and eight! The fact remains that it's suddenly different for no apparent reason, and I'd like to figure out how to change it back.

Yesterday, my New Tab page that's usually set with three rows and five columns of Top Sites suddenly had seven columns instead. This happened suddenly in the middle of the day, while I was using Firefox. I've restarted FF, and restarted my PC. I've tried the about:config browser.newtabpage.columns variable that I've seen posted in various places as a fix, but that variable doesn't exist any longer. I've tried this fix: https://support.mozilla.org/en-US/questions/1242653, and it didn't do anything at all. How do I change it back to five columns like it was before? Edit: Well, it's actually eight columns now, and it was six before the change. Apparently I can't even count to six and eight! The fact remains that it's suddenly different for no apparent reason, and I'd like to figure out how to change it back.

Okulungisiwe ngu dwquilts

Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17481 izisombululo 157964 izimpendulo
Kuphostiwe

The code in userContent.css should still work.

@-moz-document url("about:newtab"),url(about:home) {
 main, .search-inner-wrapper {width: 540px !important;}
}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true
The code in userContent.css should still work. <pre><nowiki>@-moz-document url("about:newtab"),url(about:home) { main, .search-inner-wrapper {width: 540px !important;} }</nowiki></pre> ---- In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true *https://www.userchrome.org/firefox-changes-userchrome-css.html
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hi, and thanks for the help! I've checked the pref in about:config. It was already set to true because I have been using userChrome.css for quite a while.

I inserted the css in your post, and the only thing different was that the Top Sites icons are all shifted to the right a bit, and now causing a scroll bar at the bottom of the browser window, but there are still seven columns.

Hi, and thanks for the help! I've checked the pref in about:config. It was already set to true because I have been using userChrome.css for quite a while. I inserted the css in your post, and the only thing different was that the Top Sites icons are all shifted to the right a bit, and now causing a scroll bar at the bottom of the browser window, but there are still seven columns.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17481 izisombululo 157964 izimpendulo
Kuphostiwe

You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))
You may have accidentally zoomed web page(s). Reset the page zoom on pages that cause problems. *<b>View -> Zoom -> Reset</b> (Ctrl+0/Command+0 (zero)) *https://support.mozilla.org/en-US/kb/how-do-i-use-zoom
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Yes, I do use the zoom feature, but no matter what level of zoom, even at 100%, there are still seven columns and they are now pushed to the right after using the CSS from your previous post. Of course, with it zoomed to 100%, there is no scroll bar at the bottom, but that's not the basic problem anyway. The basic problem is that there are seven columns of Top Sites instead of five.

Yes, I do use the zoom feature, but no matter what level of zoom, even at 100%, there are still seven columns and they are now pushed to the right after using the CSS from your previous post. Of course, with it zoomed to 100%, there is no scroll bar at the bottom, but that's not the basic problem anyway. The basic problem is that there are seven columns of Top Sites instead of five.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17481 izisombululo 157964 izimpendulo
Kuphostiwe

The main container has a "margin: auto" rule, so this container in centered. You can set a specific margin-left to override the centering.

@-moz-document
 url("about:newtab"),
 url(about:home) {
 main, .search-inner-wrapper { width: 540px !important; }
 main { margin-left: 5px important; }
}
The main container has a "margin: auto" rule, so this container in centered. You can set a specific margin-left to override the centering. <pre><nowiki>@-moz-document url("about:newtab"), url(about:home) { main, .search-inner-wrapper { width: 540px !important; } main { margin-left: 5px important; } } </nowiki></pre>
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

That didn't help either. I've attached a screenshot of what it looks like. This is at 100%, with this in the userContent.css file:

@-moz-document

url("about:newtab"),
url(about:home) {
main, .search-inner-wrapper { width: 540px !important; }
main { margin-left: 5px important; }

}

All that's happening here is that everything is pushed to the right instead of centered, but there are still eight columns instead of six (in case you didn't see my edit, there were six before it suddenly changed to eight; apparently I can't even count to numbers less than ten!).

I liked it at six. It was perfect. I'd like to figure out how to get it set back to six columns.

Thanks for your help!

That didn't help either. I've attached a screenshot of what it looks like. This is at 100%, with this in the userContent.css file: @-moz-document url("about:newtab"), url(about:home) { main, .search-inner-wrapper { width: 540px !important; } main { margin-left: 5px important; } } All that's happening here is that everything is pushed to the right instead of centered, but there are still eight columns instead of six (in case you didn't see my edit, there were six before it suddenly changed to eight; apparently I can't even count to numbers less than ten!). I liked it at six. It was perfect. I'd like to figure out how to get it set back to six columns. Thanks for your help!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17481 izisombululo 157964 izimpendulo
Kuphostiwe

What Firefox locale do use?

It looks that you have a RTL locale, so you can po0sibly try margin-right:0 !important instead.

What Firefox locale do use? It looks that you have a RTL locale, so you can po0sibly try margin-right:0 !important instead.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I don't know what FF locale I use, and not sure how to figure it out. I did try margin-right:0 !important instead, and it still looks the same, with eight columns instead of six.

I don't know what FF locale I use, and not sure how to figure it out. I did try margin-right:0 !important instead, and it still looks the same, with eight columns instead of six.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

dwquilts said

I don't know what FF locale I use, and not sure how to figure it out.

Type about:support in the adress bar and press Enter.

Then scroll all the way down to "Internationalization & Localization".

''dwquilts [[#answer-1251933|said]]'' <blockquote> I don't know what FF locale I use, and not sure how to figure it out. </blockquote> Type '''about:support''' in the adress bar and press Enter. Then scroll all the way down to "Internationalization & Localization".
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I found this article that says:

New "New Tab" page experience for users from the United State that displays more Pocket content.

I don't have Pocket set to display (and when I turn it on to test it, it's exactly the same width as the eight columns that I have now), but perhaps that's what's causing the issue? If so, is there a way to fix?

I found [https://www.ghacks.net/2019/09/03/firefox-69-0-release-information/ this article] that says: New "New Tab" page experience for users from the United State that displays more Pocket content. I don't have Pocket set to display (and when I turn it on to test it, it's exactly the same width as the eight columns that I have now), but perhaps that's what's causing the issue? If so, is there a way to fix?

Okulungisiwe ngu dwquilts

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

McCoy said

dwquilts said
I don't know what FF locale I use, and not sure how to figure it out.

Type about:support in the adress bar and press Enter.

Then scroll all the way down to "Internationalization & Localization".

Thanks—it's en-US.

''McCoy [[#answer-1251939|said]]'' <blockquote> ''dwquilts [[#answer-1251933|said]]'' <blockquote> I don't know what FF locale I use, and not sure how to figure it out. </blockquote> Type '''about:support''' in the adress bar and press Enter. Then scroll all the way down to "Internationalization & Localization". </blockquote> Thanks—it's en-US.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

dwquilts said

there are still seven columns and they are now pushed to the right after using the CSS from your previous post.

Removing that CSS should take care of that problem.

FWIW : I have my new tab page at a 120 zoom level, and have six columns. Reset zoom (or reducing it to 110 even) gives me eight columns.

Please, don't take it the wrong way, but as you said " apparently I can't even count to numbers less than ten! " (which happens to all of us at one point, so don't feel bad) - could it be that you hadn't noticed that you'll get those six columns back when you zoom in ?

''dwquilts [[#answer-1251836|said]]'' <blockquote> there are still seven columns and they are now pushed to the right after using the CSS from your previous post. </blockquote> Removing that CSS should take care of that problem. FWIW : I have my new tab page at a 120 zoom level, and have six columns. Reset zoom (or reducing it to 110 even) gives me eight columns. Please, don't take it the wrong way, but as you said "'' apparently I can't even count to numbers less than ten!'' " (which happens to all of us at one point, so don't feel bad) - could it be that you hadn't noticed that you'll get those six columns back when you zoom in ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Yes, I have removed all CSS at this point.

I have tried different zoom levels, but it only causes a horizontal scroll bar at the bottom of the window, and the eight columns are still there. Sure, at 180%, I see six columns, but the icons are huge, some of them are cut off at the bottom, and it looks pretty terrible. It was great before with six columns and three rows. It was perfect. All the sites I visit daily were there. Now it's kind of a mess.

I guess I'm just going to give up, honestly. It seems like this type of thing is an issue with almost every FF update, as some weird thing changes with the layout and then I have to jump through hoops to get the layout and look that I liked, and have used for years, back again. It's very frustrating.

Thank you for the help, regardless.

Yes, I have removed all CSS at this point. I have tried different zoom levels, but it only causes a horizontal scroll bar at the bottom of the window, and the eight columns are still there. Sure, at 180%, I see six columns, but the icons are huge, some of them are cut off at the bottom, and it looks pretty terrible. It was great before with six columns and three rows. It was perfect. All the sites I visit daily were there. Now it's kind of a mess. I guess I'm just going to give up, honestly. It seems like this type of thing is an issue with almost every FF update, as some weird thing changes with the layout and then I have to jump through hoops to get the layout and look that I liked, and have used for years, back again. It's very frustrating. Thank you for the help, regardless.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

dwquilts said

I guess I'm just going to give up, honestly.

Aww, don't give up - I'm sure that cor-el (or someone else) will figure this out.

I'm rather curious about what's going on here myself .....

''dwquilts [[#answer-1251970|said]]'' <blockquote> I guess I'm just going to give up, honestly. </blockquote> Aww, don't give up - I'm sure that cor-el (or someone else) will figure this out. I'm rather curious about what's going on here myself .....
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.