X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Turn off download popup

Kuphostiwe

Hi guys, I need help turning off the download popup that asks what Firefox should do with the file I selected to download. I've ticked the box "Do this automatically for files like this a couple of times but it still pops up every time and now the tick box is even greyed out. This is SUPER frustrating as I am a designer so I download a lot of content all the time and it slows down my workflow if I have to click a popup box every time I download something. Thanks in advance! :)

Hi guys, I need help turning off the download popup that asks what Firefox should do with the file I selected to download. I've ticked the box "Do this automatically for files like this a couple of times but it still pops up every time and now the tick box is even greyed out. This is SUPER frustrating as I am a designer so I download a lot of content all the time and it slows down my workflow if I have to click a popup box every time I download something. Thanks in advance! :)
Ama-screenshot ananyekiwe
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

None from my side

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Hello Arnodt02,

Please take a look at this article :

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file

Any good ?

Hello Arnodt02, Please take a look at this article : https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file Any good ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thank you so much for your response, I tried the steps they give in that article but in my settings I can't see any image formats to specify that it should just save the files instead of asking and all other options are set to save (except irc and ircs). I did read that if the tick box is disabled that it might mean: 'This can happen if the website's server incorrectly specifies the Internet Media type of the file. It also can happen if the server assigns "Content-Disposition: attachment" to the file.' I am not 100% sure what that means, id there anything I can do about that?

Thank you so much for your response, I tried the steps they give in that article but in my settings I can't see any image formats to specify that it should just save the files instead of asking and all other options are set to save (except irc and ircs). I did read that if the tick box is disabled that it might mean: 'This can happen if the website's server incorrectly specifies the Internet Media type of the file. It also can happen if the server assigns "Content-Disposition: attachment" to the file.' I am not 100% sure what that means, id there anything I can do about that?

Okulungisiwe ngu Arnodt02

Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Arnodt02 said

I did read that if the tick box is disabled that it might mean: 'This can happen if the website's server incorrectly specifies the Internet Media type of the file. It also can happen if the server assigns "Content-Disposition: attachment" to the file.' I am not 100% sure what that means, id there anything I can do about that?

I did some searching, and unfortunately the only thing I could find (that makes any sense) is this :

https://www.bleepingcomputer.com/forums/t/573983/firefox-am-trying-to-set-downloads-to-automatically-save/

Maybe someone else will come up with a better answer .....

''Arnodt02 [[#answer-1251363|said]]'' <blockquote> I did read that if the tick box is disabled that it might mean: 'This can happen if the website's server incorrectly specifies the Internet Media type of the file. It also can happen if the server assigns "Content-Disposition: attachment" to the file.' I am not 100% sure what that means, id there anything I can do about that? </blockquote> I did some searching, and unfortunately the only thing I could find (that makes any sense) is this : https://www.bleepingcomputer.com/forums/t/573983/firefox-am-trying-to-set-downloads-to-automatically-save/ Maybe someone else will come up with a better answer .....
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks again for the feedback @McCoy, what I've gathered now from both the above links basically comes down to it being an error on the server I am downloading from.

With that said I did some tests on my side and looks like some sites download fine without the popup and some don't so the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end."

Thanks again for the feedback @McCoy, what I've gathered now from both the above links basically comes down to it being an error on the server I am downloading from. With that said I did some tests on my side and looks like some sites download fine without the popup and some don't so the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end."

Okulungisiwe ngu Arnodt02

Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Arnodt02 said

With that said I did some tests on my side and looks like some sites download fine without the popup and some don't so the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end."

Spot on - cause that's the part "that made sense to me" .....

''Arnodt02 [[#answer-1251368|said]]'' <blockquote> With that said I did some tests on my side and looks like some sites download fine without the popup and some don't so the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end." </blockquote> Spot on - cause that's the part "that made sense to me" .....
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8692 izisombululo 71041 izimpendulo
Kuphostiwe

Arnodt02 said

... the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end."

Hi Arnodt02, if the problem is the server is sending a generic Content-Type for the download instead of the specific Content-Type for JPG files, Firefox won't store the association for the generic content type because it is also used for downloadable program files.

If that is the problem:

As a workaround, you can define a new content type using my extension here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Here's how:

(1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button)

(2) Start the download again, you can cancel out of the Open/Save dialog

(3) Click the toolbar button and click Add/Edit Content Types

(4) A tab will appear with a table showing your download request. Click Add for the .jpg file and assign a content-type -- to take advantage of the current association, try image/jpeg (we don't want to break normal inline image handling, so in this case, we wouldn't want to invent our own fictitious type).

The table will show that row is now obsolete. Ignore that.

You can close this tab.

(5) Try the download again and either Firefox should now handle the file properly or you should now be able to define a persistent behavior (check the box).

Does that work on yours? Do you now have a new problem that Firefox wants to display the image in a tab instead of downloading it?

You can disable the extension when you are not downloading .jpg files. Click the button and then click Stop Listening/Clear Log.

''Arnodt02 [[#answer-1251368|said]]'' <blockquote>... the statement given in the last link seems to be accurate: "There is little you can do in these cases because the problem is at the server end." </blockquote> Hi Arnodt02, if the problem is the server is sending a generic Content-Type for the download instead of the specific Content-Type for JPG files, Firefox won't store the association for the generic content type because it is also used for downloadable program files. ''If that is the problem:'' As a workaround, you can define a new content type using my extension here: https://addons.mozilla.org/firefox/addon/content-type-fixer/ Here's how: (1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button) (2) Start the download again, you can cancel out of the Open/Save dialog (3) Click the toolbar button and click Add/Edit Content Types <center><img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-10-08-22-08-474306.png" width="250"></center> (4) A tab will appear with a table showing your download request. Click Add for the .jpg file and assign a content-type -- to take advantage of the current association, try '''image/jpeg''' (we don't want to break normal inline image handling, so in this case, we wouldn't want to invent our own fictitious type). The table will show that row is now obsolete. Ignore that. You can close this tab. (5) Try the download again and either Firefox should now handle the file properly or you should now be able to define a persistent behavior (check the box). Does that work on yours? Do you now have a new problem that Firefox wants to display the image in a tab instead of downloading it? You can disable the extension when you are not downloading .jpg files. Click the button and then click Stop Listening/Clear Log.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thank you very much, I'll give that a shot if necessary and let you know the outcome!

Thank you very much, I'll give that a shot if necessary and let you know the outcome!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.