X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Search bar on New Tab has moved to the top of the page

Kuphostiwe

The search bar that used to be in the center of the page has suddenly moved to the top of the page in all new tabs: https://i.imgur.com/2f5VZjv.png

This started around noon today, and was not preceded by any updates or changes to Firefox or any of my addons, so far that I'm aware of.

How do I return the search bar to the center of the page?

The search bar that used to be in the center of the page has suddenly moved to the top of the page in all new tabs: https://i.imgur.com/2f5VZjv.png This started around noon today, and was not preceded by any updates or changes to Firefox or any of my addons, so far that I'm aware of. How do I return the search bar to the center of the page?

Isisombululo esikhethiwe

I've noticed over the past couple days that all of my PCs have migrated to the top-of-page search bar. It does seem to be the new default, for whatever reason. With its new position being all but adjacent to the address bar, it seems rather redundant.

Regarding the CSS changes: it adjusts the page as expected when a new tab is loaded, but when first firing up firefox that initial page is not adjusted. Both "Homepage and New Windows" and "New tabs" are set to "Firefox Home (default)", but only the latter seems to be affected by the changes made by the CSS.

edit: I noticed the CSS above is targeted at about:newtab, so I just copied that code and redirected the new block to about:home and that seems to have addressed the issue. For anyone else stumbling on this, I found 300px to be fairly close to the previous position.

@-moz-document url(about:newtab) {

 .search-wrapper { margin-top: 300px !important; }

}

@-moz-document url(about:home) {

 .search-wrapper { margin-top: 300px !important; }

}

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

Imagus, RES, uBlock Origin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157955 izimpendulo
Kuphostiwe

Your screenshot shows the default Firefox Home page with the search bar and the collapsed Top Sites sections enabled. If you hide all item except the search bar then the search bar will be more centered.

  • Options/Preferences -> Home

Your screenshot shows the default Firefox Home page with the search bar and the collapsed Top Sites sections enabled. If you hide all item except the search bar then the search bar will be more centered. *Options/Preferences -> Home ---- *https://support.mozilla.org/en-US/kb/hide-or-display-content-new-tab *https://support.mozilla.org/en-US/kb/customize-new-tab-page
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Here's a screenshot from my home PC, which is how it has always been on all of my PCs and how I want it to be. https://puu.sh/Eg8m0/d3ec426614.png

Not sure how the original image could possibly be considered centered.

Here's a screenshot from my home PC, which is how it has always been on all of my PCs and how I want it to be. https://puu.sh/Eg8m0/d3ec426614.png Not sure how the original image could possibly be considered centered.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 izisombululo 10669 izimpendulo
Kuphostiwe

So you just want to move the search bar down a bit? I imagine you could achieve that with userchrome.css hacks

So you just want to move the search bar down a bit? I imagine you could achieve that with userchrome.css hacks
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157955 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Possible code for userContent.css would be (you can adjust the margin-top): @-moz-document url(about:newtab) { .search-wrapper {margin-top: 150px !important; } }


You can add the code to the userContent.css file.

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.


Possible code for userContent.css would be (you can adjust the margin-top): <nowiki>@-moz-document url(about:newtab) { .search-wrapper {margin-top: 150px !important; } }</nowiki> ---- You can add the code to the <b>userContent.css</b> file. *http://kb.mozillazine.org/userContent.css In Firefox 69 and later you need to set this pref to true on the <b>about:config</b> page to enable userChrome.css and userContent.css in the chrome folder. *toolkit.legacyUserProfileCustomizations.stylesheets = true *https://www.userchrome.org/firefox-changes-userchrome-css.html#fx69 ---- *https://www.userchrome.org/what-is-userchrome-css.html *https://www.userchrome.org/how-create-userchrome-css.html
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jjones7791 0 izisombululo 2 izimpendulo
Kuphostiwe

Is the issue that OP raised here the default now for Firefox? I find it hard to believe that adding folders and additional code should be required to force FF to do what it has always done since I started using it 10+ years ago. Only a minor annoyance, but as OP stated, I have the exact same issue. Centered on my work PC and not on my personal PC with both running version 69.

Is the issue that OP raised here the default now for Firefox? I find it hard to believe that adding folders and additional code should be required to force FF to do what it has always done since I started using it 10+ years ago. Only a minor annoyance, but as OP stated, I have the exact same issue. Centered on my work PC and not on my personal PC with both running version 69.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157955 izimpendulo
Kuphostiwe

Hi jjones7791

Did you select in both cases the same content on the Firefox Home page?

Hi jjones7791 Did you select in both cases the same content on the Firefox Home page? *https://support.mozilla.org/en-US/kb/hide-or-display-content-new-tab
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jjones7791 0 izisombululo 2 izimpendulo
Kuphostiwe

Yes I did. I checked my wife's PC and hers is at the top as well now, so it seems this is just the current design of FF. On my work computer, my company updates Windows under their own schedule and I'm thinking that the Win updates may have something to do with it. My personal PC is fully up to date whereas my work PC doesn't have the latest updates yet.

Yes I did. I checked my wife's PC and hers is at the top as well now, so it seems this is just the current design of FF. On my work computer, my company updates Windows under their own schedule and I'm thinking that the Win updates may have something to do with it. My personal PC is fully up to date whereas my work PC doesn't have the latest updates yet.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

I've noticed over the past couple days that all of my PCs have migrated to the top-of-page search bar. It does seem to be the new default, for whatever reason. With its new position being all but adjacent to the address bar, it seems rather redundant.

Regarding the CSS changes: it adjusts the page as expected when a new tab is loaded, but when first firing up firefox that initial page is not adjusted. Both "Homepage and New Windows" and "New tabs" are set to "Firefox Home (default)", but only the latter seems to be affected by the changes made by the CSS.

edit: I noticed the CSS above is targeted at about:newtab, so I just copied that code and redirected the new block to about:home and that seems to have addressed the issue. For anyone else stumbling on this, I found 300px to be fairly close to the previous position.

@-moz-document url(about:newtab) {

 .search-wrapper { margin-top: 300px !important; }

}

@-moz-document url(about:home) {

 .search-wrapper { margin-top: 300px !important; }

}

I've noticed over the past couple days that all of my PCs have migrated to the top-of-page search bar. It does seem to be the new default, for whatever reason. With its new position being all but adjacent to the address bar, it seems rather redundant. Regarding the CSS changes: it adjusts the page as expected when a new tab is loaded, but when first firing up firefox that initial page is not adjusted. Both "Homepage and New Windows" and "New tabs" are set to "Firefox Home (default)", but only the latter seems to be affected by the changes made by the CSS. edit: I noticed the CSS above is targeted at about:newtab, so I just copied that code and redirected the new block to about:home and that seems to have addressed the issue. For anyone else stumbling on this, I found 300px to be fairly close to the previous position. @-moz-document url(about:newtab) { .search-wrapper { margin-top: 300px !important; } } @-moz-document url(about:home) { .search-wrapper { margin-top: 300px !important; } }

Okulungisiwe ngu tockity

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157955 izimpendulo
Kuphostiwe

For code in userContent.css you need to include both about:newtab and about:home.


@-moz-document
 url(about:newtab),
 url(about:home) {
/*place your code here*/
}
For code in userContent.css you need to include both about:newtab and about:home. ---- <pre><nowiki>@-moz-document url(about:newtab), url(about:home) { /*place your code here*/ }</nowiki></pre>
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.