X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Website keeps asking me to accept cookies - any way to "whitelist" it

Kuphostiwe

Firefox 68. A web site I visit daily always shows a popup asking me to accept cookies ("aceptar y continuar navegando"). It's annoying.

In options, I've selected "standard" for the cookie policy. I've emptied the cache, used the "forget this site" in the history for the web pages where the message pops up, and reloaded Firefox. It still prompts me.

Here's one of the pages it happens on: https://www.antena3.com/series/el-secreto-de-puente-viejo/avances/ Click "avances" or "momentos" and a large black box should pop up on the bottom of the screen, with the "aceptar y continuar navegando" in the lower right in a red rectangle.

Essentially, I want to tell the web site that I accept having cookies and have the web site remember my answer for the future.

Firefox 68. A web site I visit daily always shows a popup asking me to accept cookies ("aceptar y continuar navegando"). It's annoying. In options, I've selected "standard" for the cookie policy. I've emptied the cache, used the "forget this site" in the history for the web pages where the message pops up, and reloaded Firefox. It still prompts me. Here's one of the pages it happens on: https://www.antena3.com/series/el-secreto-de-puente-viejo/avances/ Click "avances" or "momentos" and a large black box should pop up on the bottom of the screen, with the "aceptar y continuar navegando" in the lower right in a red rectangle. Essentially, I want to tell the web site that I accept having cookies and have the web site remember my answer for the future.
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

WMagicModel
  • Top 10 Contributor
  • Administrator
13 izisombululo 195 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hi RemySecor,

From what I understand, from this extension you can select sites that you wish to have more control over your cookies; as well as being able to 'WhiteList' them.

Cookie AutoDelete {link}

Hope this answered your question!

Hi RemySecor, From what I understand, from this extension you can select sites that you wish to have more control over your cookies; as well as being able to 'WhiteList' them. [https://addons.mozilla.org/en-US/firefox/addon/cookie-autodelete/ Cookie AutoDelete] {link} Hope this answered your question!
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jscher2000
  • Top 10 Contributor
8695 izisombululo 71076 izimpendulo
Kuphostiwe

Hi RemySecor, you mentioned --

In options, I've selected "standard" for the cookie policy.

-- do you mean in the Content Blocking section of the page?

As you might suspect, the answer you give to the question of whether you accept cookies is saved in a cookie. If for some reason that cookie is cleared and Firefox can't send it to the site the next time you visit, the site will have to ask again.

How could the cookie be cleared?

(1) If you are visiting the site in a private window

Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session.

The two ways a site could open in a private window are:

(A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window)

(B) Setting Firefox to use automatic private browsing on the Preferences page --

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, then scroll down to the History section. Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.

You can check for this on the Options/Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies.

(3) If Firefox is set to Clear History When it Closes and that includes Cookies

Most people do not have this setting, but you can double-check here: On the Options/Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with some types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared.

(4) If you use an add-on that modifies how cookies work

There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container.

(5) If external utility or privacy software cleans browser cookies

If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data.

Does any of that help?

Hi RemySecor, you mentioned -- <blockquote> In options, I've selected "standard" for the cookie policy. </blockquote> -- do you mean in the Content Blocking section of the page? As you might suspect, the answer you give to the question of whether you accept cookies is saved in a cookie. If for some reason that cookie is cleared and Firefox can't send it to the site the next time you visit, the site will have to ask again. '''''How could the cookie be cleared?''''' '''(1) If you are visiting the site in a private window''' Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session. The two ways a site could open in a private window are: (A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window) (B) Setting Firefox to use automatic private browsing on the Preferences page -- * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click '''Privacy & Security''', then scroll down to the '''History''' section. Either of these will invoke automatic private browsing: * Firefox will: Never remember history * Firefox will: Use custom settings for history + "Always use private browsing mode" '''(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.''' You can check for this on the Options/Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies. <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-05-01-08-10-39-73a6c7.png" width="500"> '''(3) If Firefox is set to Clear History When it Closes and that includes Cookies''' Most people do not have this setting, but you can double-check here: On the Options/Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with ''some'' types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared. '''(4) If you use an add-on that modifies how cookies work''' There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container. '''(5) If external utility or privacy software cleans browser cookies''' If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data. Does any of that help?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Yes, I was talking about the Privacy & Security/Content Blocking section of Options. It is set to " standard" "Delete cookies & site data" is NOT checked In the manage data section, there are 3 entries for the antena3 web site (antena3.com - 12 cookies, www.antena3.com - 9 cookies, antenat-e-programaxion-by.accengage... - 0 cookies)

History:

   Remember browsing & download history is checked
   Remember search and form history is checked
   the others are unchecked

I'm not using a private window, nor is that the default.

I do have a "toggle cookies" addon to enable/disable cookies, but it's been set to "on". (https://github.com/M-Reimer/togglecookies). I disabled it and tried the antena3 web site again. No difference. It keeps prompting me. (In the Data Management, there are now 12 cookies for the site & the time stamp goes from yesterday to minutes ago)

"Extensions that isolate pages in a container" - how would I know if I have one that does that?

I don't use CClearner etc.

I do periodically clear the cache but that certainly doesn't affect other sites that use cookies (don't they all?)

Yes, I was talking about the Privacy & Security/Content Blocking section of Options. It is set to " standard" "Delete cookies & site data" is NOT checked In the manage data section, there are 3 entries for the antena3 web site (antena3.com - 12 cookies, www.antena3.com - 9 cookies, antenat-e-programaxion-by.accengage... - 0 cookies) History: Remember browsing & download history is checked Remember search and form history is checked the others are unchecked I'm not using a private window, nor is that the default. I do have a "toggle cookies" addon to enable/disable cookies, but it's been set to "on". (https://github.com/M-Reimer/togglecookies). I disabled it and tried the antena3 web site again. No difference. It keeps prompting me. (In the Data Management, there are now 12 cookies for the site & the time stamp goes from yesterday to minutes ago) "Extensions that isolate pages in a container" - how would I know if I have one that does that? I don't use CClearner etc. I do periodically clear the cache but that certainly doesn't affect other sites that use cookies (don't they all?)
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8695 izisombululo 71076 izimpendulo
Kuphostiwe

Hi, that sounds like your settings are good.

RemySecor said

In the manage data section, there are 3 entries for the antena3 web site (antena3.com - 12 cookies, www.antena3.com - 9 cookies, antenat-e-programaxion-by.accengage... - 0 cookies)

Are they still there after you exit and restart Firefox?

I do periodically clear the cache but that certainly doesn't affect other sites that use cookies (don't they all?)

Cookies are not stored in cache, so as long as the method you use is limited to cache, it's not causing the problem.


Another possible reason a site might want to re-confirm your device would be if it only honors the cookie as long as your IP address remains stable. This would mostly affect devices that connect to the site using different networks such as home, work, school, coffee shop, etc.

In some cases, one of the connection settings could be an issue:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

  • The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting
  • "Auto-detect" can lead to a flaky connection -- avoid this one if sites lose track of you
  • You could experiment with "No proxy"
Hi, that sounds like your settings are good. ''RemySecor [[#answer-1248150|said]]'' <blockquote> In the manage data section, there are 3 entries for the antena3 web site (antena3.com - 12 cookies, www.antena3.com - 9 cookies, antenat-e-programaxion-by.accengage... - 0 cookies) </blockquote> Are they still there after you exit and restart Firefox? <blockquote> I do periodically clear the cache but that certainly doesn't affect other sites that use cookies (don't they all?) </blockquote> Cookies are not stored in cache, so as long as the method you use is limited to cache, it's not causing the problem. ---- Another possible reason a site might want to re-confirm your device would be if it only honors the cookie as long as your IP address remains stable. This would mostly affect devices that connect to the site using different networks such as home, work, school, coffee shop, etc. In some cases, one of the connection settings could be an issue: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. * The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting * "Auto-detect" can lead to a flaky connection -- avoid this one if sites lose track of you * You could experiment with "No proxy"
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157964 izimpendulo
Kuphostiwe

You can create one cookie exception for the top level domain with the proper protocol to cover the www. prefix as well.

You can create one cookie exception for the top level domain with the proper protocol to cover the www. prefix as well. *https://antena3.com
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 - Yes, the cookies are still there after I restart. The network setting is already "no proxy" and this is a home computer so IP address should be stable.

cor-el: I'm not sure what you mean. The Data Management section seems designed to delete cookies not add them. And the top level of that web site does not prompt for cookie acceptance.

jscher2000 - Yes, the cookies are still there after I restart. The network setting is already "no proxy" and this is a home computer so IP address should be stable. cor-el: I'm not sure what you mean. The Data Management section seems designed to delete cookies not add them. And the top level of that web site does not prompt for cookie acceptance.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
McCoy
  • Top 10 Contributor
534 izisombululo 5035 izimpendulo
Kuphostiwe

Hello RemySecor,

Would you try this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Hello RemySecor, Would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

McCoy, I checked the Page Info. Cookies were set to "default". I changed to "allow".

Restarted Firefox.

Avances - prompts. Checked Page Info. Cookies allowed. Clicked on Accept & continue. Momentos - prompts. Checked Page Info. Cookies allowed. Clicked on Accept & continue. Went back to Avances. Prompted again. Wash, rinse, repeat.

McCoy, I checked the Page Info. Cookies were set to "default". I changed to "allow". Restarted Firefox. Avances - prompts. Checked Page Info. Cookies allowed. Clicked on Accept & continue. Momentos - prompts. Checked Page Info. Cookies allowed. Clicked on Accept & continue. Went back to Avances. Prompted again. Wash, rinse, repeat.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17479 izisombululo 157964 izimpendulo
Kuphostiwe

I checked the website and am able to replicate seeing the confirmation pop-up, so apparently the website stores this in a way that it doesn't span multiple sessions

The website also uses IndexedDB and Local Storage when I check this in the "Site Identity Button".

I checked the website and am able to replicate seeing the confirmation pop-up, so apparently the website stores this in a way that it doesn't span multiple sessions The website also uses IndexedDB and Local Storage when I check this in the "Site Identity Button".
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el Thank you. At least I know it's got nothing to do with any of my add-ons.

I did check the site out in Chrome (yea, I know, I should have thought of this days ago). In Chrome, the site does remember my selection.

Any idea if this is fixable? Is it something that should be reported to Mozilla?

cor-el Thank you. At least I know it's got nothing to do with any of my add-ons. I did check the site out in Chrome (yea, I know, I should have thought of this days ago). In Chrome, the site does remember my selection. Any idea if this is fixable? Is it something that should be reported to Mozilla?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Impendulo Ewusizo

I submitted a bug report to Mozilla (#1578855). They were able to duplicate the problem and have figured out what is causing it.

I submitted a bug report to Mozilla (#1578855). They were able to duplicate the problem and have figured out what is causing it.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.