Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Widevine plugin keeps crashing

  • 19 uphendule
  • 2 zinale nkinga
  • 36 views
  • Igcine ukuphendulwa ngu branbro365

more options

Issue on both Amazon Prime and Netflix. I've tried multiple options like removing the Widevine folder from my profile so it downloads another, unchecking the play DRM field and then turning it on again but nothing has helped.

When playing a video from Netflix, the console gives this message, (MediaKeySystemAccess::GetKeySystemStatus(com.widevine.alpha) result=available msg=)

I am on Firefox Quantum 68.0.2 (64 bit) and the Widevine plugin version is 4.10.1440.18

All Replies (19)

more options

Hello Aqiul,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Hi!

Thank you for your response. I used the Help menu to start Firefox in safe mode and the Widevine plugin still crashed.

Tried it with Netflix.

more options

Are you in a Private window or Always Use Private Mode When Browsing?

more options

Also, looking up the error message, indicates that some kind of blocking is happening. Try disabling Content Blocking and/or your security software.

There may have been some blocking occur when you re-installed Widevine, also.

more options

No I do not use Private mode.

My_Cheese_Is_Slippin' said

Also, looking up the error message, indicates that some kind of blocking is happening. Try disabling Content Blocking and/or your security software. There may have been some blocking occur when you re-installed Widevine, also.

There is something strange happening. I use BitDefender and looking at the logs, its been blocking this JSON file every few hours. It doesn't seem to coincide with the streaming attempt though.

https://surveygizmobeacon.s3.amazonaws.com/beaconconfigs/MjgwNDktQUYyRDQ3ODk0MjY1NEVFNUIwNTI3MjhFMDk2QTE3RDU%3D.json

I opened that JSON on a different browser and the file seems to contain the production and staging URLs for Mozilla support, alongwith a survey link which doesn't work.

Beyond that, I've added the Widevine folder into exceptions on BitDefender with no success.

Also streaming works fine on Brave without any issues.

more options

You wouldn't happen to have the rest of the MediaKeySystemAccess::GetKeySystemStatus message?

I also found this: One Reddit user, who frequently streams Netflix on Firefox, had an issue with the Widevine CDM. He said he tried a variety of common fixes including safe mode, turning DRM off and on again, reinstalling, creating a new profile, clearing all of his browsing data.

He finally found a fix- apparently by temporarily removing his HOSTS file from C:\Windows\System32\drivers\etc and then restarting Firefox, it enabled the module to update itself and clear the error. Specifically, the HOSTS file was blocking ‘0.0.0.0 redirector.gvt1. com’.

By removing that, it enabled Firefox to update Widevine DRM, according to this user.

more options

I am adding a screenshot of the console here. It shows all the messages since I press play on Amazon Prime.

I did this after moving the hosts file to a different folder and restarting Firefox. It did not trigger an update. Is there a way to check what the latest version of Widevine is?

more options

I have version 4.10.1440.18.

You can check configuration entries against mine:

Type about:config in the address bar and press enter Select "I Accept The Risk!" (if asked) Type widevine in the search bar at the top

You should see the same as in the image.

The entry media.decoder-doctor.notifications-allowed = MediaWMFNeeded,MediaWidevineNoWMF,MediaCannotInitializePulseAudio,MediaCannotPlayNoDecoders,MediaUnsupportedLibavcodec

more options

I have the same version as you. The values for media.decoder-doctor.notifications-allowed match in my config as well. Though from your screenshot, I can see mine is missing one entry, media.gmp-widevinecdm.autoupdate

I added it the same way it shows in your screenshot and restarted firefox. Still get the same issue.

But considering I do have the latest version, what would it even upgrade to?

more options

Here CORS request did not succeed "is caused by a browser plugin (e.g. an ad blocker or privacy protector) blocking the request."

And here CORS request did not succeed "It sounds like you are running this in dev mode."

more options

I went back to Firefox Safe mode to see the console output, I don't get a CORS error there but a WebGL one so I guess the CORS error does come from some addon. But the plugin is crashing even without it. The promise rejected message seems the same.

I also tried dialing down the Content Blocking from Custom to Standard with no success.

more options

Found this at How can I enable WebGL in my browser?

In Firefox enable WebGL:

Go to about:config Search for webgl.disabled Ensure that its value is false (any changes take effect immediately without relaunching Firefox)

Then inspect the status of WebGL:

Go to about:support Inspect the WebGL Renderer row in the Graphics table: If the status contains a graphics card manufacturer, model and driver (eg: "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine"), then WebGL is enabled. If the status is something like "Blocked for your graphics card because of unresolved driver issues" or "Blocked for your graphics driver version", then your graphics card/driver is blacklisted.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

Go to about:config Search for webgl.force-enabled Set it to true

(Like Chrome, Firefox has a Use hardware acceleration when available checkbox, in Preferences > Advanced > General > Browsing. However, unlike Chrome, Firefox does not require this checkbox to be checked for WebGL to work.)

more options

webgl.disabled is set to false.

WebGL renderer values look fine, I've added a screenshot.

Also, thank you for the help you've been giving so far :)

more options

I was reading through some threads earlier and some people mentioned that problems with Widevine were site specific to Netflix and Amazon Prime. Maybe I'm just plucking at straws, right now, but could you try another site? Like IMDbTv?

more options

My_Cheese_Is_Slippin' said

I was reading through some threads earlier and some people mentioned that problems with Widevine were site specific to Netflix and Amazon Prime. Maybe I'm just plucking at straws, right now, but could you try another site? Like IMDbTv?

IMDB TV doesn't work here in India but I tried hotstar.com which is a streaming service here and Widevine crashed there as well :(

I also have some purchased movies on Youtube which crash the plugin if I try to play them. Youtube works fine for the free stuff.

more options

Let's try an empty Test Profile.

Type about:profiles in the address bar and press Enter. Select Create A New Profile Follow the steps in the Wizard.

When it is finished select Launch In A New Window.

Go to Plug-ins and make sure Widevine has downloaded and is Active.

Try Netflix or Prime Video.


BTW: I found a quick test site for WebGL at https://get.webgl.org/

more options

If the Widevine plug-in does not work in the Test Profile, do a Clean Install.

Note: A clean install will not delete your bookmarks, saved passwords, add-ons or other personal information. This information is stored separately in your profile folder.

Here's how to do a clean install of Firefox:

Uninstall Firefox from your computer.

Delete the Firefox installation folder (located in one of these folders by default): C:\Program Files\Mozilla Firefox C:\Program Files (x86)\Mozilla Firefox

(If you have one - run a Registry cleaner)

Restart your computer.

Download a fresh copy of Firefox at https://www.mozilla.org/en-US/firefox/new/#download-fx (There is a link to get Firefox in a different language, if you like.)

Double-click on the downloaded file and follow the prompts to continue the installation process.


If the Widevine plug-in does work in the Test Profile, you can copy your personal information from your current profile to the new profile. This article explains the specific files in detail: https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

more options

Will try both options when I get back home in a day or so. Thanks!

more options

I am having the same issue, it started 3 days ago after Widevine updated, now everytime I try to watch Amazone Prime it says Widevine has crashed. I'm looking for a easy solution, I'm not looking to go int the settings and do any type of developer crap with code, Mozilla needs to fix this, or Widevine needs to fix their crappy latest update that crashes. This should be as easy as rolling back to the last working update but I don't see that option any where. So does someone have a fix for this or am I gonna need someone with a bachelors in computer science to solve this problem, because that's how it's looking right now.