X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

I want to stop private browsing when I open firefox.

Kuphostiwe

When I open Firefox it automatically opens in Private Browsing. This is a nuisance since it means logging into everything every time I open.

When I open Firefox it automatically opens in Private Browsing. This is a nuisance since it means logging into everything every time I open.
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

Sg 0 izisombululo 3 izimpendulo
Kuphostiwe

Hi, Please follow these steps - Click the Firefox button and click Options to open the Options dialog box. Click the checkbox labeled "Always use private browsing" to clear it. Click the drop-down box labeled "Firefox will" and click "Remember history" and then click "OK." Click the Firefox button and click "Stop Private Browsing."

Hi, Please follow these steps - Click the Firefox button and click ''Options'' to open the Options dialog box. Click the checkbox labeled "Always use private browsing" to clear it. Click the drop-down box labeled "Firefox will" and click "Remember history" and then click "OK." Click the Firefox button and click "Stop Private Browsing."
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157353 izimpendulo
Kuphostiwe

You can also check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

You can also check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program. *https://support.mozilla.org/en-US/kb/wrong-home-page-opens-when-i-start-firefox-how-fix *https://developer.mozilla.org/en-US/Command_Line_Options
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

This is not clear at all. I don't see any checkbox for private browsing.

This is not clear at all. I don't see any checkbox for private browsing.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Sg 0 izisombululo 3 izimpendulo
Kuphostiwe
https://www.youtube.com/watch?v=D1U_71AdAiE - this might be helpful
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Sg 0 izisombululo 3 izimpendulo
Kuphostiwe

DISABLE PRIVATE BROWSING FOR FIREFOX To disable private browsing in Firefox, you need to download a JSON file from GitHub. There are registry changes you could make but I couldn’t get those to work on my Windows 10 PC. This JSON file worked fine.

Download the Windows file from GitHub (https://github.com/mozilla/policy-templates/)

Navigate to your Firefox installation directory. Open or create a folder called ‘distribution’. Place the JSON file inside that folder. Try to open a private window in Firefox to test. If that doesn’t work, you could try the registry tweak as it may work for you.

Type ‘regedit’ into the Windows Search box and select Registry Editor. Navigate to ‘HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox’. Create a Mozilla entry if there isn’t one by right clicking in the left pane, selecting New and Key and naming it Mozilla. Repeat this from within the Mozilla key and call the new key Firefox. Select that final Firefox key in the left pane and right click an empty space in the right pane. Select New and then DWORD (32-Bit) Value. Name it ‘DisablePrivateBrowsing’ and give it a value of 1. Shut down Firefox if it is open and test it.

Source : https://www.techjunkie.com/disable-private-browsing-firefox/

DISABLE PRIVATE BROWSING FOR FIREFOX To disable private browsing in Firefox, you need to download a JSON file from GitHub. There are registry changes you could make but I couldn’t get those to work on my Windows 10 PC. This JSON file worked fine. Download the Windows file from GitHub (https://github.com/mozilla/policy-templates/) Navigate to your Firefox installation directory. Open or create a folder called ‘distribution’. Place the JSON file inside that folder. Try to open a private window in Firefox to test. If that doesn’t work, you could try the registry tweak as it may work for you. Type ‘regedit’ into the Windows Search box and select Registry Editor. Navigate to ‘HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox’. Create a Mozilla entry if there isn’t one by right clicking in the left pane, selecting New and Key and naming it Mozilla. Repeat this from within the Mozilla key and call the new key Firefox. Select that final Firefox key in the left pane and right click an empty space in the right pane. Select New and then DWORD (32-Bit) Value. Name it ‘DisablePrivateBrowsing’ and give it a value of 1. Shut down Firefox if it is open and test it. Source : https://www.techjunkie.com/disable-private-browsing-firefox/
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Both PC and cell are locked in private mode. Changing to Chrome. Frustrated with Firefox.

Both PC and cell are locked in private mode. Changing to Chrome. Frustrated with Firefox.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
jscher2000
  • Top 10 Contributor
8637 izisombululo 70651 izimpendulo
Kuphostiwe

bostonappleton said

Sg said
Hi, Please follow these steps - Click the Firefox button and click Options to open the Options dialog box. Click the checkbox labeled "Always use private browsing" to clear it. Click the drop-down box labeled "Firefox will" and click "Remember history" and then click "OK." Click the Firefox button and click "Stop Private Browsing."

This is not clear at all. I don't see any checkbox for private browsing.

Your Firefox history settings may be set to "Never Remember History". Take a look here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What is your setting here:

(1) Firefox will: Remember history

This setting is not causing your problem. It is coming from somewhere else. (Where? TBD!)

(2) Firefox will: Never remember history

Change this setting to Remember history

(3) Firefox will: Use custom settings for history

In this case, you should see the checkbox for "Always use private browsing mode" and you can uncheck it if it's checked.

Any progress so far?

''bostonappleton [[#answer-1244746|said]]'' <blockquote> ''Sg [[#answer-1244741|said]]'' <blockquote> Hi, Please follow these steps - Click the Firefox button and click ''Options'' to open the Options dialog box. Click the checkbox labeled "Always use private browsing" to clear it. Click the drop-down box labeled "Firefox will" and click "Remember history" and then click "OK." Click the Firefox button and click "Stop Private Browsing." </blockquote> This is not clear at all. I don't see any checkbox for private browsing. </blockquote> Your Firefox history settings may be set to "Never Remember History". Take a look here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click Privacy & Security On the right side, scroll down to the History section. What is your setting here: '''(1) Firefox will: Remember history''' This setting is not causing your problem. It is coming from somewhere else. (Where? TBD!) '''(2) Firefox will: Never remember history''' Change this setting to Remember history '''(3) Firefox will: Use custom settings for history''' In this case, you should see the checkbox for "Always use private browsing mode" and you can uncheck it if it's checked. Any progress so far?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157353 izimpendulo
Kuphostiwe
See also: *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.