X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox tab persistently crashes on some sites Ubuntu 19.04

Kuphostiwe

1. Fresh FF install on freshly installed Xubuntu 19.04 in Vbox. 2. FF started ok. Open different tabs, certain sites at different stages crashes with 'Gah. Your tab just crashed' message: (just a few examples of sites below)

2a. Technet: https://social.technet.microsoft.com/Forums/windows/en-US/cf6ceadd-4bb4-4668-b8fb-8ccf7d067e31/diagnostic-policy-service-high-cpu

2b. http://www.ctrip.com/ - Started to load, but when it is almost fully completed, it crashed.

2c. mail.yahoo.com - After keying in user name, the next page for password crashes.

3. Steps tried: Had googled left right center but nothing of help. Some articles that seem close, tried but failed: 3a. disable multi-process tabs doesn't help :

          browser.tabs.remote.autostart = false 
          browser.tabs.remote.autostart.2 = false  (can't find this part though, only the above line)

3b. Disable hardware acceleration - doesn't help.

3c. There is no extension nor theme added, it's a newly installed FF and OS.

4. What works: safe mode. All the sites listed above are able to load in safe mode.

5. There is no crash report? Is it because it is a tab crash rather than a full crash?


Please help ...

1. Fresh FF install on freshly installed Xubuntu 19.04 in Vbox. 2. FF started ok. Open different tabs, certain sites at different stages crashes with 'Gah. Your tab just crashed' message: (just a few examples of sites below) 2a. Technet: https://social.technet.microsoft.com/Forums/windows/en-US/cf6ceadd-4bb4-4668-b8fb-8ccf7d067e31/diagnostic-policy-service-high-cpu 2b. http://www.ctrip.com/ - Started to load, but when it is almost fully completed, it crashed. 2c. mail.yahoo.com - After keying in user name, the next page for password crashes. 3. Steps tried: Had googled left right center but nothing of help. Some articles that seem close, tried but failed: 3a. disable multi-process tabs doesn't help : browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false (can't find this part though, only the above line) 3b. Disable hardware acceleration - doesn't help. 3c. There is no extension nor theme added, it's a newly installed FF and OS. 4. What works: safe mode. All the sites listed above are able to load in safe mode. 5. There is no crash report? Is it because it is a tab crash rather than a full crash? Please help ...

Okulungisiwe ngu miyos

Isisombululo esikhethiwe

You can check the current multi-process settings and stats on the about:support page to see whether there are differences between normal mode and safe mode.

You can start Firefox via a Bash script to set the environment variable to disable multi-process.

#!/bin/sh

export MOZ_FORCE_DISABLE_E10S=1
cd <path-to-firefox>
./firefox
Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

none

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17413 izisombululo 157294 izimpendulo
Kuphostiwe

You can't disable multi-process via a pref on the about:config page, so browser.tabs.remote.autostart to false won't have effect. Disabling multi-process can only be done via an environment variable (MOZ_FORCE_DISABLE_E10S=1).

Did you check for memory issues (i.e. does Firefox has enough memory available)?

You can check the Firefox Task Manager (about:performance) and about:memory pages.

You can't disable multi-process via a pref on the <b>about:config</b> page, so browser.tabs.remote.autostart to false won't have effect. Disabling multi-process can only be done via an environment variable (MOZ_FORCE_DISABLE_E10S=1). Did you check for memory issues (i.e. does Firefox has enough memory available)? You can check the Firefox Task Manager (about:performance) and about:memory pages. *https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox *https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

I forgotten to mention that I had found articles about memory issue. My Vbox only uses close to 50% memory. And FF just need to open 1 tab and it will crash on those URLs. Don't think it needs that much memory for a tab? Anyway I still have 1 GB memory left. So I don't think memory should be an issue.

Regarding disabling multi-process, what is the best way to add and set value to new variable "MOZ_FORCE_DISABLE_E10S" in Ubuntu?

So far the main difference here is normal mode and safe mode. In safe mode I'm good. So what's the difference in safe mode compared to normal mode? Is there any switches that I can turn them off for normal mode?

Thanks for your help.

I forgotten to mention that I had found articles about memory issue. My Vbox only uses close to 50% memory. And FF just need to open 1 tab and it will crash on those URLs. Don't think it needs that much memory for a tab? Anyway I still have 1 GB memory left. So I don't think memory should be an issue. Regarding disabling multi-process, what is the best way to add and set value to new variable "MOZ_FORCE_DISABLE_E10S" in Ubuntu? So far the main difference here is normal mode and safe mode. In safe mode I'm good. So what's the difference in safe mode compared to normal mode? Is there any switches that I can turn them off for normal mode? Thanks for your help.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I'm still encountering the irritating 'Gah. Your tab just crashed' message. This community support seems extremely quiet. Is there any other resources that I can seek?

I'm still encountering the irritating 'Gah. Your tab just crashed' message. This community support seems extremely quiet. Is there any other resources that I can seek?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17413 izisombululo 157294 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You can check the current multi-process settings and stats on the about:support page to see whether there are differences between normal mode and safe mode.

You can start Firefox via a Bash script to set the environment variable to disable multi-process.

#!/bin/sh

export MOZ_FORCE_DISABLE_E10S=1
cd <path-to-firefox>
./firefox
You can check the current multi-process settings and stats on the about:support page to see whether there are differences between normal mode and safe mode. You can start Firefox via a Bash script to set the environment variable to disable multi-process. <pre><nowiki> #!/bin/sh export MOZ_FORCE_DISABLE_E10S=1 cd <path-to-firefox> ./firefox </nowiki></pre>
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Hi cor-el,

Thanks! This helps! Solved! I set it directly in firefox.sh.

Hi cor-el, Thanks! This helps! Solved! I set it directly in firefox.sh.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.