Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

WebGL in Firefox stopped working

  • 5 uphendule
  • 1 inale nkinga
  • 3444 views
  • Igcine ukuphendulwa ngu clake1

more options

I can't view WebGL content anymore. It used to work until a few weeks ago (sorry I can't be more specific). It works OK on other browsers on my computer.

How do I get WebGL working again?

Okulungisiwe ngu txpt

Isisombululo esikhethiwe

Seems the update to 68.0.2 did the trick. Thanks Mozilla!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

You can try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

You can check the Graphics section on the about:support (Help -> Troubleshooting Information) page.

more options

Thanks cor-el . Looks like I might be on to something. In about:support, in the graphics section under WebGL 1 Driver Renderer it says:

WebGL creation failed:

  • Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_OLD_NVIDIA
  • Exhausted GL driver options.

And under WebGL 2 Driver Renderer I get:

WebGL creation failed:

  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_NVIDIA

Can anyone help me interpret this and help to to find a solution?

more options

Problem has disappeared. Go figure...

more options

Isisombululo Esikhethiwe

Seems the update to 68.0.2 did the trick. Thanks Mozilla!

more options

With amd HD 4200 graphics chip:

There was no webgl after updating from 60.9esr to 68.2.0esr on debian, and from debian standard repo.

After setting webgl.force-enabled true, webgl1 works, but no webgl2.

WebGL creation failed:

  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_FGLRX

GPU: GPU #1 Active Yes Description Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.9.0-11-amd64, LLVM 3.9.1) Vendor ID 0x1002 Device ID 0x9710 Driver Vendor mesa/r600 Driver Version 13.0.6.0 RAM 256MB

The ff tarball from mozilla org extracted to /opt shows same behaviour. It should work, but it seems to be looking for fglrx when open source driver/mesa is installed.