Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google News not working properly w/ Firefox

more options

I can access Google News but when I click a heading ( Sports, Science etc. ) to view more results the the screen lightens up & a blue bar @ the top keeps moving across the screen ( loading? ). If I right click to open link in new tab I get more results but not the complete list ( there is a spinning wheel ). This does not happen using Chrome.

All Replies (9)

more options

Hello canyonlight,

Same thing happened just now when I tried it - so this is what I did and what I would ask you to do :

When on news.google.com click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies".

Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work for you ?

more options

Nope. Only way it works is if I open in a new tab.

more options

'Just did what I should have done before : took a look at your system details and it shows this extension :

"Cookie Restrictions Strict List Study 3.1 (cookie-restrictions-strict-list@shield.mozilla.org) "

(apparantly in Options => Privacy & Security => under "Firefox Data Collection and Use" you checked "Allow Firefox to install and run studies")

Would you please disable (or remove) that extension and see if that will make a difference ?

You will find it either in Options => Add-ons => Extensions, or when you type about:studies in the address bar and press Enter.

Okulungisiwe ngu McCoy

more options

Still no joy. Only works opening a new tab.

more options

canyonlight3142 said

Still no joy. Only works opening a new tab.

It worked for me before, but now it does the same thing it does for you  :(

I don't know what's causing it - 'hoping someone else will come to your rescue (sorry .... )

more options

Thanks for trying. It's also glitchy for me. Every once in a while it sorta works.

more options

canyonlight3142 said

Thanks for trying. It's also glitchy for me. Every once in a while it sorta works.

'Just tried it in Edge : doesn't work either ......

Makes me kinda glad to see that it's not a Firefox issue.

But that still doesn't solve your problem though  :(

more options

When on news.google.com click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

(well, you know the drill by now .... )

Click on the 'Permissions" tab and scroll down to "Access Your Location".

Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work for you ?

I just tried, and lo and behold : it works  !

more options

No change. At least the open link in new tab works. What is strange is that the same URL works in a new tab & not in the original.