X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to remove padding from paragraphs? (i.e. how to get single line spacing? / how to remove white space?)

Kuphostiwe

No matter whether using "Body Text" or "Paragraph" options, I still get padding above and below each paragraph. This is when I hit enter twice between paragraphs. I have already read a number of questions and answers around this topic. So yes I know about "Tools > Options > Composition > General tab, uncheck "When using paragraph format, the enter key creates a new paragraph.". It doesn't work for what I want. TBird still pads paragraphs (adds white space above and below each para). In fact, on the ribbon menu, toggle a few times between Body Text and Paragraph, and TBird just adds more white space . Gaaah. Stop it.

Really, what you guys are coding is not good. I don't want crazy-long spread-out emails with masses of white space. Nor do I want to type without double-enter para spacing, coz I want to control what formatting people see and how their print-out looks. Can't you just go back to not thinking too hard? Think MS Notepad - just the plain vanilla text editor look. Please. Seriously. I know you're volunteers, and thanks. But guys, please.

No matter whether using "Body Text" or "Paragraph" options, I still get padding above and below each paragraph. This is when I hit enter twice between paragraphs. I have already read a number of questions and answers around this topic. So yes I know about "Tools > Options > Composition > General tab, uncheck "When using paragraph format, the enter key creates a new paragraph.". It doesn't work for what I want. TBird still pads paragraphs (adds white space above and below each para). In fact, on the ribbon menu, toggle a few times between Body Text and Paragraph, and TBird just adds more white space . Gaaah. Stop it. Really, what you guys are coding is not good. I don't want crazy-long spread-out emails with masses of white space. Nor do I want to type without double-enter para spacing, coz I want to control what formatting people see and how their print-out looks. Can't you just go back to not thinking too hard? Think MS Notepad - just the plain vanilla text editor look. Please. Seriously. I know you're volunteers, and thanks. But guys, please.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36 OPR/62.0.3331.43

Eminye Imininingwane

Matt
  • Top 10 Contributor
  • Moderator
3393 izisombululo 23509 izimpendulo
Kuphostiwe

Options > Composition > General. Change the setting for use paragraph formatting

https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_mail-composition

Options > Composition > General. Change the setting for use paragraph formatting https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_mail-composition

Umnikazi wombuzo

Unfortunately my question was too long. So TLDR. As I said, "I know about "Tools > Options > Composition > General tab", and the checkbox does not solve the problem of excessive white space padding around paragraphs.

However, I see from your link that this is new intentional behaviour in the latest version - which makes sense because the old workaround, which was to compose the email in MS Word and cut-paste to avoid Tbird's weird ways, no longer works. Tbird has found out about that naughty workaround, and now insists all paras will have huge padding.

Although, even more oddly, I try it just now typing (composing) directly into Tbird and paras are only padded above (slightly good, but not what I'm after, which is just a straight CR/LF look, not 'formatted' for me). Maybe I am being extra punished for cut-pasting from Word, so I get extra padding below paras, as desserts for my naughtiness. But seriously, I suppose that means there's a bug in there. Cut-paste from Word, you will get huge padding above and below. I just tried it again. That's confirmed.

And just for fun, toggle between body test/paragraph in the menu bar options, and watch the padding grow even wider with each toggle. Zounds. It's like a bugfest.

And yet another funny thing, on this support page, we're able to type paras and good old double carriage returns quite happily, without some slab of code deciding to add lots of nice padding for us. Oh, if only Tbird would take notice of that.

Well, thanks anyway for taking time to reply. I do appreciate that. You've tried to help, so blessings to you. But maybe I'll need to find another email browser.

Unfortunately my question was too long. So TLDR. As I said, "I know about "Tools > Options > Composition > General tab", and the checkbox does not solve the problem of excessive white space padding around paragraphs. However, I see from your link that this is new intentional behaviour in the latest version - which makes sense because the old workaround, which was to compose the email in MS Word and cut-paste to avoid Tbird's weird ways, no longer works. Tbird has found out about that naughty workaround, and now insists all paras will have huge padding. Although, even more oddly, I try it just now typing (composing) directly into Tbird and paras are only padded above (slightly good, but not what I'm after, which is just a straight CR/LF look, not 'formatted' for me). Maybe I am being extra punished for cut-pasting from Word, so I get extra padding below paras, as desserts for my naughtiness. But seriously, I suppose that means there's a bug in there. Cut-paste from Word, you will get huge padding above and below. I just tried it again. That's confirmed. And just for fun, toggle between body test/paragraph in the menu bar options, and watch the padding grow even wider with each toggle. Zounds. It's like a bugfest. And yet another funny thing, on this support page, we're able to type paras and good old double carriage returns quite happily, without some slab of code deciding to add lots of nice padding for us. Oh, if only Tbird would take notice of that. Well, thanks anyway for taking time to reply. I do appreciate that. You've tried to help, so blessings to you. But maybe I'll need to find another email browser.
Chris LaPointe 0 izisombululo 1 izimpendulo
Kuphostiwe

The problem here is even if "Body Text" is the default,

  1. pasting text from Word, will always paste as "Paragraph" in compose window, even if "no spacing" is used in Word
  2. when selecting the text and change formatting to "Body Text" in the compose window, there will be additional blank lines between all text lines that blows up the text and looks ugly

So really, this is two problems together that create this issue. I often want to paste code snippets with syntax highlighting from Eclipse into emails. Since Thunderbird doesn't process the formatting (look, a third problem!), but Word does, I paste into Word first, then copy from Word into Thunderbird compose. This used to work a lot better in previous versions.

The problem here is even if "Body Text" is the default, # pasting text from Word, will '''always''' paste as "Paragraph" in compose window, even if "no spacing" is used in Word # when selecting the text and change formatting to "Body Text" in the compose window, there will be additional blank lines between all text lines that blows up the text and looks ugly So really, this is two problems together that create this issue. I often want to paste code snippets with syntax highlighting from Eclipse into emails. Since Thunderbird doesn't process the formatting (look, a third problem!), but Word does, I paste into Word first, then copy from Word into Thunderbird compose. This used to work a lot better in previous versions.

Okulungisiwe ngu Chris LaPointe

al911 0 izisombululo 2 izimpendulo
Kuphostiwe

Hello I have the same problem since I switched over to version 68.x On a 13 inch screen, if you want to keep sufficently large letters, you are really limited in the number of mails aviable at one glance. Same problem in the left pane with all the files and you spend a lot of time scrolling up and down to reach what you are looking for. Hope you have a solution

Hello I have the same problem since I switched over to version 68.x On a 13 inch screen, if you want to keep sufficently large letters, you are really limited in the number of mails aviable at one glance. Same problem in the left pane with all the files and you spend a lot of time scrolling up and down to reach what you are looking for. Hope you have a solution