X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Three issues i've encountered with FF pdf built in viewer.

Kuphostiwe

windows 10/FF 68.0+ a few add-ons

Hello all

i wanted to use FF as my default PDF viewer and since i wasn't able to do so in the Windows settings, i right clicked on a file and chose my default program.

-first issue; all my pdf files took the FF icon instead of the default PDF one. only solutions I've found was changing things in the registry which i wont do and the other one(not sure if it works)was to reinstall FF which i prefer not to do since everything is nicely set up.

-second issue; in FF options i chose "always ask"in case i accidentally open a PDF file when clicking on a link in google search,not noticing it's a PDF document. the issue is that when i chose 'open' from the pop-up window,it opened a blank page,not the actual PDF i (haven't checked what happens with 'save'.) so i reverted to 'preview in Firefox'.(also i don't recall this happening with previous windows os;7-8.1)

-third issue(the worst one which caused a moment of panic :); choosing 'firefox to automatically open a file type' cause the opening of infinite blank tabs one after the other. it seems to be a very old bug and I'm surprised it hasn't been fixed yet, the solution is not to chose this option. can be viewed here: https://support.mozilla.org/en-US/kb/firefox-repeatedly-opens-empty-tabs-or-windows http://kb.mozillazine.org/File_types_and_download_actions#Setting_an_automatic_action

so for the moment being I've reverted to Edge as the default PDF viewer.

the main issue for me out of all these three, is to get those icons to show the correct description and not the FF one.

Thanks.

windows 10/FF 68.0+ a few add-ons Hello all i wanted to use FF as my default PDF viewer and since i wasn't able to do so in the Windows settings, i right clicked on a file and chose my default program. -first issue; all my pdf files took the FF icon instead of the default PDF one. only solutions I've found was changing things in the registry which i wont do and the other one(not sure if it works)was to reinstall FF which i prefer not to do since everything is nicely set up. -second issue; in FF options i chose "always ask"in case i accidentally open a PDF file when clicking on a link in google search,not noticing it's a PDF document. the issue is that when i chose 'open' from the pop-up window,it opened a blank page,not the actual PDF i (haven't checked what happens with 'save'.) so i reverted to 'preview in Firefox'.(also i don't recall this happening with previous windows os;7-8.1) -third issue(the worst one which caused a moment of panic :); choosing 'firefox to automatically open a file type' cause the opening of infinite blank tabs one after the other. it seems to be a very old bug and I'm surprised it hasn't been fixed yet, the solution is not to chose this option. can be viewed here: https://support.mozilla.org/en-US/kb/firefox-repeatedly-opens-empty-tabs-or-windows http://kb.mozillazine.org/File_types_and_download_actions#Setting_an_automatic_action so for the moment being I've reverted to Edge as the default PDF viewer. the main issue for me out of all these three, is to get those icons to show the correct description and not the FF one. Thanks.

Okulungisiwe ngu nickfree

Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

Your first issue (your main one) is not technically an issue. Windows uses the icon of the program that you use to open a file. The "default PDF icon" that you were seeing was likely the Adobe Reader icon. Since you've changed Firefox to the default, that will also change the icon that Windows uses for PDF files.

As for your third issue, it's because you don't have the PDF action set to Preview in Firefox. Setting it to something else may cause the issues described if you use Firefox the way that you are attempting to use it.

And for issue number two, it could be that the PDF file is using a feature not supported by the Firefox PDF Preview, so maybe it's downloading the file instead of viewing it. If you have the link to a specific PDF that's cause this to happen, it would be helpful for use to test the issue.

Hope this helps.

Your first issue (your main one) is not technically an issue. Windows uses the icon of the program that you use to open a file. The "default PDF icon" that you were seeing was likely the Adobe Reader icon. Since you've changed Firefox to the default, that will also change the icon that Windows uses for PDF files. As for your third issue, it's because you don't have the PDF action set to ''Preview in Firefox''. Setting it to something else may cause the issues described if you use Firefox the way that you are attempting to use it. And for issue number two, it could be that the PDF file is using a feature not supported by the Firefox PDF Preview, so maybe it's downloading the file instead of viewing it. If you have the link to a specific PDF that's cause this to happen, it would be helpful for use to test the issue. Hope this helps.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hello and Thanks. -i don't have Adobe,it's the default windows 10 PDF icon i guess. and i really would like to solve this issue, but after looking some more, it seems that only a registry modification can fix this.

for issue number two; it does what i described with files located on the hard drive,tested with a few PDF files.

Hello and Thanks. -i don't have Adobe,it's the default windows 10 PDF icon i guess. and i really would like to solve this issue, but after looking some more, it seems that only a registry modification can fix this. for issue number two; it does what i described with files located on the hard drive,tested with a few PDF files.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

For your second issue, you can't get the behaviour that you are looking for with the "Always Ask" option. This is because when you select Firefox from the dialog menu that appears, it will open a new tab. Then since the behaviour is to "Always Ask", it's going to open the same dialog again. It will be an infinite loop of new tabs.

This happens because "Preview with Firefox" is not an option that can be accessed using the "Always Ask" dialog. Your only option is to select the "Preview with Firefox" option.

For your second issue, you can't get the behaviour that you are looking for with the "Always Ask" option. This is because when you select Firefox from the dialog menu that appears, it will open a new tab. Then since the behaviour is to "Always Ask", it's going to open the same dialog again. It will be an infinite loop of new tabs. This happens because "Preview with Firefox" is not an option that can be accessed using the "Always Ask" dialog. Your only option is to select the "Preview with Firefox" option.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.