X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox 68.0 making multiple processes in the Task Manager, can't disable them at all.

Kuphostiwe

After Firefox updated to 68.0 the other day, I have found myself being plagued by it making multiple processes in the Task Manager yet again. I have already tried the following:

1) Already tried about:config to change browser.tabs.remote.autostart.2/browser.tabs.remote.autostart from true to false. It is set, but absolutely nothing has changed.

2) I have tried going into Options>Performance and limiting the Content Process Limit to 1 instead of 4. The setting was saved, and yet it has not changed a thing.

3) Ending these processes only results in my tabs crashing, and reloading them only adds another Firefox process.

But as it turns out here: https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/ Firefox has removed the option to turn this off entirely after updating.

My computer can't handle having more than 1 Firefox process open and I want to disable multiple processes, otherwise everything will lag horribly. Is there any way I can permanently disable the multiple processes?

After Firefox updated to 68.0 the other day, I have found myself being plagued by it making multiple processes in the Task Manager yet again. I have already tried the following: 1) Already tried about:config to change browser.tabs.remote.autostart.2/browser.tabs.remote.autostart from true to false. It is set, but absolutely nothing has changed. 2) I have tried going into Options>Performance and limiting the Content Process Limit to 1 instead of 4. The setting was saved, and yet it has not changed a thing. 3) Ending these processes only results in my tabs crashing, and reloading them only adds another Firefox process. But as it turns out here: https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/ Firefox has removed the option to turn this off entirely after updating. My computer can't handle having more than 1 Firefox process open and I want to disable multiple processes, otherwise everything will lag horribly. Is there any way I can permanently disable the multiple processes?

Isisombululo esikhethiwe

Felis-Licht said

I'm not sure how to do either of those things, is there a tutorial on how to do that?

Hello Felis-LIcht,

How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17422 izisombululo 157420 izimpendulo
Kuphostiwe

In Firefox 68+ you can only disable multi-process by creating an environment variable named MOZ_FORCE_DISABLE_E10S and set its value to 1. You can either use a .cmd file to start Firefox or set this variable in the Windows Control Panel -> System.

In Firefox 68+ you can only disable multi-process by creating an environment variable named MOZ_FORCE_DISABLE_E10S and set its value to 1. You can either use a .cmd file to start Firefox or set this variable in the Windows Control Panel -> System. *https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

In Firefox 68+ you can only disable multi-process by creating an environment variable named MOZ_FORCE_DISABLE_E10S and set its value to 1. You can either use a .cmd file to start Firefox or set this variable in the Windows Control Panel -> System.

I'm not sure how to do either of those things, is there a tutorial on how to do that?

''cor-el [[#answer-1237027|said]]'' <blockquote> In Firefox 68+ you can only disable multi-process by creating an environment variable named MOZ_FORCE_DISABLE_E10S and set its value to 1. You can either use a .cmd file to start Firefox or set this variable in the Windows Control Panel -> System. *https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html </blockquote> I'm not sure how to do either of those things, is there a tutorial on how to do that?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
521 izisombululo 4902 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Felis-Licht said

I'm not sure how to do either of those things, is there a tutorial on how to do that?

Hello Felis-LIcht,

How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

''Felis-Licht [[#answer-1237080|said]]'' <blockquote> I'm not sure how to do either of those things, is there a tutorial on how to do that? </blockquote> Hello Felis-LIcht, How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

McCoy said

Felis-Licht said
I'm not sure how to do either of those things, is there a tutorial on how to do that?

Hello Felis-LIcht,

How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

Thank you!

''McCoy [[#answer-1237084|said]]'' <blockquote> ''Felis-Licht [[#answer-1237080|said]]'' <blockquote> I'm not sure how to do either of those things, is there a tutorial on how to do that? </blockquote> Hello Felis-LIcht, How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm </blockquote> Thank you!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
521 izisombululo 4902 izimpendulo
Kuphostiwe

My pleasure - have a nice weekend !

My pleasure - have a nice weekend !
Ingabe lokhu kube usizo kuwena?
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

McCoy said

Felis-Licht said
I'm not sure how to do either of those things, is there a tutorial on how to do that?

Hello Felis-LIcht,

How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

What installation directory? People who give directions like these seem to be techies who think everybody else is as well and on the same page. what does this mean please?

''McCoy [[#answer-1237084|said]]'' <blockquote> ''Felis-Licht [[#answer-1237080|said]]'' <blockquote> I'm not sure how to do either of those things, is there a tutorial on how to do that? </blockquote> Hello Felis-LIcht, How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm </blockquote> What installation directory? People who give directions like these seem to be techies who think everybody else is as well and on the same page. what does this mean please?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17422 izisombululo 157420 izimpendulo
Kuphostiwe

You can create an environment variable in the Windows Control Panel.

  • Windows Control Panel -> System -> Advanced -> Environment variables

Otherwise you can start Firefox via a firefox-e10s.cmd file with this content:

set MOZ_FORCE_DISABLE_E10S=1

Add one of these depending on if you have a 64-bit or a 32-bit Firefox version (see "Help -> About Firefox" and the about:support page).

start "" "C:\Program Files\Mozilla Firefox\firefox.exe"
start "" "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

So firefox-e10s.cmd has two lines: a 'set' line and a 'start' line. You can use Notepad to create this file. You can create a desktop shortcut to use this firefox-e10s.cmd file to launch Firefox and disable multi-process.

Note that disabling this feature via a preference on the about:config page has been done for a reason as it breaks some features.

You can create an environment variable in the Windows Control Panel. *Windows Control Panel -> System -> Advanced -> Environment variables Otherwise you can start Firefox via a firefox-e10s.cmd file with this content: set MOZ_FORCE_DISABLE_E10S=1 Add one of these depending on if you have a 64-bit or a 32-bit Firefox version (see "Help -> About Firefox" and the about:support page). start "" "C:\Program Files\Mozilla Firefox\firefox.exe" start "" "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" So firefox-e10s.cmd has two lines: a 'set' line and a 'start' line. You can use Notepad to create this file. You can create a desktop shortcut to use this firefox-e10s.cmd file to launch Firefox and disable multi-process. Note that disabling this feature via a preference on the about:config page has been done for a reason as it breaks some features. *https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/ *https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html
Ingabe lokhu kube usizo kuwena?
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

I got as far as the advanced tab. Now am I adding something in "user variable for Robert" or "system variable"?

Thanks.

I got as far as the advanced tab. Now am I adding something in "user variable for Robert" or "system variable"? Thanks.

Okulungisiwe ngu ronen1968

Ingabe lokhu kube usizo kuwena?
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

I got as far as system variables in advanced under system properties, and added c:\program files\Mozilla firefox\firefox.exe after a semi-colon and adding to the "Path" line. I don't follow the rest of your description as to what I'm creating in notepad or where I'm putting such a file.

I got as far as system variables in advanced under system properties, and added c:\program files\Mozilla firefox\firefox.exe after a semi-colon and adding to the "Path" line. I don't follow the rest of your description as to what I'm creating in notepad or where I'm putting such a file.

Okulungisiwe ngu ronen1968

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17422 izisombululo 157420 izimpendulo
Kuphostiwe

If you have set the environment variable in the "Windows Control Panel -> Advanced -> Environment variables" then you can start Firefox normally, no need to make further changes.

name: MOZ_FORCE_DISABLE_E10S
value: 1
If you have set the environment variable in the "Windows Control Panel -> Advanced -> Environment variables" then you can start Firefox normally, no need to make further changes. name: MOZ_FORCE_DISABLE_E10S value: 1
Ingabe lokhu kube usizo kuwena?
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I didn't put the name and value above. I added the C:\program files\mozilla firefox\firefox.exe on the Path line in system variables. Where does this go?

name: MOZ_FORCE_DISABLE_E10S value: 1

I didn't put the name and value above. I added the C:\program files\mozilla firefox\firefox.exe on the Path line in system variables. Where does this go? name: MOZ_FORCE_DISABLE_E10S value: 1
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Never mind. Added "New" variable name and value as indicated. It worked finally. Thank you.

Never mind. Added "New" variable name and value as indicated. It worked finally. Thank you.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
motox22a 1 izisombululo 4 izimpendulo
Kuphostiwe

Hallelujah!!! I found this finally and found what I was doing wrong...I was doing the environment path as well...Now I've disabled E10s (Again) on all my systems and can once again launch EMAIL URLS and correctly open Firefox to the Website...Without the Environment Variable Edit it would just launch Firefox 68 to a Blank Page. This was the same as two years ago when they first Enabled E10s. I had disabled it at the time in ABOUT:CONFIG but when they disabled that ability several weeks ago it broke my ability to launch EMAIL CLIENT URLS correctly into Firefox 68. Now that I have E10s disabled once again I can click on URLS in my email client and launch into Firefox 68 correctly. I'm also only using about half as much memory and E10s wasn't doing anything to speed up browsing on my older systems but rather just using more memory.

Hallelujah!!! I found this finally and found what I was doing wrong...I was doing the environment path as well...Now I've disabled E10s (Again) on all my systems and can once again launch EMAIL URLS and correctly open Firefox to the Website...Without the Environment Variable Edit it would just launch Firefox 68 to a Blank Page. This was the same as two years ago when they first Enabled E10s. I had disabled it at the time in ABOUT:CONFIG but when they disabled that ability several weeks ago it broke my ability to launch EMAIL CLIENT URLS correctly into Firefox 68. Now that I have E10s disabled once again I can click on URLS in my email client and launch into Firefox 68 correctly. I'm also only using about half as much memory and E10s wasn't doing anything to speed up browsing on my older systems but rather just using more memory.

Okulungisiwe ngu motox22a

Ingabe lokhu kube usizo kuwena?
Isicaphuno
ronen1968 0 izisombululo 9 izimpendulo
Kuphostiwe

motox22a said

Hallelujah!!! I found this finally and found what I was doing wrong...

Congrats! Navigating your way around these confusing support pages and finding the right answer or issue is often at least half the battle. Glad it worked out.

''motox22a [[#answer-1242794|said]]'' <blockquote> Hallelujah!!! I found this finally and found what I was doing wrong... </blockquote> Congrats! Navigating your way around these confusing support pages and finding the right answer or issue is often at least half the battle. Glad it worked out.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.