X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Preferences locking no longer works since FF 67.0.4

Kuphostiwe

Useragent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0 FF Version: 67.0.4

Description: None of the below preferences customization methods work on a newly installed FF 67.0.4 with no prior ${HOME}/.mozilla profile (i.e. fresh install):

Also tried the following envvar's with the above methods, but with no luck:

  • SNAP_NAME=firefox
  • MOZ_LEGACY_PROFILES=1

I have tried filing a bug, but it seems creating an account at bugzilla.mozilla.org is restricted. And since I am a newbie in filing a report, I thought it would be best that I raise the issue in support.mozilla.org first.

Any assistance from the community would be greatly appreciated!

Thanks.

Useragent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0 FF Version: 67.0.4 Description: None of the below preferences customization methods work on a newly installed FF 67.0.4 with no prior ${HOME}/.mozilla profile (i.e. fresh install): * https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig * https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Enterprise_deployment_before_60 * http://kb.mozillazine.org/Locking_preferences Also tried the following envvar's with the above methods, but with no luck: * SNAP_NAME=firefox * MOZ_LEGACY_PROFILES=1 I have tried filing a bug, but it seems creating an account at bugzilla.mozilla.org is restricted. And since I am a newbie in filing a report, I thought it would be best that I raise the issue in support.mozilla.org first. Any assistance from the community would be greatly appreciated! Thanks.

Isisombululo esikhethiwe

Hi thanks for the reply. I have identified the issue to be my own fault. There was a syntax error in autoconfig.cfg which caused the custom preferences not loading. My apologies for any trouble I have caused.

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

Umnikazi wombuzo

Sorry missing a line break in my original post...

Useragent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

FF Version: 67.0.4

Sorry missing a line break in my original post... Useragent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0 FF Version: 67.0.4
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156060 izimpendulo
Kuphostiwe

Locking preferences is done locally and not in the Firefox profile folder.

Can you give more detail about what you want to achieve and what files you created with what content and in which location (file path)?


To use Autoconfig, place two files into the Firefox directory.

  • on Windows and Linux, they go in the same directory where Firefox is installed
  • on macOS, they go into the Contents/Resources directory of the Firefox.app

The autoconfig.js file that specifies to use autoconfig.cfg is placed into the "defaults\pref" directory where the channel-prefs.js file is located.

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);

The autoconfig.cfg file is placed at the top level of the Firefox directory.

  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF and not CR/LF)

See also:

Locking preferences is done locally and not in the Firefox profile folder. Can you give more detail about what you want to achieve and what files you created with what content and in which location (file path)? ---- To use Autoconfig, place two files into the Firefox directory. *on Windows and Linux, they go in the same directory where Firefox is installed *on macOS, they go into the Contents/Resources directory of the Firefox.app The <u>autoconfig.js</u> file that specifies to use autoconfig.cfg is placed into the "defaults\pref" directory where the channel-prefs.js file is located. // pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); The autoconfig.cfg file is placed at the top level of the Firefox directory. *autoconfig.cfg and autoconfig.js need to start with a comment line (//) *autoconfig.js needs to use Unix line endings (LF and not CR/LF) See also: *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks for the reply.

Sorry if I have caused any confusion.

I did exactly what you have described in "/usr/lib64/firefox" directory (for OpenSUSE) which I had done for the past versions of FF, but such method no longer works for me in FF 67.0.4. It was still working for me in FF 67.0.3.

Is there anyone be able to replicate the issue?

Steps to reproduce:

I have also repeated the above steps numerous times by trying different envvar when starting FF:

  • First time trying without any envvar by just running "firefox" without any parameter
  • Then I tried "SNAP_NAME=firefox firefox"
  • And then I tried "MOZ_LEGACY_PROFILES=1 firefox"
  • And finally I tried "MOZ_LEGACY_PROFILES=1 SNAP_NAME=firefox firefox"

In all the attempts described above, none of my customization was showing/applied in "about:config" for FF 67.0.4.

Thanks for the reply. Sorry if I have caused any confusion. I did exactly what you have described in "/usr/lib64/firefox" directory (for OpenSUSE) which I had done for the past versions of FF, but such method no longer works for me in FF 67.0.4. It was still working for me in FF 67.0.3. Is there anyone be able to replicate the issue? Steps to reproduce: * Fresh OS install * Install FF 67.0.4 to OS * Follow the steps in https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig to lock preferences (For example: For SuSE/RedHat, in /usr/lib64/firefox directory) * Start FF * Check "about:config" to check for the changes made by the customization I have also repeated the above steps numerous times by trying different envvar when starting FF: * First time trying without any envvar by just running "firefox" without any parameter * Then I tried "SNAP_NAME=firefox firefox" * And then I tried "MOZ_LEGACY_PROFILES=1 firefox" * And finally I tried "MOZ_LEGACY_PROFILES=1 SNAP_NAME=firefox firefox" In all the attempts described above, none of my customization was showing/applied in "about:config" for FF 67.0.4.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Paths:

  • /usr/lib64/firefox/defaults/pref/autoconfig.js
  • /usr/lib64/firefox/autoconfig.cfg
Paths: * /usr/lib64/firefox/defaults/pref/autoconfig.js * /usr/lib64/firefox/autoconfig.cfg
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

I can confirm also that line terminations in "/usr/lib64/firefox/defaults/pref/autoconfig.js" are "0x0a", and not "0x0d 0x0a".

Thanks.

I can confirm also that line terminations in "/usr/lib64/firefox/defaults/pref/autoconfig.js" are "0x0a", and not "0x0d 0x0a". Thanks.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156060 izimpendulo
Kuphostiwe

What is the content of the two files autoconfig.js and autoconfig.cfg ?

Did you check the Browser Console and about:policies for error messages?

What is the content of the two files autoconfig.js and autoconfig.cfg ? Did you check the Browser Console and about:policies for error messages?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Isisombululo Esikhethiwe

Hi thanks for the reply. I have identified the issue to be my own fault. There was a syntax error in autoconfig.cfg which caused the custom preferences not loading. My apologies for any trouble I have caused.

Hi thanks for the reply. I have identified the issue to be my own fault. There was a syntax error in autoconfig.cfg which caused the custom preferences not loading. My apologies for any trouble I have caused.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.