Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Favorite" bookmark sites no longer show up @top of screen,nor is line with File,Edit,View, etc. Have 72 open tabs/windows. Separate FFox (3 tabs) works..?

  • 3 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu jscher2000

more options

I have 72 open tabs in FFox, and in that environment, the upper portion of the FFox screen no longer shows my Favorite icons, nor the "Action" line (File, Edit, View, etc.). Does the (relatively large) number of tabs cause this behavior?

I also have another FFox session with only 3 open tabs, and it behaves "normally", with the Favorites line visible, and the Action line. Certainly, I can close lots of the 72 tabs to see if things will behave more normally. Can anyone confirm this (large # of tabs) is the root cause? Are there perhaps any other suggestions which might allow normal behavior with large number of open tabs? Thanks!

All Replies (3)

more options

What I referred to in my initial post as "Favorite bookmark sites" should probably be called "Bookmark Toolbar."

more options

The Bookmarks Toolbar disappearing can be caused by a problem with using "Restore Previous Session" as the startup setting, so if you restore the session automatically on the next start then try to disable this feature.

  • Options/Preferences -> General -> Startup

Once the Bookmarks Toolbar has reappeared then you can re-enable the "Restore Previous Session" startup setting and check if the Bookmarks Toolbar stays visible on next starts.

Make sure toolbars like the "Bookmarks Toolbar" and the "Menu Bar" are visible. Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • Right-click empty toolbar area -> Customize
  • "3-bar" menu button -> Customize
  • View -> Toolbars
    *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily
  • check that "Bookmarks Toolbar Items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar Items" is not on the Bookmarks Toolbar then drag it back from the Customize palette to the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window to the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button in the Customize palette window to restore the default toolbar set.

Make sure you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

When you are in Full Screen mode, hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. You can use one of these to leave Full Screen mode:

  • press the F11 key
  • click the Maximize button at the right end of the Tab bar
  • click the Full Screen button in the "3-bar" Firefox menu button drop-down list
  • right-click empty space on a toolbar and click "Exit Full Screen Mode"

You can start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Hi BILLM9, by default, Firefox only shows the tab bar and the main navigation toolbar. You can optionally turn on the menu bar (File, Edit, View...) and bookmarks toolbar. For context, I have attached a screenshot showing where the bars appear when everything is turned on. (Right-click the + button or a blank area of the toolbar to access the toolbar list.)

Usually your windows would be consistent in what bars they show. However, in the case of a popup window with custom settings, bars may be missing and impossible to add. Which is annoying. However, you probably would have noticed something like that long before accumulating 72 tabs in that window, so I suspect it's a different problem.

Does it make any difference if you switch the window between maximized and resizable (using the "middle button" on the upper right)?

Does it make any difference if you switch the window between regular and fullscreen (you can use the F11 function key to make the change)?