X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Why my FF does not remember page zoom?

Kuphostiwe

Hi, my FF does not remember page zoom when I close and reopen the page later. This used to work until some time ago. At first I thought this was some problem with addons. I tried disabling all addons but to no luck. I am running FF 60.7.1esr (deb9u1) on Debian 9.9.

Hi, my FF does not remember page zoom when I close and reopen the page later. This used to work until some time ago. At first I thought this was some problem with addons. I tried disabling all addons but to no luck. I am running FF 60.7.1esr (deb9u1) on Debian 9.9.

Isisombululo esikhethiwe

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

You can check this pref on the about:config page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an Allow exception you may want to keep
Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

Open H264 video codec provided by cisco systems - disabled.

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

Umnikazi wombuzo

Extensions I have installed:

  • CanvasBlocker
  • DecentralEyes
  • Disconnect
  • HTTPS Everywhere
  • Privacy Badger
  • uBlock origin

However, disabling all extensions does not help.

Extensions I have installed: * CanvasBlocker * DecentralEyes * Disconnect * HTTPS Everywhere * Privacy Badger * uBlock origin However, disabling all extensions does not help.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4224 izisombululo 58972 izimpendulo
Kuphostiwe

You can rename (or delete) the content-prefs.sqlite file in the Firefox profile folder to reset the page zoom for all websites.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

You can rename (or delete) the '''content-prefs.sqlite''' file in the Firefox profile folder to reset the page zoom for all websites. Type '''about:support'''<enter> in the address bar. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Locate the above file. Then rename or delete it. Restart Firefox.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

FredMcD said

You can rename (or delete) the content-prefs.sqlite file in the Firefox profile folder to reset the page zoom for all websites. Type about:support<enter> in the address bar. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Locate the above file. Then rename or delete it. Restart Firefox.

Hi FredMcD. Thank you for your help. I tried the above steps couple of times. Once with extensions and addons enabled, once with extensions and addons disabled, once in safe mode. Every time i renamed content-prefs.sqlite file in my profile folder. However, FF still does not remember page zoom.

E.g. I navigate to https://en.wikipedia.org/wiki/Main_Page . Once the page loads, I set zoom to 150% (Ctrl + mouse wheel). Then I close this tab. When I open new tab and navigate to the same page, page zoom is reset back to 100%. When I tried this on my other computers, this worked as supposed (web page in new tab opened with 150% zoom). I will try to install fresh debian on a new computer and try to see if I can replicate this problem on fresh debian install.

''FredMcD [[#answer-1232939|said]]'' <blockquote> You can rename (or delete) the '''content-prefs.sqlite''' file in the Firefox profile folder to reset the page zoom for all websites. Type '''about:support'''<enter> in the address bar. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Locate the above file. Then rename or delete it. Restart Firefox. </blockquote> Hi FredMcD. Thank you for your help. I tried the above steps couple of times. Once with extensions and addons enabled, once with extensions and addons disabled, once in safe mode. Every time i renamed content-prefs.sqlite file in my profile folder. However, FF still does not remember page zoom. E.g. I navigate to [https://en.wikipedia.org/wiki/Main_Page https://en.wikipedia.org/wiki/Main_Page] . Once the page loads, I set zoom to 150% (Ctrl + mouse wheel). Then I close this tab. When I open new tab and navigate to the same page, page zoom is reset back to 100%. When I tried this on my other computers, this worked as supposed (web page in new tab opened with 150% zoom). I will try to install fresh debian on a new computer and try to see if I can replicate this problem on fresh debian install.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

So I installed fresh debian in new virtual machine. Zoom level is remembered correctly, so the problem is specific to my setup, I guess. Any idea what might be causing this?

So I installed fresh debian in new virtual machine. Zoom level is remembered correctly, so the problem is specific to my setup, I guess. Any idea what might be causing this?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4224 izisombululo 58972 izimpendulo
Kuphostiwe

I don't know Linux so check with its support.

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

I don't know Linux so check with its support. That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

You can check this pref on the about:config page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an Allow exception you may want to keep
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode" ---- You can check this pref on the <b>about:config</b> page to see if resist fingerprinting (RFP) is enabled and if this pref is user set (bold) reset to false via the right-click context menu. *privacy.resistFingerprinting = false ---- In case you use "Clear history when Firefox closes" or otherwise clear history. *do not clear the Site Preferences *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history":<br>[X] "Clear history when Firefox closes" -> Settings *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox *clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data *clearing "Cookies" will remove all selected cookies including cookies with an Allow exception you may want to keep
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Hey cor-el, thank you for your help. privacy.resistFingerprinting = true is causing this. Turning this off solves the issue of page zoom. Thank you once more.

Hey cor-el, thank you for your help. privacy.resistFingerprinting = true is causing this. Turning this off solves the issue of page zoom. Thank you once more.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
GaijinSue 0 izisombululo 1 izimpendulo
Kuphostiwe

I checked and privacy.resistFingerprinting=false is OK in my config. I also have under History:

Firefox will "Use custom settings for history" [ ] Always use private browsing mode (unchecked)

    [x]  Remember browsing and download history
    [x]  Remember search and form history
    [  ]  Clear history when Firefox closes (unchecked)

Yet, Firefox does not remember any page zooms.

I would like to permanently set ALL page zooms to 133%.

Currently using Firefox Quantum, 68.0.2 (64 bit)

Please help.

I checked and privacy.resistFingerprinting=false is OK in my config. I also have under History: Firefox will "Use custom settings for history" [ ] Always use private browsing mode (unchecked) [x] Remember browsing and download history [x] Remember search and form history [ ] Clear history when Firefox closes (unchecked) Yet, Firefox does not remember any page zooms. I would like to permanently set ALL page zooms to 133%. Currently using Firefox Quantum, 68.0.2 (64 bit) Please help.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an Allow exception you may want to keep, use this instead:
    use Options/Preferences -> Privacy & Security
    Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"
In case you use "Clear history when Firefox closes" or otherwise clear history. *do not clear the Site Preferences *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history":<br>[X] "Clear history when Firefox closes" -> Settings *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox *clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data *clearing "Cookies" will remove all selected cookies including cookies with an Allow exception you may want to keep, use this instead:<br>use Options/Preferences -> Privacy & Security<br>Cookies and Site Data: [ ] "Delete cookies and site data when Firefox is closed"
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.