X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

How do I disable keyboard shortcuts?

Kuphostiwe

Some of the sites I visit allow me to format text with control characters (eg ctrl-b to bold the text). However, Firefox interrupts the control characters and opens the bookmark sidebar instead. How can I override this shortcut (and, perhaps, almost every shortcut)? Thank you, Ben

Some of the sites I visit allow me to format text with control characters (eg ctrl-b to bold the text). However, Firefox interrupts the control characters and opens the bookmark sidebar instead. How can I override this shortcut (and, perhaps, almost every shortcut)? Thank you, Ben
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

WestEnd 60 izisombululo 5387 izimpendulo
Kuphostiwe

What sites and screenshot of the error so others can test what your saying.

What sites and screenshot of the error so others can test what your saying.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno
Isaac Vazquez 0 izisombululo 1 izimpendulo
Kuphostiwe

It happens on any contenteditable element.

For example: MDN Contenteditable

Select some text in the editor on that page and try to bold it using cmd+b OR ctrl+b and it will open the bookmarks sidebar.

I just want to be able to disable or turn off that shortcut, so those content editors work correctly.

It happens on any contenteditable element. For example: [https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/contenteditable MDN Contenteditable] Select some text in the editor on that page and try to bold it using cmd+b OR ctrl+b and it will open the bookmarks sidebar. I just want to be able to disable or turn off that shortcut, so those content editors work correctly.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17585 izisombululo 159083 izimpendulo
Kuphostiwe

Firefox 65 changed how key events on non-printing keys are sent to websites. Previously, a site would get a "keydown" and a "keypress", but starting in Firefox 65, it only got a "keydown".

  • dom.keyboardevent.keypress.hack.dispatch_non_printable_keys = "comma separated list of host-names"
Firefox 65 changed how key events on non-printing keys are sent to websites. Previously, a site would get a "keydown" and a "keypress", but starting in Firefox 65, it only got a "keydown". *dom.keyboardevent.keypress.hack.dispatch_non_printable_keys = "comma separated list of host-names" *[https://www.fxsitecompat.dev/en-CA/docs/2018/non-printable-keys-no-longer-fire-keypress-event/]

Okulungisiwe ngu cor-el

Ingabe lokhu kube usizo kuwena?
Isicaphuno
Azur 0 izisombululo 5 izimpendulo
Kuphostiwe

CTRL+i also opens bookmarks toolbar (instead of making text italic). I tried installing Shortkeys (addon) and disabled CTRL+b and CTRL+i, but it doesn't work, firefox still intercepts the keypress and opens the effing bookmarks bar.

CTRL+i also opens bookmarks toolbar (instead of making text italic). I tried installing Shortkeys (addon) and disabled CTRL+b and CTRL+i, but it doesn't work, firefox still intercepts the keypress and opens the effing bookmarks bar.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Alison N. 0 izisombululo 1 izimpendulo
Kuphostiwe

This happens to me on Mac with Command–[comma] on Google Drive, which should insert a subscript in the document, but instead is intercepted by Firefox which opens my Preferences.

Infuriatingly, there does not appear to be any way in the Preferences tab which I keep opening to disable keystrokes, and on top of that, this command isn't even listed in any of the lists I can find of keyboard shortcuts for Firefox in the first place (e.g. https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly).

This happens to me on Mac with Command–[comma] on Google Drive, which should insert a subscript in the document, but instead is intercepted by Firefox which opens my Preferences. Infuriatingly, there does not appear to be any way in the Preferences tab which I keep opening to disable keystrokes, and on top of that, this command isn't even listed in any of the lists I can find of keyboard shortcuts for Firefox in the first place (e.g. https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly).
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.